diff mbox

[1/2] systemd: add option to enable compatibility libs

Message ID 1397467537-22766-2-git-send-email-eric.le.bihan.dev@free.fr
State Accepted
Headers show

Commit Message

Eric Le Bihan April 14, 2014, 9:25 a.m. UTC
Since systemd 209, some libraries have been merged into libsystemd.so:

 - libsystemd-daemon.so
 - libsystemd-id128.so
 - libsystemd-journal.so
 - libsystemd-login.so

A new configuration menu entry has been added to enable the installation
of compatibility pkg-config files, so that programs that depend on them
can still be built.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
---
 package/systemd/Config.in  | 13 +++++++++++++
 package/systemd/systemd.mk |  4 ++++
 2 files changed, 17 insertions(+)

Comments

Yann E. MORIN April 14, 2014, 9:39 a.m. UTC | #1
Eric, All,

On 2014-04-14 11:25 +0200, Eric Le Bihan spake thusly:
> Since systemd 209, some libraries have been merged into libsystemd.so:
> 
>  - libsystemd-daemon.so
>  - libsystemd-id128.so
>  - libsystemd-journal.so
>  - libsystemd-login.so
> 
> A new configuration menu entry has been added to enable the installation
> of compatibility pkg-config files, so that programs that depend on them
> can still be built.
> 
> Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

But see small comment below...

[--SNIP--]
> diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
> index ecedfce..4fa0e89 100644
> --- a/package/systemd/systemd.mk
> +++ b/package/systemd/systemd.mk
> @@ -46,6 +46,10 @@ SYSTEMD_CONF_OPT += \
>  	--disable-dbus \
>  	--without-python
>  
> +ifeq ($(BR2_PACKAGE_SYSTEMD_COMPAT),y)
> +SYSTEMD_CONF_OPT += --enable-compat-libs
> +endif

I guess the default in systemd's ./configure is --disable-compat-libs.
But I'd prefer we enforce that with an else-block:

    ifeq ($(BR2_PACKAGE_SYSTEMD_COMPAT),y)
    SYSTEMD_CONF_OPT += --enable-compat-libs
    else
    SYSTEMD_CONF_OPT += --disable-compat-libs
    endif

I know Peter does not really mind in that case, so I won't complain much
if this goes in as is. ;-)

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/systemd/Config.in b/package/systemd/Config.in
index 095fee0..f10637a 100644
--- a/package/systemd/Config.in
+++ b/package/systemd/Config.in
@@ -92,4 +92,17 @@  config BR2_PACKAGE_SYSTEMD_NETWORKD
 
 	  http://www.freedesktop.org/software/systemd/man/systemd-networkd.html
 
+config BR2_PACKAGE_SYSTEMD_COMPAT
+	bool "enable compatibility libraries"
+	help
+	  Since systemd 209, the following libraries have been merged into
+	  libsystemd.so:
+
+	  - libsystemd-daemon
+	  - libsystemd-id128
+	  - libsystemd-journal
+	  - libsystemd-login
+
+	  This option enables the installation of compatibility *.pc files.
+
 endif
diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index ecedfce..4fa0e89 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -46,6 +46,10 @@  SYSTEMD_CONF_OPT += \
 	--disable-dbus \
 	--without-python
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_COMPAT),y)
+SYSTEMD_CONF_OPT += --enable-compat-libs
+endif
+
 ifeq ($(BR2_PACKAGE_ACL),y)
 SYSTEMD_CONF_OPT += --enable-acl
 SYSTEMD_DEPENDENCIES += acl