diff mbox

[v2,2/2] mutt: Add options for imap/pop3 support, enable optional iconv/OpenSSL support

Message ID 1397391257-12882-2-git-send-email-bernd.kuhls@t-online.de
State Accepted
Headers show

Commit Message

Bernd Kuhls April 13, 2014, 12:14 p.m. UTC
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
v2: - do not disable iconv support for toolchains with locale support (Thomas)
    - optimize if-clause for OpenSSL support (Thomas)

 package/mutt/Config.in |   16 +++++++++++++++-
 package/mutt/mutt.mk   |   31 ++++++++++++++++++++++++++++++-
 2 files changed, 45 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni April 14, 2014, 9:37 p.m. UTC | #1
Dear Bernd Kuhls,

On Sun, 13 Apr 2014 14:14:17 +0200, Bernd Kuhls wrote:
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
> v2: - do not disable iconv support for toolchains with locale support (Thomas)
>     - optimize if-clause for OpenSSL support (Thomas)

Applied, thanks. However, I've kept a 'config BR2_PACKAGE_MUTT' and not
switched to a 'menuconfig BR2_PACKAGE_MUTT'. There are not enough
sub-options for now to warrant a menuconfig for mutt I believe.

Thomas
diff mbox

Patch

diff --git a/package/mutt/Config.in b/package/mutt/Config.in
index 430eeb8..372c137 100644
--- a/package/mutt/Config.in
+++ b/package/mutt/Config.in
@@ -1,4 +1,4 @@ 
-config BR2_PACKAGE_MUTT
+menuconfig BR2_PACKAGE_MUTT
 	bool "mutt"
 	depends on BR2_USE_WCHAR
 	depends on BR2_USE_MMU # fork()
@@ -8,6 +8,20 @@  config BR2_PACKAGE_MUTT
 
 	  http://www.mutt.org/
 
+if BR2_PACKAGE_MUTT
+
+config BR2_PACKAGE_MUTT_IMAP
+	bool "imap"
+	help
+	  IMAP support
+
+config BR2_PACKAGE_MUTT_POP3
+	bool "pop3"
+	help
+	  POP3 support
+
+endif # BR2_PACKAGE_MUTT
+
 comment "mutt needs a toolchain w/ wchar"
 	depends on BR2_USE_MMU
 	depends on !BR2_USE_WCHAR
diff --git a/package/mutt/mutt.mk b/package/mutt/mutt.mk
index 5aa18eb..633b2af 100644
--- a/package/mutt/mutt.mk
+++ b/package/mutt/mutt.mk
@@ -9,7 +9,36 @@  MUTT_SITE = http://downloads.sourceforge.net/project/mutt/mutt
 MUTT_LICENSE = GPLv2+
 MUTT_LICENSE_FILES = GPL
 MUTT_DEPENDENCIES = ncurses
-MUTT_CONF_OPT = --disable-iconv --disable-smtp
+MUTT_CONF_OPT = --disable-smtp
 MUTT_AUTORECONF = YES
 
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+MUTT_DEPENDENCIES += libiconv
+MUTT_CONF_OPT += --enable-iconv
+endif
+
+ifeq ($(BR2_PACKAGE_MUTT_IMAP),y)
+MUTT_CONF_OPT += --enable-imap
+else
+MUTT_CONF_OPT += --disable-imap
+endif
+
+ifeq ($(BR2_PACKAGE_MUTT_POP3),y)
+MUTT_CONF_OPT += --enable-pop
+else
+MUTT_CONF_OPT += --disable-pop
+endif
+
+# SSL support is only used by imap or pop3 module
+ifneq ($(BR2_PACKAGET_MUTT_IMAP)$(BR2_PACKAGE_MUTT_POP3),)
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+MUTT_DEPENDENCIES += openssl
+MUTT_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr
+else
+MUTT_CONF_OPT += --without-ssl
+endif
+else
+MUTT_CONF_OPT += --without-ssl
+endif
+
 $(eval $(autotools-package))