diff mbox

[1/1] libuci: Disable lua binding on no mmu

Message ID 1396903421-4110-1-git-send-email-romain.naour@openwide.fr
State Accepted
Commit 32e06911640a2f18cb29288e0ab10c6366ee3d19
Headers show

Commit Message

Romain Naour April 7, 2014, 8:43 p.m. UTC
Same error as in libubox package.
http://autobuild.buildroot.net/results/1a5/1a5c50f8ca0ae70c1e0d3733765f521790b97a30/build-end.log

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
---
 package/libuci/libuci.mk | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Yann E. MORIN April 7, 2014, 8:46 p.m. UTC | #1
Romain, All,

On 2014-04-07 22:43 +0200, Romain Naour spake thusly:
> Same error as in libubox package.
> http://autobuild.buildroot.net/results/1a5/1a5c50f8ca0ae70c1e0d3733765f521790b97a30/build-end.log
> 
> Signed-off-by: Romain Naour <romain.naour@openwide.fr>

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/libuci/libuci.mk | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/package/libuci/libuci.mk b/package/libuci/libuci.mk
> index a7d3a80..adc7bce 100644
> --- a/package/libuci/libuci.mk
> +++ b/package/libuci/libuci.mk
> @@ -10,14 +10,12 @@ LIBUCI_LICENSE = LGPLv2.1
>  LIBUCI_INSTALL_STAGING = YES
>  LIBUCI_DEPENDENCIES = libubox
>  
> -ifeq ($(BR2_USE_MMU),y) # fork()
> -ifeq ($(BR2_PACKAGE_LUA_5_1),y)
> +ifeq ($(BR2_USE_MMU)$(BR2_PACKAGE_LUA_5_1),yy)
>  LIBUCI_DEPENDENCIES += lua
>  LIBUCI_CONF_OPT += -DLUAPATH=$(STAGING_DIR)/usr/lib/lua/5.1 \
>  	-DLUA_CFLAGS=-I$(STAGING_DIR)/usr/include
>  else
>  LIBUCI_CONF_OPT += -DBUILD_LUA:BOOL=OFF
>  endif
> -endif # MMU
>  
>  $(eval $(cmake-package))
> -- 
> 1.9.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard April 7, 2014, 10:56 p.m. UTC | #2
>>>>> "Romain" == Romain Naour <romain.naour@openwide.fr> writes:

 > Same error as in libubox package.
 > http://autobuild.buildroot.net/results/1a5/1a5c50f8ca0ae70c1e0d3733765f521790b97a30/build-end.log

 > Signed-off-by: Romain Naour <romain.naour@openwide.fr>

Committed, thanks.
diff mbox

Patch

diff --git a/package/libuci/libuci.mk b/package/libuci/libuci.mk
index a7d3a80..adc7bce 100644
--- a/package/libuci/libuci.mk
+++ b/package/libuci/libuci.mk
@@ -10,14 +10,12 @@  LIBUCI_LICENSE = LGPLv2.1
 LIBUCI_INSTALL_STAGING = YES
 LIBUCI_DEPENDENCIES = libubox
 
-ifeq ($(BR2_USE_MMU),y) # fork()
-ifeq ($(BR2_PACKAGE_LUA_5_1),y)
+ifeq ($(BR2_USE_MMU)$(BR2_PACKAGE_LUA_5_1),yy)
 LIBUCI_DEPENDENCIES += lua
 LIBUCI_CONF_OPT += -DLUAPATH=$(STAGING_DIR)/usr/lib/lua/5.1 \
 	-DLUA_CFLAGS=-I$(STAGING_DIR)/usr/include
 else
 LIBUCI_CONF_OPT += -DBUILD_LUA:BOOL=OFF
 endif
-endif # MMU
 
 $(eval $(cmake-package))