diff mbox

[2/2] package/zile: add Zile is Lossy Emacs editor

Message ID 1396868422-5757-3-git-send-email-alex.bennee@linaro.org
State Superseded
Headers show

Commit Message

Alex Bennée April 7, 2014, 11 a.m. UTC
This is a lightweight Emacs clone useful for embedded systems. I nabbed
the help2man disable patch from OpenEmbedded.

Signed-off-by: Alex Bennée <alex.bennee@linaro.org>
Signed-off-by: Alex Bennée <alex@bennee.com>
---
 package/Config.in                  |  1 +
 package/zile/Config.in             | 14 ++++++++++++++
 package/zile/remove-help2man.patch | 28 ++++++++++++++++++++++++++++
 package/zile/zile.mk               | 13 +++++++++++++
 4 files changed, 56 insertions(+)
 create mode 100644 package/zile/Config.in
 create mode 100644 package/zile/remove-help2man.patch
 create mode 100644 package/zile/zile.mk

Comments

Yann E. MORIN April 7, 2014, 8:33 p.m. UTC | #1
Alex, All,

On 2014-04-07 12:00 +0100, Alex Bennée spake thusly:
> This is a lightweight Emacs clone useful for embedded systems. I nabbed
> the help2man disable patch from OpenEmbedded.
[--SNIP--]
> diff --git a/package/zile/Config.in b/package/zile/Config.in
> new file mode 100644
> index 0000000..29fb0fc
> --- /dev/null
> +++ b/package/zile/Config.in
> @@ -0,0 +1,14 @@
> +config BR2_PACKAGE_ZILE
> +	bool "zile"
> +        select BR2_PACKAGE_LIBGC
> +	depends on BR2_USE_MMU # fork()
> +	help
> +	  Zile is Lossy Emacs
> +
> +          GNU Zile (Zile Is Lossy Emacs) is a lightweight Emacs clone. Every
> +          Emacs user should feel at home with Zile. Zile is aimed at small
> +          footprint systems (a typical binary is about 100Kb) and quick editing
> +          sessions (it starts up and shuts down instantly).
> +
> +	  http://www.gnu.org/software/zile/

There is space damage above:
  - use one tab in front of options parameters (type, select, depends...)
  - use one tab and two spaces in front of the help text

The above mixes spaces and tabs.

> diff --git a/package/zile/remove-help2man.patch b/package/zile/remove-help2man.patch
> new file mode 100644
> index 0000000..c1a63f4
> --- /dev/null
> +++ b/package/zile/remove-help2man.patch
> @@ -0,0 +1,28 @@
> +Upstream-Status: Inappropriate [configuration]

Please add a complete commit log, and your SoB lines too, in this patch.

Could you also add a pointer to the upstream refusal (bug -tracker or ML
archive), please?

> diff --git a/package/zile/zile.mk b/package/zile/zile.mk
> new file mode 100644
> index 0000000..024595c
> --- /dev/null
> +++ b/package/zile/zile.mk
> @@ -0,0 +1,13 @@
> +################################################################################
> +#
> +# Zile
> +#
> +################################################################################
> +
> +ZILE_VERSION = 2.4.11
> +ZILE_SITE = http://ftp.gnu.org/gnu/zile/
> +ZILE_LICENSE = GPLv1+
> +ZILE_LICENSE_FILES = COPYING
> +ZILE_CONF_OPT += --without-help2man

In the previous patch, you added libgc, stating that it was a dependency
of Zile, but you forgot to add it here.

Probably it is working for you since libgz sorts alphabetically before
zile, but that's not guaranteed with parallel builds.

Regards,
Yann E. MORIN.
Alex Bennée April 8, 2014, 10:19 a.m. UTC | #2
Yann E. MORIN <yann.morin.1998@free.fr> writes:

> Alex, All,
>
> On 2014-04-07 12:00 +0100, Alex Bennée spake thusly:
<snip>
>> +	  http://www.gnu.org/software/zile/
>
> There is space damage above:
>   - use one tab in front of options parameters (type, select, depends...)
>   - use one tab and two spaces in front of the help text
>
> The above mixes spaces and tabs.

I'll get that cleaned up

>> diff --git a/package/zile/remove-help2man.patch b/package/zile/remove-help2man.patch
>> new file mode 100644
>> index 0000000..c1a63f4
>> --- /dev/null
>> +++ b/package/zile/remove-help2man.patch
>> @@ -0,0 +1,28 @@
>> +Upstream-Status: Inappropriate [configuration]
>
> Please add a complete commit log, and your SoB lines too, in this patch.
>
> Could you also add a pointer to the upstream refusal (bug -tracker or ML
> archive), please?

I'll see if I can find it. 

>
>> diff --git a/package/zile/zile.mk b/package/zile/zile.mk
>> new file mode 100644
>> index 0000000..024595c
>> --- /dev/null
>> +++ b/package/zile/zile.mk
>> @@ -0,0 +1,13 @@
>> +################################################################################
>> +#
>> +# Zile
>> +#
>> +################################################################################
>> +
>> +ZILE_VERSION = 2.4.11
>> +ZILE_SITE = http://ftp.gnu.org/gnu/zile/
>> +ZILE_LICENSE = GPLv1+
>> +ZILE_LICENSE_FILES = COPYING
>> +ZILE_CONF_OPT += --without-help2man
>
> In the previous patch, you added libgc, stating that it was a dependency
> of Zile, but you forgot to add it here.

Ahh I thought it was enforced by the Config.in select but of course you
need to ensure it's built as well. I'll fix that up.

>
> Probably it is working for you since libgz sorts alphabetically before
> zile, but that's not guaranteed with parallel builds.
>
> Regards,
> Yann E. MORIN.
Yann E. MORIN April 8, 2014, 4:16 p.m. UTC | #3
Alex, All,

On 2014-04-08 11:19 +0100, Alex Bennée spake thusly:
> Yann E. MORIN <yann.morin.1998@free.fr> writes:
[--SNIP--]
> >> diff --git a/package/zile/zile.mk b/package/zile/zile.mk
> >> new file mode 100644
> >> index 0000000..024595c
> >> --- /dev/null
> >> +++ b/package/zile/zile.mk
> >> @@ -0,0 +1,13 @@
> >> +################################################################################
> >> +#
> >> +# Zile
> >> +#
> >> +################################################################################
> >> +
> >> +ZILE_VERSION = 2.4.11
> >> +ZILE_SITE = http://ftp.gnu.org/gnu/zile/
> >> +ZILE_LICENSE = GPLv1+
> >> +ZILE_LICENSE_FILES = COPYING
> >> +ZILE_CONF_OPT += --without-help2man
> >
> > In the previous patch, you added libgc, stating that it was a dependency
> > of Zile, but you forgot to add it here.
> 
> Ahh I thought it was enforced by the Config.in select but of course you
> need to ensure it's built as well. I'll fix that up.

THere are two types of dependencies:
  - build-time dependencies, and
  - run-time dependencies.

The run-time dependencies (eg. I need *that* program to be present) are
handled purely in the Config.in.

The build-time dependencies (eg. I need to link to *that* library) are
handled both in Config.in and the .mk.

The dependencies in Config.in will ensure that the package is present in
the target, while the dependencies in the .mk guarantee the build order.

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 5cdf72b..99b0b96 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1115,6 +1115,7 @@  source "package/uemacs/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/vim/Config.in"
 endif
+source "package/zile/Config.in"
 endmenu
 
 endmenu
diff --git a/package/zile/Config.in b/package/zile/Config.in
new file mode 100644
index 0000000..29fb0fc
--- /dev/null
+++ b/package/zile/Config.in
@@ -0,0 +1,14 @@ 
+config BR2_PACKAGE_ZILE
+	bool "zile"
+        select BR2_PACKAGE_LIBGC
+	depends on BR2_USE_MMU # fork()
+	help
+	  Zile is Lossy Emacs
+
+          GNU Zile (Zile Is Lossy Emacs) is a lightweight Emacs clone. Every
+          Emacs user should feel at home with Zile. Zile is aimed at small
+          footprint systems (a typical binary is about 100Kb) and quick editing
+          sessions (it starts up and shuts down instantly).
+
+	  http://www.gnu.org/software/zile/
+
diff --git a/package/zile/remove-help2man.patch b/package/zile/remove-help2man.patch
new file mode 100644
index 0000000..c1a63f4
--- /dev/null
+++ b/package/zile/remove-help2man.patch
@@ -0,0 +1,28 @@ 
+Upstream-Status: Inappropriate [configuration]
+
+diff --git a/Makefile.am b/Makefile.am
+index 54bc59f..46c2650 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -36,7 +36,6 @@ PERL_BUILDTIME =					\
+ 
+ EXTRA_DIST =						\
+ 	FAQ						\
+-	build-aux/zile-help2man-wrapper			\
+ 	$(PERL_BUILDTIME)
+ 
+ doc_DATA = AUTHORS FAQ NEWS
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index 639f59c..8c5123e 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -33,9 +33,3 @@ doc/zile.1: $(srcdir)/doc/zile.1.in doc/Makefile.am config.status
+ 	$(edit) $(abs_srcdir)/doc/zile.1.in >$@.tmp
+ 	mv $@.tmp $@
+ 
+-$(srcdir)/doc/zile.1.in: doc/man-extras build-aux/zile-help2man-wrapper configure.ac $(builddir)/src/zile$(EXEEXT)
+-	@test -d doc || mkdir doc
+-## Exit gracefully if zile.1.in is not writeable, such as during distcheck!
+-	$(AM_V_GEN)if ( touch $@.w && rm -f $@.w; ) >/dev/null 2>&1; then \
+-	  $(srcdir)/build-aux/missing --run $(HELP2MAN) --output=$@ --no-info --name="Zile Is Lossy Emacs" --include $(srcdir)/doc/man-extras $(srcdir)/build-aux/zile-help2man-wrapper; \
+-	fi
diff --git a/package/zile/zile.mk b/package/zile/zile.mk
new file mode 100644
index 0000000..024595c
--- /dev/null
+++ b/package/zile/zile.mk
@@ -0,0 +1,13 @@ 
+################################################################################
+#
+# Zile
+#
+################################################################################
+
+ZILE_VERSION = 2.4.11
+ZILE_SITE = http://ftp.gnu.org/gnu/zile/
+ZILE_LICENSE = GPLv1+
+ZILE_LICENSE_FILES = COPYING
+ZILE_CONF_OPT += --without-help2man
+
+$(eval $(autotools-package))