diff mbox

[4/4] mysql: host-mysql depends on host-zlib

Message ID 1393944603-3104-4-git-send-email-kuyurix@gmail.com
State Accepted
Headers show

Commit Message

Marcelo Gutiérrez(UTN/FRH) March 4, 2014, 2:50 p.m. UTC
Signed-off-by: Marcelo Gutiérrez <kuyurix@gmail.com>
---
 package/mysql/mysql.mk |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni March 4, 2014, 5:52 p.m. UTC | #1
Dear Marcelo Gutiérrez,

On Tue,  4 Mar 2014 14:50:03 +0000, Marcelo Gutiérrez wrote:
> 
> Signed-off-by: Marcelo Gutiérrez <kuyurix@gmail.com>
> ---
>  package/mysql/mysql.mk |    2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/mysql/mysql.mk b/package/mysql/mysql.mk
> index c35fef5..9a8612b 100644
> --- a/package/mysql/mysql.mk
> +++ b/package/mysql/mysql.mk
> @@ -34,7 +34,7 @@ MYSQL_CONF_OPT = \
>  
>  ifeq ($(BR2_PACKAGE_MYSQL_SERVER),y)
>  MYSQL_DEPENDENCIES += host-mysql host-bison
> -HOST_MYSQL_DEPENDENCIES =
> +HOST_MYSQL_DEPENDENCIES = host-zlib

Hum, why? I have built the mysql server successfully without this
patch. Can you give some details about why this is needed?

And by the way, thanks a lot for the patches!

Thomas
Marcelo Gutiérrez(UTN/FRH) March 4, 2014, 6:30 p.m. UTC | #2
Hi Thomas, all.

Hum, why? I have built the mysql server successfully without this
> patch. Can you give some details about why this is needed?
>

I downloaded a fresh "git buildroot" and I've only selected MySQL client
and  MySQL server.

When it was compiling "host-mysql", could not find "libzlt.la" library.

So I've added host-zlib and that issue completely gone.

Regards,
Marcelo.
Marcelo Gutiérrez(UTN/FRH) March 4, 2014, 8:03 p.m. UTC | #3
Hi Thomas,


> I downloaded a fresh "git buildroot" and I've only selected MySQL client
> and  MySQL server.
>
> When it was compiling "host-mysql", could not find "libzlt.la" library.
>
> So I've added host-zlib and that issue completely gone.
>


More details about host-zlib dependency....

I'm using a Debian distro and if remove "zlib1g-dev" package. I got the
following error message without host-zlib.

libtool: link: cannot find the library `../zlib/libzlt.la' or unhandled
argument `../zlib/libzlt.la'

Therefore, zlib1g-dev makes the difference.

Regards,
Marcelo
Thomas Petazzoni July 21, 2014, 10:11 p.m. UTC | #4
Dear Marcelo Gutiérrez,

On Tue,  4 Mar 2014 14:50:03 +0000, Marcelo Gutiérrez wrote:
> 
> Signed-off-by: Marcelo Gutiérrez <kuyurix@gmail.com>
> ---
>  package/mysql/mysql.mk |    2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied, thanks. I've added a reference to the autobuilder issue being
fixed by this commit. Next time, make sure to include such a reference.
Thanks a lot!

Thomas
diff mbox

Patch

diff --git a/package/mysql/mysql.mk b/package/mysql/mysql.mk
index c35fef5..9a8612b 100644
--- a/package/mysql/mysql.mk
+++ b/package/mysql/mysql.mk
@@ -34,7 +34,7 @@  MYSQL_CONF_OPT = \
 
 ifeq ($(BR2_PACKAGE_MYSQL_SERVER),y)
 MYSQL_DEPENDENCIES += host-mysql host-bison
-HOST_MYSQL_DEPENDENCIES =
+HOST_MYSQL_DEPENDENCIES = host-zlib
 
 HOST_MYSQL_CONF_OPT = \
 	--with-embedded-server