diff mbox

[2/4] mysql: add mysql user

Message ID 1393944603-3104-2-git-send-email-kuyurix@gmail.com
State Accepted
Headers show

Commit Message

Marcelo Gutiérrez(UTN/FRH) March 4, 2014, 2:50 p.m. UTC
Signed-off-by: Marcelo Gutiérrez <kuyurix@gmail.com>
---
 package/mysql/mysql.mk |    4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni July 21, 2014, 10:10 p.m. UTC | #1
Dear Marcelo Gutiérrez,

On Tue,  4 Mar 2014 14:50:01 +0000, Marcelo Gutiérrez wrote:

> +define MYSQL_USERS
> +	mysql -1 nogroup -1 = /var/mysql /bin/sh -
> +endef

I've changed = to * to generate an user that cannot log in. I've
changed /bin/sh to - because there's no point in having a shell
defined. And I've added a description of the user.

Applied with those changes, thanks.

Thomas
diff mbox

Patch

diff --git a/package/mysql/mysql.mk b/package/mysql/mysql.mk
index eb3a70e..3b69bdc 100644
--- a/package/mysql/mysql.mk
+++ b/package/mysql/mysql.mk
@@ -79,6 +79,10 @@  define HOST_MYSQL_INSTALL_CMDS
 	$(INSTALL) -m 0755  $(@D)/sql/gen_lex_hash  $(HOST_DIR)/usr/bin/
 endef
 
+define MYSQL_USERS
+	mysql -1 nogroup -1 = /var/mysql /bin/sh -
+endef
+
 define MYSQL_ADD_FOLDER
 	$(INSTALL) -d $(TARGET_DIR)/var/mysql
 endef