diff mbox

[v5,1/4] bustle: use TARGET_MAKE_ENV instead of setting PATH in the make environment

Message ID 1393703951-7059-2-git-send-email-s.martin49@gmail.com
State Accepted
Headers show

Commit Message

Samuel Martin March 1, 2014, 7:59 p.m. UTC
TARGET_MAKE_ENV already contains the PATH definition among other useful
variables.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

---
changes v4 -> v5:
- rebase
- add Acked-by tag

changes v3 -> v4:
- add this change to the series (ThomasP)
---
 package/bustle/bustle.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni March 1, 2014, 10:47 p.m. UTC | #1
Dear Samuel Martin,

On Sat,  1 Mar 2014 20:59:08 +0100, Samuel Martin wrote:
> TARGET_MAKE_ENV already contains the PATH definition among other useful
> variables.
> 
> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

Applied, thanks.

For the other patches, I'll wait for some other people to do some
review.

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/bustle/bustle.mk b/package/bustle/bustle.mk
index 2330c08..7bc3e97 100644
--- a/package/bustle/bustle.mk
+++ b/package/bustle/bustle.mk
@@ -11,7 +11,7 @@  BUSTLE_LICENSE_FILES = LICENSE
 BUSTLE_DEPENDENCIES = libglib2 libpcap host-pkgconf
 
 define BUSTLE_BUILD_CMDS
-	PATH=$(TARGET_PATH) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
 		PCAP_FLAGS='-lpcap' -C $(@D) dist/build/bustle-pcap
 endef