diff mbox

[03/11] opencv: add jasper support

Message ID 1392588004-13317-4-git-send-email-s.martin49@gmail.com
State Superseded
Headers show

Commit Message

Samuel Martin Feb. 16, 2014, 9:59 p.m. UTC
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
---
 package/opencv/Config.in | 6 ++++++
 package/opencv/opencv.mk | 8 +++++++-
 2 files changed, 13 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN March 5, 2014, 10:59 p.m. UTC | #1
Samuel, All,

On 2014-02-16 22:59 +0100, Samuel Martin spake thusly:
> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
> ---
>  package/opencv/Config.in | 6 ++++++
>  package/opencv/opencv.mk | 8 +++++++-
>  2 files changed, 13 insertions(+), 1 deletion(-)
> 
> diff --git a/package/opencv/Config.in b/package/opencv/Config.in
> index 2acbe19..73f03e1 100644
> --- a/package/opencv/Config.in
> +++ b/package/opencv/Config.in
> @@ -158,6 +158,12 @@ config BR2_PACKAGE_OPENCV_WITH_GTK
>  	depends on BR2_INSTALL_LIBSTDCPP
>  	select BR2_PACKAGE_LIBGTK2
>  
> +config BR2_PACKAGE_OPENCV_WITH_JASPER
> +	bool "jasper (jpeg 2000) support"
> +	select BR2_PACKAGE_JASPER
> +	help
> +	  Use shared libjasper from the target system.

What do you mean by "from the target system?"

I would expect to read something like:

    config BR2_PACKAGE_OPENCV_WITH_JASPER
        bool "jpeg2000 support"
        select BR2_PACKAGE_JASPER
        help
          Use libjasper to provide support for jpeg2000.

Regards,
Yann E. MORIN.
Samuel Martin March 5, 2014, 11:08 p.m. UTC | #2
Yann, all,

On Wed, Mar 5, 2014 at 11:59 PM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> Samuel, All,
>
> On 2014-02-16 22:59 +0100, Samuel Martin spake thusly:
>> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
>> ---
>>  package/opencv/Config.in | 6 ++++++
>>  package/opencv/opencv.mk | 8 +++++++-
>>  2 files changed, 13 insertions(+), 1 deletion(-)
>>
>> diff --git a/package/opencv/Config.in b/package/opencv/Config.in
>> index 2acbe19..73f03e1 100644
>> --- a/package/opencv/Config.in
>> +++ b/package/opencv/Config.in
>> @@ -158,6 +158,12 @@ config BR2_PACKAGE_OPENCV_WITH_GTK
>>       depends on BR2_INSTALL_LIBSTDCPP
>>       select BR2_PACKAGE_LIBGTK2
>>
>> +config BR2_PACKAGE_OPENCV_WITH_JASPER
>> +     bool "jasper (jpeg 2000) support"
>> +     select BR2_PACKAGE_JASPER
>> +     help
>> +       Use shared libjasper from the target system.
>
> What do you mean by "from the target system?"

OpenCV comes with many libs in its 3rdparty directory (ffmpeg, jinja2,
libjasper, libjpeg, libpng, libtiff, libwebp, openexr, tbb, zlib), and
can build these, or use those provided by the system or disabling
their support.

When I integrated opencv in BR for the first, it was requested to me
to only use the libs provided by the system. I stick to this ;-)

>
> I would expect to read something like:
>
>     config BR2_PACKAGE_OPENCV_WITH_JASPER
>         bool "jpeg2000 support"
>         select BR2_PACKAGE_JASPER
>         help
>           Use libjasper to provide support for jpeg2000.
>

Regards,
Yann E. MORIN March 5, 2014, 11:27 p.m. UTC | #3
Samuel, All,

On 2014-03-06 00:08 +0100, Samuel Martin spake thusly:
> On Wed, Mar 5, 2014 at 11:59 PM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> > Samuel, All,
> >
> > On 2014-02-16 22:59 +0100, Samuel Martin spake thusly:
> >> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
> >> ---
> >>  package/opencv/Config.in | 6 ++++++
> >>  package/opencv/opencv.mk | 8 +++++++-
> >>  2 files changed, 13 insertions(+), 1 deletion(-)
> >>
> >> diff --git a/package/opencv/Config.in b/package/opencv/Config.in
> >> index 2acbe19..73f03e1 100644
> >> --- a/package/opencv/Config.in
> >> +++ b/package/opencv/Config.in
> >> @@ -158,6 +158,12 @@ config BR2_PACKAGE_OPENCV_WITH_GTK
> >>       depends on BR2_INSTALL_LIBSTDCPP
> >>       select BR2_PACKAGE_LIBGTK2
> >>
> >> +config BR2_PACKAGE_OPENCV_WITH_JASPER
> >> +     bool "jasper (jpeg 2000) support"
> >> +     select BR2_PACKAGE_JASPER
> >> +     help
> >> +       Use shared libjasper from the target system.
> >
> > What do you mean by "from the target system?"
> 
> OpenCV comes with many libs in its 3rdparty directory (ffmpeg, jinja2,
> libjasper, libjpeg, libpng, libtiff, libwebp, openexr, tbb, zlib), and
> can build these, or use those provided by the system or disabling
> their support.
> 
> When I integrated opencv in BR for the first, it was requested to me
> to only use the libs provided by the system. I stick to this ;-)

Ah, OK I understand. But then, the help text is not clear enough.

I would expect to read something like:

    config BR2_PACKAGE_OPENCV_WITH_JASPER
        bool "jpeg2000 support"
        select BR2_PACKAGE_JASPER
        help
          Use the package 'libjasper' to provide support for jpeg2000.

          The copy of libjasper bundled in openCV is not used.

But do we even want to state this in the help text?

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/opencv/Config.in b/package/opencv/Config.in
index 2acbe19..73f03e1 100644
--- a/package/opencv/Config.in
+++ b/package/opencv/Config.in
@@ -158,6 +158,12 @@  config BR2_PACKAGE_OPENCV_WITH_GTK
 	depends on BR2_INSTALL_LIBSTDCPP
 	select BR2_PACKAGE_LIBGTK2
 
+config BR2_PACKAGE_OPENCV_WITH_JASPER
+	bool "jasper (jpeg 2000) support"
+	select BR2_PACKAGE_JASPER
+	help
+	  Use shared libjasper from the target system.
+
 config BR2_PACKAGE_OPENCV_WITH_JPEG
 	bool "jpeg support"
 	select BR2_PACKAGE_JPEG
diff --git a/package/opencv/opencv.mk b/package/opencv/opencv.mk
index fb56769..ff11f1c 100644
--- a/package/opencv/opencv.mk
+++ b/package/opencv/opencv.mk
@@ -149,7 +149,6 @@  OPENCV_CONF_OPT += \
 	-DWITH_1394=OFF           \
 	-DWITH_EIGEN=OFF          \
 	-DWITH_IMAGEIO=OFF        \
-	-DWITH_JASPER=OFF         \
 	-DWITH_OPENCL=OFF         \
 	-DWITH_OPENEXR=OFF        \
 	-DWITH_OPENGL=OFF         \
@@ -181,6 +180,13 @@  else
 OPENCV_CONF_OPT += -DWITH_GTK=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_OPENCV_WITH_JASPER),y)
+OPENCV_CONF_OPT += -DWITH_JASPER=ON
+OPENCV_DEPENDENCIES += jasper
+else
+OPENCV_CONF_OPT += -DWITH_JASPER=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_OPENCV_WITH_JPEG),y)
 OPENCV_CONF_OPT += -DWITH_JPEG=ON
 OPENCV_DEPENDENCIES += jpeg