diff mbox

[PATCHv1,12/26] python3: add config directory symbolic link

Message ID 1392324555-29246-13-git-send-email-thomas.petazzoni@free-electrons.com
State Superseded
Headers show

Commit Message

Thomas Petazzoni Feb. 13, 2014, 8:49 p.m. UTC
From: "kpa_info@yahoo.fr" <kpa_info@yahoo.fr>

When using host python to install an external module, the setup tool
look for some files in python3.3/config/. The python3 package config
directory is called config-3.3m. This is why we need to alias config
to config-3.3m.

[Thomas: use PYTHON3_VERSION_MAJOR instead of hardcoding 3.3, update
commit title.]

Signed-off-by: Patrick Gerber <kpa_info@yahoo.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/python3/python3.mk | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

Comments

Samuel Martin Feb. 13, 2014, 9:54 p.m. UTC | #1
Hi Thomas,

On Thu, Feb 13, 2014 at 9:49 PM, Thomas Petazzoni
<thomas.petazzoni@free-electrons.com> wrote:
> From: "kpa_info@yahoo.fr" <kpa_info@yahoo.fr>
>
> When using host python to install an external module, the setup tool
> look for some files in python3.3/config/. The python3 package config
> directory is called config-3.3m. This is why we need to alias config
> to config-3.3m.
>
> [Thomas: use PYTHON3_VERSION_MAJOR instead of hardcoding 3.3, update
> commit title.]
>
> Signed-off-by: Patrick Gerber <kpa_info@yahoo.fr>
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> ---
>  package/python3/python3.mk | 11 ++++++++++-
>  1 file changed, 10 insertions(+), 1 deletion(-)
>
> diff --git a/package/python3/python3.mk b/package/python3/python3.mk
> index ba72e75..d98ca38 100644
> --- a/package/python3/python3.mk
> +++ b/package/python3/python3.mk
> @@ -163,7 +163,16 @@ define HOST_PYTHON3_INSTALL_SYMLINK
>         ln -fs python3 $(HOST_DIR)/usr/bin/python
>  endef
>
> -HOST_PYTHON3_POST_INSTALL_HOOKS += HOST_PYTHON3_INSTALL_SYMLINK
> +# Alias the python<version>/config-<version>m to python<version>/config
> +# This is needed when installing an external python module, because
> +# the setup is looking for files in python<version>/config/
> +define HOST_PYTHON3_INSTALL_CONFIG_SYMLINK
> +       ln -fs config-$(PYTHON3_VERSION_MAJOR)m $(HOST_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOE)config

s/PYTHON3_VERSION_MAJOE/PYTHON3_VERSION_MAJOR/

Regards,
diff mbox

Patch

diff --git a/package/python3/python3.mk b/package/python3/python3.mk
index ba72e75..d98ca38 100644
--- a/package/python3/python3.mk
+++ b/package/python3/python3.mk
@@ -163,7 +163,16 @@  define HOST_PYTHON3_INSTALL_SYMLINK
 	ln -fs python3 $(HOST_DIR)/usr/bin/python
 endef
 
-HOST_PYTHON3_POST_INSTALL_HOOKS += HOST_PYTHON3_INSTALL_SYMLINK
+# Alias the python<version>/config-<version>m to python<version>/config
+# This is needed when installing an external python module, because
+# the setup is looking for files in python<version>/config/
+define HOST_PYTHON3_INSTALL_CONFIG_SYMLINK
+	ln -fs config-$(PYTHON3_VERSION_MAJOR)m $(HOST_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOE)config
+endef
+
+HOST_PYTHON3_POST_INSTALL_HOOKS += \
+	HOST_PYTHON3_INSTALL_SYMLINK \
+	HOST_PYTHON3_INSTALL_CONFIG_SYMLINK
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))