diff mbox

[2/2] stress: add license information

Message ID 1381200417.18302.3.camel@phoenix
State Superseded
Headers show

Commit Message

Axel Lin Oct. 8, 2013, 2:46 a.m. UTC
Signed-off-by: Axel Lin <axel.lin@ingics.com>
---
 package/stress/stress.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Thomas Petazzoni Oct. 8, 2013, 7:15 a.m. UTC | #1
Dear Axel Lin,

On Tue, 08 Oct 2013 10:46:57 +0800, Axel Lin wrote:
> Signed-off-by: Axel Lin <axel.lin@ingics.com>
> ---
>  package/stress/stress.mk | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/stress/stress.mk b/package/stress/stress.mk
> index 6e82b50..387166d 100644
> --- a/package/stress/stress.mk
> +++ b/package/stress/stress.mk
> @@ -6,6 +6,8 @@
>  
>  STRESS_VERSION = 1.0.4
>  STRESS_SITE = http://people.seas.harvard.edu/~apw/stress
> +STRESS_LICENSE = GPLv3+
> +STRESS_LICENSE_FILES = COPYING

Hum, the situation is a bit weird:

 * The homepage of the project states " It is written in C, and is free
   software licensed under the GPLv2."

 * The tarball contains a COPYING file which is a copy of the GPLv3.

 * The source code itself contains the mention:

     This program is free software; you can redistribute it and/or
     modify it under the terms of the GNU General Public License as
     published by the Free Software Foundation; either version 2 of the
     License, or (at your option) any later version.

So in the end, it's hard to decide whether it's GPLv2+ or GPLv3+. Maybe
you could contact the author of 'stress' and clarify the situation?

Best regards,

Thomas
Axel Lin Oct. 8, 2013, 7:44 a.m. UTC | #2
2013/10/8 Thomas Petazzoni <thomas.petazzoni@free-electrons.com>:
> Dear Axel Lin,
>
> On Tue, 08 Oct 2013 10:46:57 +0800, Axel Lin wrote:
>> Signed-off-by: Axel Lin <axel.lin@ingics.com>
>> ---
>>  package/stress/stress.mk | 2 ++
>>  1 file changed, 2 insertions(+)
>>
>> diff --git a/package/stress/stress.mk b/package/stress/stress.mk
>> index 6e82b50..387166d 100644
>> --- a/package/stress/stress.mk
>> +++ b/package/stress/stress.mk
>> @@ -6,6 +6,8 @@
>>
>>  STRESS_VERSION = 1.0.4
>>  STRESS_SITE = http://people.seas.harvard.edu/~apw/stress
>> +STRESS_LICENSE = GPLv3+
>> +STRESS_LICENSE_FILES = COPYING
>
> Hum, the situation is a bit weird:
>
>  * The homepage of the project states " It is written in C, and is free
>    software licensed under the GPLv2."
>
>  * The tarball contains a COPYING file which is a copy of the GPLv3.
>
>  * The source code itself contains the mention:
>
>      This program is free software; you can redistribute it and/or
>      modify it under the terms of the GNU General Public License as
>      published by the Free Software Foundation; either version 2 of the
>      License, or (at your option) any later version.
>
> So in the end, it's hard to decide whether it's GPLv2+ or GPLv3+. Maybe
> you could contact the author of 'stress' and clarify the situation?
OK. I just sent a mail to the author for clarifying the license issue.

Regards,
Axel
diff mbox

Patch

diff --git a/package/stress/stress.mk b/package/stress/stress.mk
index 6e82b50..387166d 100644
--- a/package/stress/stress.mk
+++ b/package/stress/stress.mk
@@ -6,6 +6,8 @@ 
 
 STRESS_VERSION = 1.0.4
 STRESS_SITE = http://people.seas.harvard.edu/~apw/stress
+STRESS_LICENSE = GPLv3+
+STRESS_LICENSE_FILES = COPYING
 STRESS_AUTORECONF = YES
 
 # Stress is linked statically if the --enable-static is specified.