diff mbox

configs: add Freescale i.MX 6SoloLite EVK support

Message ID 1380185523-26736-1-git-send-email-gilles.talis@gmail.com
State Superseded
Headers show

Commit Message

Gilles Talis Sept. 26, 2013, 8:52 a.m. UTC
i.MX6 SoloLite EVK is Freescale's evaluation board based on
the i.MX6 SoloLite applications processor.

This defconfig is based off Freescale "official" git repo on git.freescale.com
and SW release 3.0.35_4.1.0.

Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
---
 configs/freescale_imx6sololiteevk_defconfig |   15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 configs/freescale_imx6sololiteevk_defconfig

Comments

Peter Korsgaard Sept. 26, 2013, 7:37 p.m. UTC | #1
>>>>> "Gilles" == Gilles Talis <gilles.talis@gmail.com> writes:

 Gilles> i.MX6 SoloLite EVK is Freescale's evaluation board based on
 Gilles> the i.MX6 SoloLite applications processor.

 Gilles> This defconfig is based off Freescale "official" git repo on git.freescale.com
 Gilles> and SW release 3.0.35_4.1.0.

 Gilles> Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
 Gilles> ---
 Gilles>  configs/freescale_imx6sololiteevk_defconfig |   15 +++++++++++++++
 Gilles>  1 file changed, 15 insertions(+)
 Gilles>  create mode 100644 configs/freescale_imx6sololiteevk_defconfig

 Gilles> diff --git a/configs/freescale_imx6sololiteevk_defconfig b/configs/freescale_imx6sololiteevk_defconfig
 Gilles> new file mode 100644
 Gilles> index 0000000..7ed6e6c
 Gilles> --- /dev/null
 Gilles> +++ b/configs/freescale_imx6sololiteevk_defconfig
 Gilles> @@ -0,0 +1,15 @@
 Gilles> +BR2_arm=y
 Gilles> +BR2_cortex_a9=y
 Gilles> +BR2_ROOTFS_DEVICE_CREATION_STATIC=y

Why do you want static device nodes?
Gilles Talis Sept. 27, 2013, 9:03 a.m. UTC | #2
Peter,

>  Gilles> +BR2_ROOTFS_DEVICE_CREATION_STATIC=y
>
> Why do you want static device nodes?
Kernel defconfig does not support DEVTMPFS. I did not want to change
that. Is it a problem?
Peter Korsgaard Sept. 27, 2013, 10:02 a.m. UTC | #3
>>>>> "Gilles" == Gilles Talis <gilles.talis@gmail.com> writes:

 Gilles> Peter,
 Gilles> +BR2_ROOTFS_DEVICE_CREATION_STATIC=y
 >> 
 >> Why do you want static device nodes?

 Gilles> Kernel defconfig does not support DEVTMPFS. I did not want to change
 Gilles> that. Is it a problem?

It's not really a problem, no - Just quite uncommon. Do notice that
Buildroot automatically enables devtmpfs support in the kernel if
needed, so it should all just work.
Gilles Talis Sept. 27, 2013, 10:08 a.m. UTC | #4
Hi Peter,

> It's not really a problem, no - Just quite uncommon. Do notice that
> Buildroot automatically enables devtmpfs support in the kernel if
> needed, so it should all just work.

Does it? I was not aware of that. It did not seem to work for me,
hence the reason why I had to force static device nodes. Let me give
it another try and see how it goes.
Thanks

Gilles.
Peter Korsgaard Sept. 27, 2013, 10:50 a.m. UTC | #5
>>>>> "Gilles" == Gilles Talis <gilles.talis@gmail.com> writes:

 Gilles> Hi Peter,
 >> It's not really a problem, no - Just quite uncommon. Do notice that
 >> Buildroot automatically enables devtmpfs support in the kernel if
 >> needed, so it should all just work.

 Gilles> Does it? I was not aware of that. It did not seem to work for me,
 Gilles> hence the reason why I had to force static device nodes. Let me give
 Gilles> it another try and see how it goes.

As long as you build the kernel through buildroot it should:

git grep -B1  DEVTMPFS linux/linux.mk
linux/linux.mk- $(if $(BR2_ROOTFS_DEVICE_CREATION_STATIC),,
linux/linux.mk:         $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS,$(@D)/.config)
linux/linux.mk:         $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS_MOUNT,$(@D)/.c
diff mbox

Patch

diff --git a/configs/freescale_imx6sololiteevk_defconfig b/configs/freescale_imx6sololiteevk_defconfig
new file mode 100644
index 0000000..7ed6e6c
--- /dev/null
+++ b/configs/freescale_imx6sololiteevk_defconfig
@@ -0,0 +1,15 @@ 
+BR2_arm=y
+BR2_cortex_a9=y
+BR2_ROOTFS_DEVICE_CREATION_STATIC=y
+BR2_TARGET_GENERIC_GETTY_PORT="ttymxc0"
+BR2_LINUX_KERNEL=y
+BR2_LINUX_KERNEL_CUSTOM_GIT=y
+BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL="git://git.freescale.com/imx/linux-2.6-imx.git"
+BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION="rel_imx_3.0.35_4.1.0"
+BR2_LINUX_KERNEL_DEFCONFIG="imx6s"
+BR2_TARGET_ROOTFS_EXT2=y
+BR2_TARGET_UBOOT=y
+BR2_TARGET_UBOOT_BOARDNAME="mx6sl_evk"
+BR2_TARGET_UBOOT_CUSTOM_GIT=y
+BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL="git://git.freescale.com/imx/uboot-imx.git"
+BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION="rel_imx_3.0.35_4.1.0"