diff mbox

glibc: Pass correct -mabi for MIPS

Message ID 1380121257-10449-1-git-send-email-markos.chandras@imgtec.com
State Accepted
Commit 3dfa23fcc2d54e75eb80d14fc2b0045a3a24c355
Headers show

Commit Message

Markos Chandras Sept. 25, 2013, 3 p.m. UTC
According to glibc-2.18/ports/sysdeps/mips/preconfigure,
if no -mabi was passed to CFLAGS, then it defaults to -mabi=n32.
This breaks o32 and n64 builds for MIPS64. Therefore, it is
necessary to append -mabi to CFLAGS.

Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
---
 package/glibc/glibc.mk | 10 ++++++++++
 1 file changed, 10 insertions(+)

Comments

Markos Chandras Sept. 30, 2013, 8:33 a.m. UTC | #1
On 09/25/13 16:00, Markos Chandras wrote:
> According to glibc-2.18/ports/sysdeps/mips/preconfigure,
> if no -mabi was passed to CFLAGS, then it defaults to -mabi=n32.
> This breaks o32 and n64 builds for MIPS64. Therefore, it is
> necessary to append -mabi to CFLAGS.
>
> Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
> ---
>   package/glibc/glibc.mk | 10 ++++++++++
>   1 file changed, 10 insertions(+)
>
> diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
> index 4dd2e63..68c4636 100644
> --- a/package/glibc/glibc.mk
> +++ b/package/glibc/glibc.mk
> @@ -43,6 +43,16 @@ ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
>   GLIBC_EXTRA_CFLAGS += -marm
>   endif
>
> +# MIPS64 defaults to n32 so pass the correct -mabi if
> +# we are using a different ABI. OABI32 is also used
> +# in MIPS so we pass -mabi=32 in this case as well
> +# even though it's not strictly necessary.
> +ifeq ($(BR2_MIPS_NABI64),y)
> +GLIBC_EXTRA_CFLAGS += -mabi=64
> +else ifeq ($(BR2_MIPS_OABI32),y)
> +GLIBC_EXTRA_CFLAGS += -mabi=32
> +endif
> +
>   # Even though we use the autotools-package infrastructure, we have to
>   # override the default configure commands for several reasons:
>   #
>
Ping? :)
Thomas Petazzoni Oct. 1, 2013, 9:33 p.m. UTC | #2
Dear Markos Chandras,

On Wed, 25 Sep 2013 16:00:57 +0100, Markos Chandras wrote:
> According to glibc-2.18/ports/sysdeps/mips/preconfigure,
> if no -mabi was passed to CFLAGS, then it defaults to -mabi=n32.
> This breaks o32 and n64 builds for MIPS64. Therefore, it is
> necessary to append -mabi to CFLAGS.
> 
> Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>

Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Peter Korsgaard Oct. 1, 2013, 9:59 p.m. UTC | #3
>>>>> "Markos" == Markos Chandras <markos.chandras@imgtec.com> writes:

 Markos> According to glibc-2.18/ports/sysdeps/mips/preconfigure,
 Markos> if no -mabi was passed to CFLAGS, then it defaults to -mabi=n32.
 Markos> This breaks o32 and n64 builds for MIPS64. Therefore, it is
 Markos> necessary to append -mabi to CFLAGS.

 Markos> Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>

Committed, thanks.
diff mbox

Patch

diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
index 4dd2e63..68c4636 100644
--- a/package/glibc/glibc.mk
+++ b/package/glibc/glibc.mk
@@ -43,6 +43,16 @@  ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
 GLIBC_EXTRA_CFLAGS += -marm
 endif
 
+# MIPS64 defaults to n32 so pass the correct -mabi if
+# we are using a different ABI. OABI32 is also used
+# in MIPS so we pass -mabi=32 in this case as well
+# even though it's not strictly necessary.
+ifeq ($(BR2_MIPS_NABI64),y)
+GLIBC_EXTRA_CFLAGS += -mabi=64
+else ifeq ($(BR2_MIPS_OABI32),y)
+GLIBC_EXTRA_CFLAGS += -mabi=32
+endif
+
 # Even though we use the autotools-package infrastructure, we have to
 # override the default configure commands for several reasons:
 #