diff mbox

neon: disable webdav when no XML support is available

Message ID 1378043691-28892-1-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit 7573464a9857c9480f7ee358ab6766f7349571ab
Headers show

Commit Message

Thomas Petazzoni Sept. 1, 2013, 1:54 p.m. UTC
Since 9169810a9bd97c99d8b7a0e8aadabdcca3883e99 ("neon: replace
'choice' for XML library with two options") the option
BR2_PACKAGE_NEON_NOXML no longer exists. However, it was not taken
into account properly within neon.mk, as this option was still used to
disable webdav support when no XML library has been selected.

Fixes:

  http://autobuild.buildroot.org/results/7ed/7ed657570d83b28389dd8c01ffdd895d2e8d145f/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/neon/neon.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Sept. 1, 2013, 7:37 p.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 Thomas> Since 9169810a9bd97c99d8b7a0e8aadabdcca3883e99 ("neon: replace
 Thomas> 'choice' for XML library with two options") the option
 Thomas> BR2_PACKAGE_NEON_NOXML no longer exists. However, it was not taken
 Thomas> into account properly within neon.mk, as this option was still used to
 Thomas> disable webdav support when no XML library has been selected.

 Thomas> Fixes:

 Thomas>   http://autobuild.buildroot.org/results/7ed/7ed657570d83b28389dd8c01ffdd895d2e8d145f/

Ups, committed - Thanks.
diff mbox

Patch

diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index 1915e6c..2edc6b2 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -42,7 +42,7 @@  else
 NEON_CONF_OPT += --with-libxml2=no
 endif
 
-ifeq ($(BR2_PACKAGE_NEON_NOXML),y)
+ifeq ($(BR2_PACKAGE_NEON_EXPAT)$(BR2_PACKAGE_NEON_LIBXML2),)
 # webdav needs xml support
 NEON_CONF_OPT += --disable-webdav
 endif