diff mbox

iptables: fix build after linux-headers changes

Message ID 1373123930-15389-1-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit 478f826518e1cf769abfb69da9361d931be15f8c
Headers show

Commit Message

Thomas Petazzoni July 6, 2013, 3:18 p.m. UTC
As reported by 'scanf' on IRC, the iptables now fails to build because
of a missing <asm/cache.h> header in the kernel headers. The package
directly uses $(LINUX_HEADERS_DIR), which is not correct: this is the
source directory of the kernel, not where they are installed, and in
addition, this directory is empty/does not exist when using external
toolchains.

Instead, we use $(STAGING_DIR)/usr, which contains the kernel headers,
as part of the toolchain headers.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/iptables/iptables.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard July 7, 2013, 7:36 p.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 Thomas> As reported by 'scanf' on IRC, the iptables now fails to build
 Thomas> because of a missing <asm/cache.h> header in the kernel
 Thomas> headers. The package directly uses $(LINUX_HEADERS_DIR), which
 Thomas> is not correct: this is the source directory of the kernel, not
 Thomas> where they are installed, and in addition, this directory is
 Thomas> empty/does not exist when using external toolchains.

 Thomas> Instead, we use $(STAGING_DIR)/usr, which contains the kernel
 Thomas> headers, as part of the toolchain headers.

Committed, thanks.
diff mbox

Patch

diff --git a/package/iptables/iptables.mk b/package/iptables/iptables.mk
index cfb227a..f548cb9 100644
--- a/package/iptables/iptables.mk
+++ b/package/iptables/iptables.mk
@@ -12,7 +12,7 @@  IPTABLES_DEPENDENCIES = host-pkgconf
 IPTABLES_LICENSE = GPLv2
 IPTABLES_LICENSE_FILES = COPYING
 
-IPTABLES_CONF_OPT = --libexecdir=/usr/lib --with-kernel=$(LINUX_HEADERS_DIR)
+IPTABLES_CONF_OPT = --libexecdir=/usr/lib --with-kernel=$(STAGING_DIR)/usr
 
 define IPTABLES_TARGET_SYMLINK_CREATE
 	ln -sf xtables-multi $(TARGET_DIR)/usr/sbin/iptables