diff mbox

icu: security bump to version 51.2

Message ID 1372562606-991-1-git-send-email-gustavo@zacarias.com.ar
State Accepted
Commit 3911e67151bfa5885e6e4c7a93e02c89ccac069f
Headers show

Commit Message

Gustavo Zacarias June 30, 2013, 3:23 a.m. UTC
Fixes CVE-2011-4599, CVE 2013-0900, CVE-2013-1569, CVE-2013-2383,
CVE-2013-2384, CVE-2013-2419.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/icu/icu-workaround-toolchain-bugs.patch | 32 ++++++++++++-------------
 package/icu/icu.mk                              |  5 ++--
 2 files changed, 19 insertions(+), 18 deletions(-)

Comments

Peter Korsgaard June 30, 2013, 8:22 a.m. UTC | #1
>>>>> "Gustavo" == Gustavo Zacarias <gustavo@zacarias.com.ar> writes:

 Gustavo> Fixes CVE-2011-4599, CVE 2013-0900, CVE-2013-1569, CVE-2013-2383,
 Gustavo> CVE-2013-2384, CVE-2013-2419.

Committed, thanks.
diff mbox

Patch

diff --git a/package/icu/icu-workaround-toolchain-bugs.patch b/package/icu/icu-workaround-toolchain-bugs.patch
index df9d528..64d67a0 100644
--- a/package/icu/icu-workaround-toolchain-bugs.patch
+++ b/package/icu/icu-workaround-toolchain-bugs.patch
@@ -10,27 +10,27 @@  is trivial in this case. So it will avoid our users falling into this
 internal compiler error, and allow our autobuilders to test more
 packages using this Sourcery CodeBench toolchain.qq
 
+[Gustavo: update for ICU4C 51.2]
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 
-Index: b/source/configure
-===================================================================
---- a/source/configure
-+++ b/source/configure
-@@ -4320,7 +4320,7 @@
-                 echo "# Note: We are not using '-ansi' with HP/UX GCC because int64_t broke, see <http://bugs.icu-project.org/trac/ticket/8493>"
-                 CFLAGS="$CFLAGS -Wall -pedantic -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -Wno-long-long";;
-             *)
--                CFLAGS="$CFLAGS -Wall -ansi -pedantic -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -Wno-long-long";;
-+                CFLAGS="$CFLAGS -ansi -pedantic -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -Wno-long-long";;
-             esac
+diff -Nura icu.orig/source/configure icu/source/configure
+--- icu.orig/source/configure	2013-05-23 17:06:32.000000000 -0300
++++ icu/source/configure	2013-06-29 15:43:04.202320953 -0300
+@@ -4066,7 +4066,7 @@
+         then
+             # Do not use -ansi. It limits us to C90, and it breaks some platforms.
+             # We use -std=c99 to disable the gnu99 defaults and its associated warnings
+-            CFLAGS="$CFLAGS -Wall -std=c99 -pedantic -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings"
++            CFLAGS="$CFLAGS -std=c99 -pedantic -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings"
          else
              case "${host}" in
-@@ -4333,7 +4333,7 @@
+             *-*-cygwin)
+@@ -4078,7 +4078,7 @@
          fi
          if test "$GXX" = yes
          then
--            CXXFLAGS="$CXXFLAGS -W -Wall -ansi -pedantic -Wpointer-arith -Wwrite-strings -Wno-long-long"
-+            CXXFLAGS="$CXXFLAGS -ansi -pedantic -Wpointer-arith -Wwrite-strings -Wno-long-long"
+-            CXXFLAGS="$CXXFLAGS -W -Wall -pedantic -Wpointer-arith -Wwrite-strings -Wno-long-long"
++            CXXFLAGS="$CXXFLAGS -pedantic -Wpointer-arith -Wwrite-strings -Wno-long-long"
+         else
              case "${host}" in
-             *-*-solaris*)
-                 CXXFLAGS="$CXXFLAGS -D__STDC__=0";;
+             *-*-cygwin)
diff --git a/package/icu/icu.mk b/package/icu/icu.mk
index 00eacc7..7954eb0 100644
--- a/package/icu/icu.mk
+++ b/package/icu/icu.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-ICU_VERSION = 4.8.1.1
+ICU_VERSION = 51.2
 ICU_SOURCE = icu4c-$(subst .,_,$(ICU_VERSION))-src.tgz
 ICU_SITE = http://download.icu-project.org/files/icu4c/$(ICU_VERSION)
 ICU_LICENSE = ICU License
@@ -20,7 +20,8 @@  HOST_ICU_CONF_OPT = \
 	--disable-tests \
 	--disable-extras \
 	--disable-icuio \
-	--disable-layout
+	--disable-layout \
+	--disable-renaming
 ICU_MAKE = $(MAKE1)
 ICU_SUBDIR = source
 HOST_ICU_SUBDIR = source