diff mbox

[PATCHv3,5/5] tcl: make the libtcl writable in order to be stripped

Message ID 1372063256-23292-6-git-send-email-richard.genoud@gmail.com
State Accepted
Headers show

Commit Message

Richard Genoud June 24, 2013, 8:40 a.m. UTC
The libtcl is installed with 0555 and that prevents it from being
stripped.

Signed-off-by: Richard Genoud <richard.genoud@gmail.com>
---
 package/tcl/tcl.mk |    7 +++++++
 1 file changed, 7 insertions(+)
diff mbox

Patch

diff --git a/package/tcl/tcl.mk b/package/tcl/tcl.mk
index 3fd4047..9f766e0 100644
--- a/package/tcl/tcl.mk
+++ b/package/tcl/tcl.mk
@@ -42,5 +42,12 @@  endef
 TCL_POST_INSTALL_TARGET_HOOKS += TCL_SYMLINK_TCLSH
 endif
 
+# library get installed read only, so strip fails
+define TCL_FIXUP_RO_LIB
+	chmod +w $(TARGET_DIR)/usr/lib/libtcl*
+endef
+
+TCL_POST_INSTALL_TARGET_HOOKS += TCL_FIXUP_RO_LIB
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))