diff mbox

[PATCHv2,1/3] Add on2-8170 kernel modules

Message ID 1370803110-27093-1-git-send-email-alexandre.belloni@free-electrons.com
State Superseded
Headers show

Commit Message

Alexandre Belloni June 9, 2013, 6:38 p.m. UTC
Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
---
 package/Config.in                            |  1 +
 package/on2-8170-modules/Config.in           | 10 ++++++++++
 package/on2-8170-modules/on2-8170-modules.mk | 20 ++++++++++++++++++++
 3 files changed, 31 insertions(+)
 create mode 100644 package/on2-8170-modules/Config.in
 create mode 100644 package/on2-8170-modules/on2-8170-modules.mk

Comments

Arnout Vandecappelle June 10, 2013, 4:57 p.m. UTC | #1
On 09/06/13 20:38, Alexandre Belloni wrote:
> diff --git a/package/on2-8170-modules/Config.in b/package/on2-8170-modules/Config.in
> new file mode 100644
> index 0000000..f082c5f
> --- /dev/null
> +++ b/package/on2-8170-modules/Config.in
> @@ -0,0 +1,10 @@
> +config BR2_PACKAGE_ON2_8170_MODULES
> +	bool "on2-8170 modules"
> +	depends on BR2_LINUX_KERNEL

  We usually add a "depends on BR2_arm" or something similar for such 
SoC-specific packages.

  I'm not sure though if everyone agrees that this is a good ide.

> +	help
> +	  Kernel modules for the Hantro x170 hardware video decompression.
> +
> +	http://www.at91.com/linux4sam/bin/view/Linux4SAM/SAM9M10Gstreamer
> +
> +comment "on2-8170 modules requires a linux kernel to be built"
> +	depends on !BR2_LINUX_KERNEL
> diff --git a/package/on2-8170-modules/on2-8170-modules.mk b/package/on2-8170-modules/on2-8170-modules.mk
> new file mode 100644
> index 0000000..53286fb
> --- /dev/null
> +++ b/package/on2-8170-modules/on2-8170-modules.mk
> @@ -0,0 +1,20 @@
> +################################################################################
> +#
> +# on2-8170-modules
> +#
> +################################################################################
> +
> +ON2_8170_MODULES_VERSION = 73b08061d30789178e692bc332b73d1d9922bf39
> +ON2_8170_MODULES_SITE    = git://github.com/alexandrebelloni/on2-8170-modules.git

  Can you use a tarball, cfr. 
docs/manual/adding-packages-tips.txt:[[github-download-url]] ?

  Could you add license info?



  Regards,
  Arnout

> +
> +ON2_8170_MODULES_DEPENDENCIES = linux
> +
> +define ON2_8170_MODULES_BUILD_CMDS
> +	$(MAKE) -C $(LINUX_DIR) $(LINUX_MAKE_FLAGS) M=$(@D)
> +endef
> +
> +define ON2_8170_MODULES_INSTALL_TARGET_CMDS
> +	$(MAKE) -C $(LINUX_DIR) $(LINUX_MAKE_FLAGS) M=$(@D) modules_install
> +endef
> +
> +$(eval $(generic-package))
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index ce82e99..e915abe 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -272,6 +272,7 @@  source "package/minicom/Config.in"
 source "package/nanocom/Config.in"
 source "package/neard/Config.in"
 source "package/ofono/Config.in"
+source "package/on2-8170-modules/Config.in"
 source "package/open2300/Config.in"
 source "package/openocd/Config.in"
 source "package/owl-linux/Config.in"
diff --git a/package/on2-8170-modules/Config.in b/package/on2-8170-modules/Config.in
new file mode 100644
index 0000000..f082c5f
--- /dev/null
+++ b/package/on2-8170-modules/Config.in
@@ -0,0 +1,10 @@ 
+config BR2_PACKAGE_ON2_8170_MODULES
+	bool "on2-8170 modules"
+	depends on BR2_LINUX_KERNEL
+	help
+	  Kernel modules for the Hantro x170 hardware video decompression.
+
+	  http://www.at91.com/linux4sam/bin/view/Linux4SAM/SAM9M10Gstreamer
+
+comment "on2-8170 modules requires a linux kernel to be built"
+	depends on !BR2_LINUX_KERNEL
diff --git a/package/on2-8170-modules/on2-8170-modules.mk b/package/on2-8170-modules/on2-8170-modules.mk
new file mode 100644
index 0000000..53286fb
--- /dev/null
+++ b/package/on2-8170-modules/on2-8170-modules.mk
@@ -0,0 +1,20 @@ 
+################################################################################
+#
+# on2-8170-modules
+#
+################################################################################
+
+ON2_8170_MODULES_VERSION = 73b08061d30789178e692bc332b73d1d9922bf39
+ON2_8170_MODULES_SITE    = git://github.com/alexandrebelloni/on2-8170-modules.git
+
+ON2_8170_MODULES_DEPENDENCIES = linux
+
+define ON2_8170_MODULES_BUILD_CMDS
+	$(MAKE) -C $(LINUX_DIR) $(LINUX_MAKE_FLAGS) M=$(@D)
+endef
+
+define ON2_8170_MODULES_INSTALL_TARGET_CMDS
+	$(MAKE) -C $(LINUX_DIR) $(LINUX_MAKE_FLAGS) M=$(@D) modules_install
+endef
+
+$(eval $(generic-package))