@@ -13,11 +13,11 @@ First, let's see how to write a +.mk+ file for an autotools-based
package, with an example :
------------------------
-01: #############################################################
+01: ################################################################################
02: #
03: # libfoo
04: #
-05: #############################################################
+05: ################################################################################
06:
07: LIBFOO_VERSION = 1.0
08: LIBFOO_SOURCE = libfoo-$(LIBFOO_VERSION).tar.gz
@@ -13,11 +13,11 @@ First, let's see how to write a +.mk+ file for a CMake-based package,
with an example :
------------------------
-01: #############################################################
+01: ################################################################################
02: #
03: # libfoo
04: #
-05: #############################################################
+05: ################################################################################
06:
07: LIBFOO_VERSION = 1.0
08: LIBFOO_SOURCE = libfoo-$(LIBFOO_VERSION).tar.gz
@@ -15,11 +15,11 @@ system is based on hand-written Makefiles or shell scripts.
^^^^^^^^^^^^^^^^^^^^^^^^^^
------------------------------
-01: #############################################################
+01: ################################################################################
02: #
03: # libfoo
04: #
-05: #############################################################
+05: ################################################################################
06:
07: LIBFOO_VERSION = 1.0
08: LIBFOO_SOURCE = libfoo-$(LIBFOO_VERSION).tar.gz
@@ -52,6 +52,18 @@ http://kernel.org/doc/Documentation/kbuild/kconfig-language.txt[].
The +.mk+ file
~~~~~~~~~~~~~~
+* Header: The file starts with a header. It contains the module name,
+preferably in lowercase, enclosed between separators made of 80 hashes. A
+blank line is mandatory after the header:
++
+---------------------
+################################################################################
+#
+# libfoo
+#
+################################################################################
+---------------------
++
* Assignment: use +=+ preceded and followed by one space:
+
---------------------
Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com> --- docs/manual/adding-packages-autotools.txt | 4 ++-- docs/manual/adding-packages-cmake.txt | 4 ++-- docs/manual/adding-packages-generic.txt | 4 ++-- docs/manual/writing-rules.txt | 12 ++++++++++++ 4 files changed, 18 insertions(+), 6 deletions(-)