diff mbox

ed: Fix quiet building

Message ID 1369053745-25578-1-git-send-email-markos.chandras@gmail.com
State Superseded
Headers show

Commit Message

Markos Chandras May 20, 2013, 12:42 p.m. UTC
From: Markos Chandras <markos.chandras@imgtec.com>

The configure script is a custom one, and '-q' is not supported.
It fixes the following problem when building using 'make -s'

configure: Unrecognized option: "-q"; use --help for usage.

Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
---
 package/ed/ed.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni May 20, 2013, 12:47 p.m. UTC | #1
Dear Markos Chandras,

On Mon, 20 May 2013 13:42:25 +0100, Markos Chandras wrote:

> The configure script is a custom one, and '-q' is not supported.
> It fixes the following problem when building using 'make -s'
> 
> configure: Unrecognized option: "-q"; use --help for usage.
> 
> Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>

If the configure script is not an autotools one, then we shouldn't be
using the autotools-package infrastructure for this package.

Thomas
Markos Chandras May 20, 2013, 1:08 p.m. UTC | #2
On 20 May 2013 13:47, Thomas Petazzoni
<thomas.petazzoni@free-electrons.com> wrote:
> Dear Markos Chandras,
>
> On Mon, 20 May 2013 13:42:25 +0100, Markos Chandras wrote:
>
>> The configure script is a custom one, and '-q' is not supported.
>> It fixes the following problem when building using 'make -s'
>>
>> configure: Unrecognized option: "-q"; use --help for usage.
>>
>> Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
>
> If the configure script is not an autotools one, then we shouldn't be
> using the autotools-package infrastructure for this package.
>
> Thomas
> --
> Thomas Petazzoni, Free Electrons
> Kernel, drivers, real-time and embedded Linux
> development, consulting, training and support.
> http://free-electrons.com

Hi Thomas,

No problem. I will convert it and send a new patch.

--
Regards,
Markos Chandras
diff mbox

Patch

diff --git a/package/ed/ed.mk b/package/ed/ed.mk
index 2bb8e0e..d29239f 100644
--- a/package/ed/ed.mk
+++ b/package/ed/ed.mk
@@ -11,4 +11,8 @@  ED_CONF_OPT = CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
 ED_LICENSE = GPLv3+
 ED_LICENSE_FILES = COPYING
 
+# The configure script is not a standard autotools one
+# and the '-q' option is not supported.
+QUIET=
+
 $(eval $(autotools-package))