diff mbox

[v2] chrony: new package

Message ID 1367866876-5339-1-git-send-email-ntl@pobox.com
State Superseded
Headers show

Commit Message

Nathan Lynch May 6, 2013, 7:01 p.m. UTC
Signed-off-by: Nathan Lynch <ntl@pobox.com>
---

 v2: Add upstream URL to help text
     Add dependency on BR2_USE_MMU (fork)
     Add header to chrony.mk
     Checked build with br-arm-basic, br-arm-full-nothread; no changes needed

 package/Config.in        |  1 +
 package/chrony/Config.in |  8 ++++++++
 package/chrony/chrony.mk | 12 ++++++++++++
 3 files changed, 21 insertions(+)
 create mode 100644 package/chrony/Config.in
 create mode 100644 package/chrony/chrony.mk

Comments

Thomas Petazzoni May 6, 2013, 8:02 p.m. UTC | #1
Dear Nathan Lynch,

On Mon,  6 May 2013 14:01:16 -0500, Nathan Lynch wrote:
> Signed-off-by: Nathan Lynch <ntl@pobox.com>

Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Peter Korsgaard May 6, 2013, 10:09 p.m. UTC | #2
>>>>> "Nathan" == Nathan Lynch <ntl@pobox.com> writes:

 Nathan> Signed-off-by: Nathan Lynch <ntl@pobox.com>
 Nathan> ---

 Nathan>  v2: Add upstream URL to help text
 Nathan>      Add dependency on BR2_USE_MMU (fork)
 Nathan>      Add header to chrony.mk
 Nathan>      Checked build with br-arm-basic, br-arm-full-nothread; no changes needed

Thanks, but:

Unrecognized option :  --target=arm-buildroot-linux-uclibcgnueabi
Unrecognized option :  --host=arm-buildroot-linux-uclibcgnueabi
Unrecognized option :  --build=x86_64-unknown-linux-gnu
Unrecognized option :  --program-prefix=
Unrecognized option :  --disable-gtk-doc
Unrecognized option :  --disable-doc
Unrecognized option :  --disable-docs
Unrecognized option :  --disable-documentation
Unrecognized option :  --with-xmlto=no
Unrecognized option :  --with-fop=no
Unrecognized option :  --enable-ipv6
Unrecognized option :  --enable-static
Unrecognized option :  --enable-shared
Configuring for  Linux-x86_64
Checking for math : No
Checking for math in -lm : Yes
Checking for <stdint.h> : Yes
Checking for <inttypes.h> : Yes
Checking for IPv6 support : Yes
Checking for in6_pktinfo : No
Checking for in6_pktinfo with _GNU_SOURCE : Yes
Checking for <sys/timepps.h> : No
Checking for <timepps.h> : No
Checking for linuxcaps : No
Checking for <linux/rtc.h> : Yes
Checking for sched_setscheduler() : Yes
Checking for mlockall() : Yes
Checking for editline : No
Checking for readline : No
Package nss was not found in the pkg-config search path.
Perhaps you should add the directory containing `nss.pc'
to the PKG_CONFIG_PATH environment variable
No package 'nss' found
Package nss was not found in the pkg-config search path.
Perhaps you should add the directory containing `nss.pc'
to the PKG_CONFIG_PATH environment variable
No package 'nss' found
Checking for NSS : No
Checking for tomcrypt : No


So apparently it isn't using autotools, but a handwritten
configure. This could make it troublesome to use the autotools-package
support (I haven't looked in detail to see if it's a problem though).

The 'Configuring for  Linux-x86_64' is a bit worrysome as I'm building
for ARM.

The PKG_CONFIG_PATH warnings is an indication that you should depend on
host-pkgconf. We also have a libnss package so you could add optional
support for it.
Nathan Lynch May 6, 2013, 11:21 p.m. UTC | #3
On Tue, 2013-05-07 at 00:09 +0200, Peter Korsgaard wrote:
> 
> So apparently it isn't using autotools, but a handwritten
> configure. This could make it troublesome to use the autotools-package
> support (I haven't looked in detail to see if it's a problem though).
> 
> The 'Configuring for  Linux-x86_64' is a bit worrysome as I'm building
> for ARM.
> 
> The PKG_CONFIG_PATH warnings is an indication that you should depend on
> host-pkgconf. We also have a libnss package so you could add optional
> support for it.

Thanks, I'll look into resolving these issues.  FWIW, it does work
correctly on my MIPS target.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index fe4f56b..d5719a8 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -670,6 +670,7 @@  source "package/bind/Config.in"
 source "package/bmon/Config.in"
 source "package/bridge-utils/Config.in"
 source "package/can-utils/Config.in"
+source "package/chrony/Config.in"
 source "package/connman/Config.in"
 source "package/crda/Config.in"
 source "package/ctorrent/Config.in"
diff --git a/package/chrony/Config.in b/package/chrony/Config.in
new file mode 100644
index 0000000..05d6fc1
--- /dev/null
+++ b/package/chrony/Config.in
@@ -0,0 +1,8 @@ 
+config BR2_PACKAGE_CHRONY
+	bool "chrony"
+	depends on BR2_USE_MMU # fork()
+	help
+	  Chrony is a pair of programs which are used to maintain the
+	  accuracy of the system clock.
+
+	  http://chrony.tuxfamily.org/
diff --git a/package/chrony/chrony.mk b/package/chrony/chrony.mk
new file mode 100644
index 0000000..e8f121d
--- /dev/null
+++ b/package/chrony/chrony.mk
@@ -0,0 +1,12 @@ 
+#############################################################
+#
+# chrony
+#
+#############################################################
+
+CHRONY_VERSION = 1.27
+CHRONY_SITE = http://download.tuxfamily.org/chrony/
+CHRONY_LICENSE = GPLv2
+CHRONY_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))