diff mbox

python: remove smtpd.py

Message ID 1367840923-19121-1-git-send-email-gustavo@zacarias.com.ar
State Superseded
Headers show

Commit Message

Gustavo Zacarias May 6, 2013, 11:48 a.m. UTC
It's mostly sample code, normally not used, and has a bad shebang line.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/python/python.mk | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

Comments

Peter Korsgaard May 6, 2013, 11:52 a.m. UTC | #1
>>>>> "Gustavo" == Gustavo Zacarias <gustavo@zacarias.com.ar> writes:

 Gustavo> It's mostly sample code, normally not used, and has a bad shebang line.
 Gustavo> Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
 Gustavo> ---
 Gustavo>  package/python/python.mk | 11 +++++++----
 Gustavo>  1 file changed, 7 insertions(+), 4 deletions(-)

 Gustavo> diff --git a/package/python/python.mk b/package/python/python.mk
 Gustavo> index 4876dd8..265b7d0 100644
 Gustavo> --- a/package/python/python.mk
 Gustavo> +++ b/package/python/python.mk
 Gustavo> @@ -108,10 +108,6 @@ else
 Gustavo>  PYTHON_CONF_OPT += --disable-zlib
 Gustavo>  endif
 
 Gustavo> -ifeq ($(BR2_PACKAGE_PYTHON_HASHLIB),y)
 Gustavo> -PYTHON_DEPENDENCIES += openssl
 Gustavo> -endif
 Gustavo> -

I guess this shouldn't get dropped?
Gustavo Zacarias May 6, 2013, 11:56 a.m. UTC | #2
On 05/06/2013 08:52 AM, Peter Korsgaard wrote:

>  Gustavo> -ifeq ($(BR2_PACKAGE_PYTHON_HASHLIB),y)
>  Gustavo> -PYTHON_DEPENDENCIES += openssl
>  Gustavo> -endif
>  Gustavo> -
> 
> I guess this shouldn't get dropped?

Rushy patch, sent v2.
Regards.
diff mbox

Patch

diff --git a/package/python/python.mk b/package/python/python.mk
index 4876dd8..265b7d0 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -108,10 +108,6 @@  else
 PYTHON_CONF_OPT += --disable-zlib
 endif
 
-ifeq ($(BR2_PACKAGE_PYTHON_HASHLIB),y)
-PYTHON_DEPENDENCIES += openssl
-endif
-
 PYTHON_CONF_ENV += \
 	PYTHON_FOR_BUILD=$(HOST_PYTHON_DIR)/python \
 	PGEN_FOR_BUILD=$(HOST_PYTHON_DIR)/Parser/pgen \
@@ -142,6 +138,13 @@  endef
 
 PYTHON_POST_INSTALL_STAGING_HOOKS += PYTHON_FIXUP_LIBDIR
 
+# Bad shebang, normally not used
+define PYTHON_REMOVE_SMTPD
+	rm -f $(TARGET_DIR)/usr/bin/smtpd.py
+endef
+
+PYTHON_POST_INSTALL_TARGET_HOOKS += PYTHON_REMOVE_SMTPD
+
 #
 # Development files removal
 #