diff mbox

Makefile: make skeleton rsync options consistent

Message ID 1367464526-3028-1-git-send-email-danomimanchego123@gmail.com
State Accepted
Commit e97376a0fc018970f7a166f183d3817a6b1bfaf1
Headers show

Commit Message

Danomi Manchego May 2, 2013, 3:15 a.m. UTC
Initially, a "cp" was used for the one-time target skeleton
installation, and an "rsync" was used for the every-time overlay
skeleton installations.  Then, the target skeleton install was
changed to also use rsync (1cd3f992fb3659aacbb0cdd3ed64347a37569891).
Now there are two rsyncs, but with different filter specs, which
seems odd.

This patch adds --excludes to both invocations of rsync to make them
consistent, and removes the -u option from the initial target skeleton
installation.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
---
 Makefile |    6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard May 2, 2013, 9:33 p.m. UTC | #1
>>>>> "Danomi" == Danomi Manchego <danomimanchego123@gmail.com> writes:

 Danomi> Initially, a "cp" was used for the one-time target skeleton
 Danomi> installation, and an "rsync" was used for the every-time overlay
 Danomi> skeleton installations.  Then, the target skeleton install was
 Danomi> changed to also use rsync (1cd3f992fb3659aacbb0cdd3ed64347a37569891).
 Danomi> Now there are two rsyncs, but with different filter specs, which
 Danomi> seems odd.

 Danomi> This patch adds --excludes to both invocations of rsync to make them
 Danomi> consistent, and removes the -u option from the initial target skeleton
 Danomi> installation.

 Danomi> Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>

Committed, thanks.
Danomi Manchego Sept. 8, 2013, 5:36 p.m. UTC | #2
Ping?

The patch still applies, with no fuzz but some shifted lines. The
problem described
still exists, and is still fixed by the patch.

Danomi -


On Wed, May 1, 2013 at 11:15 PM, Danomi Manchego <
danomimanchego123@gmail.com> wrote:

> Initially, a "cp" was used for the one-time target skeleton
> installation, and an "rsync" was used for the every-time overlay
> skeleton installations.  Then, the target skeleton install was
> changed to also use rsync (1cd3f992fb3659aacbb0cdd3ed64347a37569891).
> Now there are two rsyncs, but with different filter specs, which
> seems odd.
>
> This patch adds --excludes to both invocations of rsync to make them
> consistent, and removes the -u option from the initial target skeleton
> installation.
>
> Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
> ---
>  Makefile |    6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/Makefile b/Makefile
> index 97804ff..5b690f0 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -429,7 +429,9 @@ endif
>
>  $(BUILD_DIR)/.root:
>         mkdir -p $(TARGET_DIR)
> -       rsync -au --exclude=.empty --exclude=CVS --exclude=.svn
> --exclude='*~' \
> +       rsync -a \
> +               --exclude .empty --exclude .svn --exclude .git \
> +               --exclude .hg --exclude=CVS --exclude '*~' \
>                 $(TARGET_SKELETON)/ $(TARGET_DIR)/
>         cp support/misc/target-dir-warning.txt $(TARGET_DIR_WARNING_FILE)
>         touch $@
> @@ -505,7 +507,7 @@ endif
>                 $(call MESSAGE,"Copying overlay $(d)"); \
>                 rsync -a \
>                         --exclude .empty --exclude .svn --exclude .git \
> -                       --exclude .hg --exclude '*~' \
> +                       --exclude .hg --exclude=CVS --exclude '*~' \
>                         $(d)/ $(TARGET_DIR)$(sep))
>
>         @$(foreach s, $(call qstrip,$(BR2_ROOTFS_POST_BUILD_SCRIPT)), \
> --
> 1.7.9.5
>
>
Danomi Manchego Sept. 8, 2013, 5:54 p.m. UTC | #3
On Sun, Sep 8, 2013 at 1:36 PM, Danomi Manchego <danomimanchego123@gmail.com
> wrote:

> Ping?
>
> The patch still applies, with no fuzz but some shifted lines. The problem described
> still exists, and is still fixed by the patch.
>

Arg, apologies, apologies  apologies - I pinged on the wrong rsync patch.
 I meant the patch at http://patchwork.ozlabs.org/patch/249912/ -
"Makefile: change rsync used in overlays to always transfer files".

Danomi -
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 97804ff..5b690f0 100644
--- a/Makefile
+++ b/Makefile
@@ -429,7 +429,9 @@  endif
 
 $(BUILD_DIR)/.root:
 	mkdir -p $(TARGET_DIR)
-	rsync -au --exclude=.empty --exclude=CVS --exclude=.svn --exclude='*~' \
+	rsync -a \
+		--exclude .empty --exclude .svn --exclude .git \
+		--exclude .hg --exclude=CVS --exclude '*~' \
 		$(TARGET_SKELETON)/ $(TARGET_DIR)/
 	cp support/misc/target-dir-warning.txt $(TARGET_DIR_WARNING_FILE)
 	touch $@
@@ -505,7 +507,7 @@  endif
 		$(call MESSAGE,"Copying overlay $(d)"); \
 		rsync -a \
 			--exclude .empty --exclude .svn --exclude .git \
-			--exclude .hg --exclude '*~' \
+			--exclude .hg --exclude=CVS --exclude '*~' \
 			$(d)/ $(TARGET_DIR)$(sep))
 
 	@$(foreach s, $(call qstrip,$(BR2_ROOTFS_POST_BUILD_SCRIPT)), \