diff mbox

fdk-aac: new package

Message ID 1367282387-8011-1-git-send-email-gilles.talis@gmail.com
State Superseded
Headers show

Commit Message

Gilles Talis April 30, 2013, 12:39 a.m. UTC
Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
---
 package/Config.in          |    1 +
 package/fdk-aac/Config.in  |   12 ++++++++++++
 package/fdk-aac/fdk-aac.mk |   14 ++++++++++++++
 3 files changed, 27 insertions(+)
 create mode 100644 package/fdk-aac/Config.in
 create mode 100644 package/fdk-aac/fdk-aac.mk

Comments

Peter Korsgaard July 10, 2013, 5:31 a.m. UTC | #1
>>>>> "Gilles" == Gilles Talis <gilles.talis@gmail.com> writes:

Hi, and sorry for the slow response.

 Gilles> Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
 Gilles> ---
 Gilles>  package/Config.in          |    1 +
 Gilles>  package/fdk-aac/Config.in  |   12 ++++++++++++
 Gilles>  package/fdk-aac/fdk-aac.mk |   14 ++++++++++++++
 Gilles>  3 files changed, 27 insertions(+)
 Gilles>  create mode 100644 package/fdk-aac/Config.in
 Gilles>  create mode 100644 package/fdk-aac/fdk-aac.mk

 Gilles> diff --git a/package/Config.in b/package/Config.in
 Gilles> index 56fdd2f..9a06284 100644
 Gilles> --- a/package/Config.in
 Gilles> +++ b/package/Config.in
 Gilles> @@ -350,6 +350,7 @@ menu "Audio/Sound"
 Gilles>  source "package/alsa-lib/Config.in"
 Gilles>  source "package/audiofile/Config.in"
 Gilles>  source "package/celt051/Config.in"
 Gilles> +source "package/fdk-aac/Config.in"
 Gilles>  source "package/libao/Config.in"
 Gilles>  source "package/libcdaudio/Config.in"
 Gilles>  source "package/libcue/Config.in"
 Gilles> diff --git a/package/fdk-aac/Config.in b/package/fdk-aac/Config.in
 Gilles> new file mode 100644
 Gilles> index 0000000..4fba357
 Gilles> --- /dev/null
 Gilles> +++ b/package/fdk-aac/Config.in
 Gilles> @@ -0,0 +1,12 @@
 Gilles> +config BR2_PACKAGE_FDK_AAC
 Gilles> +	bool "fdk-aac"
 Gilles> +	# These architectures are not supported by FDK AAC
 Gilles> +	depends on !(BR2_bfin || BR2_avr32 || BR2_sparc || BR2_xtensa \
 Gilles> +			|| BR2_microblaze)

Are you sure about these? What about arc and aarch64? Normally we prefer
positive logic so these things don't need to be updated when a new
architecture is added.

With that said, from a 1 minute look at the source code, it looks like
there's specific code for arm/mips/x86, but generic sw fallbacks for
other archs - So perhaps it does work on all archs?

It is written in C++, so you need to depend on BR2_INSTALL_LIBSTDCPP and
show a comment if not available.


 Gilles> +	help
 Gilles> +	  The Fraunhofer FDK AAC Codec Library for Android ("FDK AAC Codec")
 Gilles> +	  is software that implements the MPEG Advanced Audio Coding ("AAC")
 Gilles> +	  encoding and decoding scheme for digital audio
 Gilles> +
 Gilles> +	  http://sourceforge.net/projects/opencore-amr/files/fdk-aac/
 Gilles> +
 Gilles> diff --git a/package/fdk-aac/fdk-aac.mk b/package/fdk-aac/fdk-aac.mk
 Gilles> new file mode 100644
 Gilles> index 0000000..b36f144
 Gilles> --- /dev/null
 Gilles> +++ b/package/fdk-aac/fdk-aac.mk
 Gilles> @@ -0,0 +1,14 @@
 Gilles> +#############################################################
 Gilles> +#
 Gilles> +# fdk-aac
 Gilles> +#
 Gilles> +#############################################################

We make the '#' headers 80 chars wide noadays.


 Gilles> +
 Gilles> +FDK_AAC_VERSION = 0.1.1
 Gilles> +FDK_AAC_SITE = http://downloads.sourceforge.net/project/opencore-amr/fdk-aac
 Gilles> +FDK_AAC_LICENSE = fdk-aac license
 Gilles> +FDK_AAC_LICENSE_FILES = NOTICE
 Gilles> +
 Gilles> +FDK_AAC_INSTALL_STAGING = YES
 Gilles> +
 Gilles> +$(eval $(autotools-package))


Are there no programs in buildroot that can use this library?

Other that these minor issues it looks good, care to send an updated
version fixing them? Thanks.
Gilles Talis July 10, 2013, 5:51 a.m. UTC | #2
Hi Peter and all,


2013/7/9 Peter Korsgaard <jacmet@uclibc.org>
>
> >>>>> "Gilles" == Gilles Talis <gilles.talis@gmail.com> writes:
>
> Hi, and sorry for the slow response.
No worries. Things have been busy around here :-)

>  Gilles> +      # These architectures are not supported by FDK AAC
>  Gilles> +      depends on !(BR2_bfin || BR2_avr32 || BR2_sparc || BR2_xtensa \
>  Gilles> +                      || BR2_microblaze)
>
> Are you sure about these? What about arc and aarch64? Normally we prefer
> positive logic so these things don't need to be updated when a new
> architecture is added.
If I remember well, at the time I tested this, I was getting a
compilation error due to architecture not supported.
I will have to retest. I agree that positive logic is less dangerous.

> With that said, from a 1 minute look at the source code, it looks like
> there's specific code for arm/mips/x86, but generic sw fallbacks for
> other archs - So perhaps it does work on all archs?
Let me retest and see what happens.

> It is written in C++, so you need to depend on BR2_INSTALL_LIBSTDCPP and
> show a comment if not available.
Correct. Well spotted.


>  Gilles> +#############################################################
>  Gilles> +#
>  Gilles> +# fdk-aac
>  Gilles> +#
>  Gilles> +#############################################################
>
> We make the '#' headers 80 chars wide noadays.
OK.


>  Gilles> +
>  Gilles> +FDK_AAC_VERSION = 0.1.1
>  Gilles> +FDK_AAC_SITE = http://downloads.sourceforge.net/project/opencore-amr/fdk-aac
>  Gilles> +FDK_AAC_LICENSE = fdk-aac license
>  Gilles> +FDK_AAC_LICENSE_FILES = NOTICE
>  Gilles> +
>  Gilles> +FDK_AAC_INSTALL_STAGING = YES
>  Gilles> +
>  Gilles> +$(eval $(autotools-package))
>
>
> Are there no programs in buildroot that can use this library?
I think ffmpeg does, but it requires to update ffmpeg version
buildroot is currently using. I first wanted this package to go in
before looking at ffmpeg version bumping.

> Other that these minor issues it looks good, care to send an updated
> version fixing them? Thanks.
Will do. Thanks for the review.

Gilles.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 56fdd2f..9a06284 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -350,6 +350,7 @@  menu "Audio/Sound"
 source "package/alsa-lib/Config.in"
 source "package/audiofile/Config.in"
 source "package/celt051/Config.in"
+source "package/fdk-aac/Config.in"
 source "package/libao/Config.in"
 source "package/libcdaudio/Config.in"
 source "package/libcue/Config.in"
diff --git a/package/fdk-aac/Config.in b/package/fdk-aac/Config.in
new file mode 100644
index 0000000..4fba357
--- /dev/null
+++ b/package/fdk-aac/Config.in
@@ -0,0 +1,12 @@ 
+config BR2_PACKAGE_FDK_AAC
+	bool "fdk-aac"
+	# These architectures are not supported by FDK AAC
+	depends on !(BR2_bfin || BR2_avr32 || BR2_sparc || BR2_xtensa \
+			|| BR2_microblaze)
+	help
+	  The Fraunhofer FDK AAC Codec Library for Android ("FDK AAC Codec")
+	  is software that implements the MPEG Advanced Audio Coding ("AAC")
+	  encoding and decoding scheme for digital audio
+
+	  http://sourceforge.net/projects/opencore-amr/files/fdk-aac/
+
diff --git a/package/fdk-aac/fdk-aac.mk b/package/fdk-aac/fdk-aac.mk
new file mode 100644
index 0000000..b36f144
--- /dev/null
+++ b/package/fdk-aac/fdk-aac.mk
@@ -0,0 +1,14 @@ 
+#############################################################
+#
+# fdk-aac
+#
+#############################################################
+
+FDK_AAC_VERSION = 0.1.1
+FDK_AAC_SITE = http://downloads.sourceforge.net/project/opencore-amr/fdk-aac
+FDK_AAC_LICENSE = fdk-aac license
+FDK_AAC_LICENSE_FILES = NOTICE
+
+FDK_AAC_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))