diff mbox

Makefile: fix cross target

Message ID 1356012991-32494-1-git-send-email-fabio.porcedda@gmail.com
State Superseded
Headers show

Commit Message

Fabio Porcedda Dec. 20, 2012, 2:16 p.m. UTC
The cross target was laking some dependency.
Now it's possible to successfully use the target right
after the configuration.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Dec. 20, 2012, 2:36 p.m. UTC | #1
>>>>> "Fabio" == Fabio Porcedda <fabio.porcedda@gmail.com> writes:

Hi,

 Fabio> The cross target was laking some dependency.
 Fabio> Now it's possible to successfully use the target right
 Fabio> after the configuration.

The fix is fine, but what exactly is your use case for using 'make
cross'? It's not documented anywhere, and I was thinking about dropping
it.
Fabio Porcedda Dec. 20, 2012, 2:51 p.m. UTC | #2
On Thu, Dec 20, 2012 at 3:36 PM, Peter Korsgaard <jacmet@uclibc.org> wrote:
>>>>>> "Fabio" == Fabio Porcedda <fabio.porcedda@gmail.com> writes:
>
> Hi,
>
>  Fabio> The cross target was laking some dependency.
>  Fabio> Now it's possible to successfully use the target right
>  Fabio> after the configuration.
>
> The fix is fine, but what exactly is your use case for using 'make
> cross'? It's not documented anywhere, and I was thinking about dropping
> it.

Sometimes i just want to built/prepare only the toolchain right after
using a defconfig or a make clean,
to be able to use the toolchain for building specific buildroot
packages or compile local source code outside buildroot without build
unnecessary stuff like busybox, rootfs, etc...

If it's useful i can submit a patch to document it.

Best regards
--
Fabio Porcedda
Bjørn Forsman Dec. 20, 2012, 2:55 p.m. UTC | #3
On 20 December 2012 15:51, Fabio Porcedda <fabio.porcedda@gmail.com> wrote:
> On Thu, Dec 20, 2012 at 3:36 PM, Peter Korsgaard <jacmet@uclibc.org> wrote:
>>>>>>> "Fabio" == Fabio Porcedda <fabio.porcedda@gmail.com> writes:
>>
>> Hi,
>>
>>  Fabio> The cross target was laking some dependency.
>>  Fabio> Now it's possible to successfully use the target right
>>  Fabio> after the configuration.
>>
>> The fix is fine, but what exactly is your use case for using 'make
>> cross'? It's not documented anywhere, and I was thinking about dropping
>> it.
>
> Sometimes i just want to built/prepare only the toolchain right after
> using a defconfig or a make clean,
> to be able to use the toolchain for building specific buildroot
> packages or compile local source code outside buildroot without build
> unnecessary stuff like busybox, rootfs, etc...
>
> If it's useful i can submit a patch to document it.

Sounds useful to me. But I'd call the target "toolchain" instead of
"cross". That sounds more like what it does, doesn't it?

Best regards,
Bjørn Forsman
Fabio Porcedda Dec. 20, 2012, 3:06 p.m. UTC | #4
On Thu, Dec 20, 2012 at 3:55 PM, Bjørn Forsman <bjorn.forsman@gmail.com> wrote:
> On 20 December 2012 15:51, Fabio Porcedda <fabio.porcedda@gmail.com> wrote:
>> On Thu, Dec 20, 2012 at 3:36 PM, Peter Korsgaard <jacmet@uclibc.org> wrote:
>>>>>>>> "Fabio" == Fabio Porcedda <fabio.porcedda@gmail.com> writes:
>>>
>>> Hi,
>>>
>>>  Fabio> The cross target was laking some dependency.
>>>  Fabio> Now it's possible to successfully use the target right
>>>  Fabio> after the configuration.
>>>
>>> The fix is fine, but what exactly is your use case for using 'make
>>> cross'? It's not documented anywhere, and I was thinking about dropping
>>> it.
>>
>> Sometimes i just want to built/prepare only the toolchain right after
>> using a defconfig or a make clean,
>> to be able to use the toolchain for building specific buildroot
>> packages or compile local source code outside buildroot without build
>> unnecessary stuff like busybox, rootfs, etc...
>>
>> If it's useful i can submit a patch to document it.
>
> Sounds useful to me. But I'd call the target "toolchain" instead of
> "cross". That sounds more like what it does, doesn't it?

"toolchain" sounds better.
If it's ok i will send an updated patch to rename and document it (make help).

Best regards
--
Fabio Porcedda
Peter Korsgaard Dec. 20, 2012, 4:29 p.m. UTC | #5
>>>>> "Fabio" == Fabio Porcedda <fabio.porcedda@gmail.com> writes:

Hi,

 Fabio> "toolchain" sounds better.

 Fabio> If it's ok i will send an updated patch to rename and document
 Fabio> it (make help).

Yes, please do.
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 4b09437..e163227 100644
--- a/Makefile
+++ b/Makefile
@@ -697,7 +697,7 @@  ifeq ($(O),output)
 endif
 	rm -rf $(CONFIG_DIR)/.config $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/.auto.deps
 
-cross: $(BASE_TARGETS)
+cross: prepare dirs dependencies $(BASE_TARGETS)
 
 help:
 	@echo 'Cleaning:'