diff mbox

strace: fix build for x86_64

Message ID 1351630798-4390-1-git-send-email-arnout@mind.be
State Accepted
Commit 8ada3b45e6af1680f9aafb38cb7425f3bcfa8380
Headers show

Commit Message

Arnout Vandecappelle Oct. 30, 2012, 8:59 p.m. UTC
strace fails to build on x86_64 because stat64 is not available.  This
is because the automatic detection of stat64 in configure is overridden
by buildroot, by setting ac_cv_type_stat64.  Just remove that override -
current strace seems to detect it correctly for non-largefile platforms.

Build-tested on x86_64 (with largefile), ARM (with and without largefile),
sh4, MIPS and ppc-32 (no largefile).

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

---
 package/strace/strace.mk |    3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Peter Korsgaard Oct. 30, 2012, 9:05 p.m. UTC | #1
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 Arnout> strace fails to build on x86_64 because stat64 is not
 Arnout> available.  This is because the automatic detection of stat64
 Arnout> in configure is overridden by buildroot, by setting
 Arnout> ac_cv_type_stat64.  Just remove that override - current strace
 Arnout> seems to detect it correctly for non-largefile platforms.

Committed, thanks.
diff mbox

Patch

diff --git a/package/strace/strace.mk b/package/strace/strace.mk
index 7876848..ad1d042 100644
--- a/package/strace/strace.mk
+++ b/package/strace/strace.mk
@@ -9,8 +9,7 @@  STRACE_SOURCE = strace-$(STRACE_VERSION).tar.xz
 STRACE_SITE = http://downloads.sourceforge.net/project/strace/strace/$(STRACE_VERSION)
 
 STRACE_CONF_ENV = ac_cv_header_linux_if_packet_h=yes \
-		  ac_cv_header_linux_netlink_h=yes \
-	          $(if $(BR2_LARGEFILE),ac_cv_type_stat64=yes,ac_cv_type_stat64=no)
+		  ac_cv_header_linux_netlink_h=yes
 
 ifeq ($(BR2_LARGEFILE),y)
 # strace gets confused when lfs mode is forced, so don't