diff mbox

[PATCHv2,03/10] ctng: add ctng-update-config target

Message ID 1351063027-13800-4-git-send-email-arnout@mind.be
State Superseded
Headers show

Commit Message

Arnout Vandecappelle Oct. 24, 2012, 7:17 a.m. UTC
From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>

Analogous to linux-update-config and friends.

Also update documentation.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 docs/manual/customize-store.txt                  |    8 ++++----
 toolchain/toolchain-crosstool-ng/crosstool-ng.mk |    3 +++
 2 files changed, 7 insertions(+), 4 deletions(-)

Comments

Luca Ceresoli Nov. 7, 2012, 8:12 a.m. UTC | #1
Arnout Vandecappelle (Essensium/Mind) wrote:
> From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
>
> Analogous to linux-update-config and friends.
>
> Also update documentation.
>
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>

Luca
Arnout Vandecappelle Nov. 7, 2012, 8:17 a.m. UTC | #2
On 07/11/12 09:12, Luca Ceresoli wrote:
> Arnout Vandecappelle (Essensium/Mind) wrote:
>> From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
>>
>> Analogous to linux-update-config and friends.
>>
>> Also update documentation.
>>
>> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
>
> Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>

  I guess you mean Acked-by?

  Regards,
  Arnout
Luca Ceresoli Nov. 7, 2012, 8:28 a.m. UTC | #3
Arnout Vandecappelle wrote:
> On 07/11/12 09:12, Luca Ceresoli wrote:
>> Arnout Vandecappelle (Essensium/Mind) wrote:
>>> From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
>>>
>>> Analogous to linux-update-config and friends.
>>>
>>> Also update documentation.
>>>
>>> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
>>
>> Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
>
>   I guess you mean Acked-by?

Oops, of course.

Sorry,
Luca
diff mbox

Patch

diff --git a/docs/manual/customize-store.txt b/docs/manual/customize-store.txt
index 7ca0db3..e8e1d9b 100644
--- a/docs/manual/customize-store.txt
+++ b/docs/manual/customize-store.txt
@@ -58,8 +58,8 @@  configuration files easier.
   path specified by +BR2_PACKAGE_BUSYBOX_CONFIG+.
 * +make uclibc-update-config+ saves the uClibc configuration to the
   path specified by +BR2_UCLIBC_CONFIG+.
-* For crosstool-NG, no helper exists so you have to copy the config
-  file manually to +BR2_TOOLCHAIN_CTNG_CONFIG+.
+* +make ctng-update-config+ saves the crosstool-NG configuration to the
+  patch specified by +BR2_TOOLCHAIN_CTNG_CONFIG+.
 
 
 Creating your own board support
@@ -122,7 +122,7 @@  you can skip the steps that are not relevant for your use case.
 1. Write the configuration files:
    * +make linux-update-defconfig+
    * +make busybox-update-config+
-   * +cp <output>/build/build-toolchain/.config board/<manufacturer>/<boardname>/ctng.config+
+   * +make ctng-update-config+
    * +make uclibc-update-config+
    * +cp <output>/build/at91bootstrap3-*/.config board/<manufacturer>/<boardname>/at91bootstrap3.config+
 1. Create +board/<manufacturer>/<boardname>/fs-overlay+ and fill it
@@ -170,7 +170,7 @@  the buildroot tree).
 1. Write the configuration files:
    * +make linux-update-defconfig+
    * +make busybox-update-config+
-   * +cp <output>/build/build-toolchain/.config <path-to-board-directory>/ctng.config+
+   * +make ctng-update-config+
    * +make uclibc-update-config+
    * +cp <output>/build/at91bootstrap3-*/.config <path-to-board-directory>/at91bootstrap3.config+
 1. Create +<path-to-board-directory>/fs-overlay+ and fill it
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
index e46bb20..fb6da0f 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
@@ -397,3 +397,6 @@  ctng-menuconfig: $(CTNG_DIR)/.config
 	$(call ctng-oldconfig,$<)
 	$(call ctng-check-config-changed,$<,$<.timestamp)
 	$(Q)rm -f $<.timestamp
+
+ctng-update-config: $(CTNG_DIR)/.config
+	cp -f $< $(CTNG_CONFIG_FILE)