diff mbox

unionfs: convert to cmake-package

Message ID 1350128769-13518-1-git-send-email-arnout@mind.be
State Accepted
Commit ee1dd812881cc7928e11addaa18e8185d2b02000
Headers show

Commit Message

Arnout Vandecappelle Oct. 13, 2012, 11:46 a.m. UTC
Fixes e.g. http://autobuild.buildroot.net/results/c279007dd8b89a1c6fc9b58d3c2cda01ab84279e

The addition of CPPFLAGS overrides the defines added in unionfs's
Makefile.  Since unionfs now has CMake support, use that instead.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
With CMake, buildroot's CPPFLAGS are just not used.  This should
probably be corrected in cmake.mk.
 package/unionfs/unionfs.mk |   10 +---------
 1 file changed, 1 insertion(+), 9 deletions(-)

Comments

Peter Korsgaard Oct. 13, 2012, 8:25 p.m. UTC | #1
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 Arnout> Fixes e.g. http://autobuild.buildroot.net/results/c279007dd8b89a1c6fc9b58d3c2cda01ab84279e
 Arnout> The addition of CPPFLAGS overrides the defines added in unionfs's
 Arnout> Makefile.  Since unionfs now has CMake support, use that instead.

Committed, thanks.
diff mbox

Patch

diff --git a/package/unionfs/unionfs.mk b/package/unionfs/unionfs.mk
index eb8109e..6c86c57 100644
--- a/package/unionfs/unionfs.mk
+++ b/package/unionfs/unionfs.mk
@@ -11,12 +11,4 @@  UNIONFS_DEPENDENCIES = libfuse host-pkg-config
 UNIONFS_LICENSE = BSD-3c
 UNIONFS_LICENSE_FILES = LICENSE
 
-define UNIONFS_BUILD_CMDS
-	$(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
-endef
-
-define UNIONFS_INSTALL_TARGET_CMDS
-	$(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) install
-endef
-
-$(eval $(generic-package))
+$(eval $(cmake-package))