@@ -109,6 +109,17 @@ config BR2_PACKAGE_QEMU_SDL
Say 'y' to enable the SDL frontend, that is, a graphical window
presenting the VM's display.
+config BR2_PACKAGE_QEMU_CURSES
+ bool "Enable the curses frontend"
+ select BR2_PACKAGE_NCURSES
+ help
+ Say 'y' to use curses to display the text-mode of VGA outpout.
+
+ If the VM's graphic adapter does not support VGA text-mode, or it
+ is in graphical mode, then nothing will be displayed with this
+ frontend (although you can still use the SDL or VNC frontends to
+ display the graphical output).
+
comment "Block backends"
config BR2_PACKAGE_QEMU_VIRTFS
@@ -81,6 +81,13 @@ else
QEMU_OPTS += --disable-sdl
endif
+ifeq ($(BR2_PACKAGE_QEMU_CURSES),y)
+QEMU_OPTS += --enable-curses
+QEMU_DEPENDENCIES += ncurses
+else
+QEMU_OPTS += --disable-curses
+endif
+
ifeq ($(BR2_PACKAGE_QEMU_VIRTFS),y)
QEMU_OPTS += --enable-virtfs
else
@@ -205,7 +212,6 @@ define QEMU_CONFIGURE_CMDS
--disable-slirp \
--disable-vnc-sasl \
--disable-brlapi \
- --disable-curses \
--disable-fdt \
--disable-bluez \
--disable-guest-base \
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> --- package/qemu/Config.in | 11 +++++++++++ package/qemu/qemu.mk | 8 +++++++- 2 files changed, 18 insertions(+), 1 deletions(-)