diff mbox

[2/2] Ensure DESTDIR will not confuse the build

Message ID 1341238874-1309-2-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit 91123a6fab2770ced312fc54a69f4d83f3a2e1e5
Headers show

Commit Message

Thomas Petazzoni July 2, 2012, 2:21 p.m. UTC
Having DESTDIR defined will confuse the build of certain packages, so
we ensure that it is undefined from the environment when Buildroot
starts.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 Makefile |    4 ++++
 1 file changed, 4 insertions(+)
diff mbox

Patch

diff --git a/Makefile b/Makefile
index bcbe9fc..b80477f 100644
--- a/Makefile
+++ b/Makefile
@@ -168,6 +168,10 @@  export HOSTCC_NOCCACHE HOSTCXX_NOCCACHE
 # Make sure pkg-config doesn't look outside the buildroot tree
 unexport PKG_CONFIG_PATH
 
+# Having DESTDIR set in the environment confuses the installation
+# steps of some packages.
+unexport DESTDIR
+
 # bash prints the name of the directory on 'cd <dir>' if CDPATH is
 # set, so unset it here to not cause problems. Notice that the export
 # line doesn't affect the environment of $(shell ..) calls, so