diff mbox

quota: new package (v2)

Message ID 1338324748-27437-1-git-send-email-jarkko.sakkinen@intel.com
State Superseded
Headers show

Commit Message

Jarkko Sakkinen May 29, 2012, 8:52 p.m. UTC
Added linuxquota package.

[update: added target ld]

Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen@intel.com>
---
 fs/skeleton/etc/network/interfaces |    2 ++
 package/Config.in                  |    3 +++
 package/quota/Config.in            |   11 +++++++++++
 package/quota/quota.mk             |   20 ++++++++++++++++++++
 4 files changed, 36 insertions(+)
 create mode 100644 package/quota/Config.in
 create mode 100644 package/quota/quota.mk

Comments

Gustavo Zacarias May 29, 2012, 8:56 p.m. UTC | #1
On 2012-05-29 17:52, Jarkko Sakkinen wrote:

> --- a/fs/skeleton/etc/network/interfaces
> +++ b/fs/skeleton/etc/network/interfaces
> @@ -2,3 +2,5 @@
>  auto lo
>  iface lo inet loopback
>
> +auto eth0
> +iface eth0 inet dhcp

Oops? It shouldn't be touching this file.

> +QUOTA_SOURCE = quota-$(QUOTA_VERSION).tar.gz

Not strictly necessary, it's the default, though it's a minor detail.
Regards.
Thomas Petazzoni May 29, 2012, 9:01 p.m. UTC | #2
Le Tue, 29 May 2012 23:52:28 +0300,
Jarkko Sakkinen <jarkko.sakkinen@intel.com> a écrit :

>  fs/skeleton/etc/network/interfaces |    2 ++

Why do you need to change this file? The change is specific to the fact
of having an eth0 interface configured using dhcp, which may not be
necessarily the case. Can you justify why such a change is needed for
this new quota package?

Thanks!

Thomas
Jarkko Sakkinen May 30, 2012, 5:49 a.m. UTC | #3
Hi

On Tue, 29 May 2012, Gustavo Zacarias wrote:

> On 2012-05-29 17:52, Jarkko Sakkinen wrote:
>
>> --- a/fs/skeleton/etc/network/interfaces
>> +++ b/fs/skeleton/etc/network/interfaces
>> @@ -2,3 +2,5 @@
>>  auto lo
>>  iface lo inet loopback
>> 
>> +auto eth0
>> +iface eth0 inet dhcp
>
> Oops? It shouldn't be touching this file.

Sorry about, slipped in by mistake. I revised it soon after
sending this:

http://patchwork.ozlabs.org/patch/161803/

>
>> +QUOTA_SOURCE = quota-$(QUOTA_VERSION).tar.gz
>
> Not strictly necessary, it's the default, though it's a minor detail.
> Regards.
>

/Jarkko
diff mbox

Patch

diff --git a/fs/skeleton/etc/network/interfaces b/fs/skeleton/etc/network/interfaces
index 218b82c..e70b502 100644
--- a/fs/skeleton/etc/network/interfaces
+++ b/fs/skeleton/etc/network/interfaces
@@ -2,3 +2,5 @@ 
 auto lo
 iface lo inet loopback
 
+auto eth0
+iface eth0 inet dhcp
diff --git a/package/Config.in b/package/Config.in
index fb1b08f..eb76e14 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -632,6 +632,9 @@  if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/module-init-tools/Config.in"
 source "package/procps/Config.in"
 source "package/psmisc/Config.in"
+endif
+source "package/quota/Config.in"
+if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/rsyslog/Config.in"
 source "package/sysklogd/Config.in"
 source "package/sysvinit/Config.in"
diff --git a/package/quota/Config.in b/package/quota/Config.in
new file mode 100644
index 0000000..a2fa9b6
--- /dev/null
+++ b/package/quota/Config.in
@@ -0,0 +1,11 @@ 
+config BR2_PACKAGE_QUOTA
+	bool "quota"
+	depends on BR2_INET_RPC
+	select BR2_PACKAGE_UTIL_LINUX
+	select BR2_PACKAGE_UTIL_LINUX_MOUNT
+	help
+		Implementation of the disk quota system.
+		http://sourceforge.net/projects/linuxquota/
+
+comment "quota requires a toolchain with RPC support"
+	depends on !BR2_INET_RPC
diff --git a/package/quota/quota.mk b/package/quota/quota.mk
new file mode 100644
index 0000000..5fd83c7
--- /dev/null
+++ b/package/quota/quota.mk
@@ -0,0 +1,20 @@ 
+#############################################################
+#
+# QUOTA
+#
+#############################################################
+
+QUOTA_VERSION = 4.00
+QUOTA_SOURCE = quota-$(QUOTA_VERSION).tar.gz
+QUOTA_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/project/linuxquota/quota-tools/$(QUOTA_VERSION)
+
+QUOTA_MAKE_OPT = \
+	CC="$(TARGET_CC)" \
+	CXX="$(TARGET_CXX)" \
+	LD="$(TARGET_LD)"
+
+QUOTA_INSTALL_TARGET_OPT = \
+	ROOTDIR=$(TARGET_DIR) \
+	install
+
+$(eval $(call AUTOTARGETS))