diff mbox

Add new package apr-util

Message ID 1335262302-31058-1-git-send-email-bachmann@tofwerk.com
State Superseded, archived
Headers show

Commit Message

Rico Bachmann April 24, 2012, 10:11 a.m. UTC
Signed-off-by: Rico Bachmann <bachmann@tofwerk.com>
---
v1: Add package apr-util
    Add patch to remove check for apr
    because check for apr search for ./apr and not for defined folder
---
 package/Config.in                                  |    1 +
 package/apr-util/Config.in                         |    7 +++++++
 .../apr-util/apr-util-1.4.1-remove-checkapr.patch  |   12 ++++++++++++
 package/apr-util/apr-util.mk                       |   14 ++++++++++++++
 4 files changed, 34 insertions(+), 0 deletions(-)
 create mode 100644 package/apr-util/Config.in
 create mode 100644 package/apr-util/apr-util-1.4.1-remove-checkapr.patch
 create mode 100644 package/apr-util/apr-util.mk

Comments

Thomas Petazzoni April 24, 2012, 10:24 a.m. UTC | #1
Le Tue, 24 Apr 2012 12:11:42 +0200,
Rico Bachmann <bachmann@tofwerk.com> a écrit :

> +diff -rupN apr-util-1.4.1/configure.in apr-util-1.4.1-fix/configure.in
> +--- apr-util-1.4.1/configure.in	2009-12-17 20:15:19.000000000 +0100
> ++++ apr-util-1.4.1-fix/configure.in	2012-04-24 10:10:32.000000000 +0200

This patch lacks a header explaining what it is doing, why, and a
Signed-off-by line.

I'm also not convinced by this patch, can you detail why it is
necessary? I have the impression that by passing the right environment
variables and/or options to the configure script, you can convince it
to do the right thing, but I haven't looked into too much details about
how APU_FIND_APR is implemented.

Regards,

Thomas
Rico Bachmann April 24, 2012, 10:51 a.m. UTC | #2
Am 24.04.2012, 12:24 Uhr, schrieb Thomas Petazzoni  
<thomas.petazzoni@free-electrons.com>:

> Le Tue, 24 Apr 2012 12:11:42 +0200,
> Rico Bachmann <bachmann@tofwerk.com> a écrit :
>
>> +diff -rupN apr-util-1.4.1/configure.in apr-util-1.4.1-fix/configure.in
>> +--- apr-util-1.4.1/configure.in	2009-12-17 20:15:19.000000000 +0100
>> ++++ apr-util-1.4.1-fix/configure.in	2012-04-24 10:10:32.000000000 +0200
>
> This patch lacks a header explaining what it is doing, why, and a
> Signed-off-by line.

I added the Signed-off-by line and added some comments, I will send it  
soon.

>
> I'm also not convinced by this patch, can you detail why it is
> necessary? I have the impression that by passing the right environment
> variables and/or options to the configure script, you can convince it
> to do the right thing, but I haven't looked into too much details about
> how APU_FIND_APR is implemented.

I asked for some help in #apr, they told me that the check of the source  
folder
only works on folders called apr. Because I don't want to rename the source
folder of the apr package (from apr-1.4.6 to apr), I disabled the check  
and the
build works nice for me

I also haven't looked to much in the implementation of APU_FIND_APR, so I  
decided
to do the way of not checking...

>
> Regards,
>
> Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 5ae1c81..805f56a 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -375,6 +375,7 @@  endmenu
 
 menu "Other"
 source "package/apr/Config.in"
+source "package/apr-util/Config.in"
 source "package/fftw/Config.in"
 source "package/libargtable2/Config.in"
 source "package/argp-standalone/Config.in"
diff --git a/package/apr-util/Config.in b/package/apr-util/Config.in
new file mode 100644
index 0000000..a4411ba
--- /dev/null
+++ b/package/apr-util/Config.in
@@ -0,0 +1,7 @@ 
+config BR2_PACKAGE_APR_UTIL
+	bool "apr-util"
+	select BR2_PACKAGE_APR
+	help
+	  The utility library for the apache runtime project
+
+	  http://apr.apache.org/
diff --git a/package/apr-util/apr-util-1.4.1-remove-checkapr.patch b/package/apr-util/apr-util-1.4.1-remove-checkapr.patch
new file mode 100644
index 0000000..46cc595
--- /dev/null
+++ b/package/apr-util/apr-util-1.4.1-remove-checkapr.patch
@@ -0,0 +1,12 @@ 
+diff -rupN apr-util-1.4.1/configure.in apr-util-1.4.1-fix/configure.in
+--- apr-util-1.4.1/configure.in	2009-12-17 20:15:19.000000000 +0100
++++ apr-util-1.4.1-fix/configure.in	2012-04-24 10:10:32.000000000 +0200
+@@ -99,7 +99,7 @@ fi
+ dnl
+ dnl Find the APR includes directory and (possibly) the source (base) dir.
+ dnl
+-APU_FIND_APR
++dnl APU_FIND_APR
+ 
+ dnl
+ dnl even though we use apr_rules.mk for building apr-util, we need
diff --git a/package/apr-util/apr-util.mk b/package/apr-util/apr-util.mk
new file mode 100644
index 0000000..8c977fa
--- /dev/null
+++ b/package/apr-util/apr-util.mk
@@ -0,0 +1,14 @@ 
+#############################################################
+#
+# apr-util
+#
+#############################################################
+APR_UTIL_VERSION = 1.4.1
+APR_UTIL_SITE = http://archive.apache.org/dist/apr
+APR_UTIL_INSTALL_STAGING = YES
+APR_UTIL_DEPENDENCIES = apr
+APR_UTIL_CONF_OPT = \
+	--prefix=/usr \
+        --with-apr=$(BUILD_DIR)/apr-$(APR_VERSION)
+
+$(eval $(call AUTOTARGETS))