diff mbox

Add cortex-a8 cpu spec to ffmpeg neon config.

Message ID 1335136731-4509-1-git-send-email-d_mo1234@yahoo.com
State Rejected
Headers show

Commit Message

Danomi Manchego April 22, 2012, 11:18 p.m. UTC
Since neon support is specific to Arm Cortex-A8, and buildroot
recognizes this by having a specific Cortex-A8 clause in ffmpeg.mk,
let's add the --cpu needed to make the ffmpeg configuration actually
report the arch as "arm (cortex-a8)", instead of just "arm (generic)".

Signed-off-by: Danomi Manchego <d_mo1234@yahoo.com>
---
 package/multimedia/ffmpeg/ffmpeg.mk |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Comments

Thomas Petazzoni March 24, 2013, 11:45 a.m. UTC | #1
Dear Danomi Manchego,

On Sun, 22 Apr 2012 19:18:51 -0400, Danomi Manchego wrote:
> Since neon support is specific to Arm Cortex-A8, and buildroot
> recognizes this by having a specific Cortex-A8 clause in ffmpeg.mk,
> let's add the --cpu needed to make the ffmpeg configuration actually
> report the arch as "arm (cortex-a8)", instead of just "arm (generic)".
> 
> Signed-off-by: Danomi Manchego <d_mo1234@yahoo.com>
> ---
>  package/multimedia/ffmpeg/ffmpeg.mk |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/package/multimedia/ffmpeg/ffmpeg.mk b/package/multimedia/ffmpeg/ffmpeg.mk
> index 4cc29ee..633ec9e 100644
> --- a/package/multimedia/ffmpeg/ffmpeg.mk
> +++ b/package/multimedia/ffmpeg/ffmpeg.mk
> @@ -145,7 +145,7 @@ FFMPEG_CONF_OPT += --enable-armvfp
>  endif
>  # NEON is optional for A9
>  ifeq ($(BR2_cortex_a8),y)
> -FFMPEG_CONF_OPT += --enable-neon
> +FFMPEG_CONF_OPT += --enable-neon --cpu=cortex-a8
>  endif

I believe this patch is not useful, because the only effect of
--cpu=<foo> options in ffmpeg configure is to add the relevant -march,
-mcpu and al. gcc options. But Buildroot is already passing them: in
the internal and Crosstool-NG toolchain backends, the toolchain is
built to automatically generate code for the selected CPU, and for the
external toolchain backend, a wrapper automatically passes
-mcpu/-march/-mtune to the compiler.

Therefore, this patch is not needed IMO, and I've removed it from the
patch work. If you don't agree, do not hesitate to send an updated
version that includes more details as to why it is needed.

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/multimedia/ffmpeg/ffmpeg.mk b/package/multimedia/ffmpeg/ffmpeg.mk
index 4cc29ee..633ec9e 100644
--- a/package/multimedia/ffmpeg/ffmpeg.mk
+++ b/package/multimedia/ffmpeg/ffmpeg.mk
@@ -145,7 +145,7 @@  FFMPEG_CONF_OPT += --enable-armvfp
 endif
 # NEON is optional for A9
 ifeq ($(BR2_cortex_a8),y)
-FFMPEG_CONF_OPT += --enable-neon
+FFMPEG_CONF_OPT += --enable-neon --cpu=cortex-a8
 endif
 # Set powerpc altivec appropriately
 ifeq ($(BR2_powerpc),y)