diff mbox

Add fmtools package.

Message ID 1333231898-20980-1-git-send-email-marek.belisko@open-nandra.com
State Not Applicable
Headers show

Commit Message

Marek Belisko March 31, 2012, 10:11 p.m. UTC
Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com>
---
 package/Config.in          |    1 +
 package/fmtools/Config.in  |    9 +++++++++
 package/fmtools/fmtools.mk |   19 +++++++++++++++++++
 3 files changed, 29 insertions(+), 0 deletions(-)
 create mode 100644 package/fmtools/Config.in
 create mode 100644 package/fmtools/fmtools.mk

Comments

Baruch Siach April 1, 2012, 4:53 a.m. UTC | #1
Hi Marek,

On Sun, Apr 01, 2012 at 12:11:38AM +0200, Marek Belisko wrote:
> Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com>

[snip]

> new file mode 100644
> index 0000000..c03afbc
> --- /dev/null
> +++ b/package/fmtools/fmtools.mk
> @@ -0,0 +1,19 @@
> +#############################################################
> +#
> +# fmtools
> +#
> +#############################################################
> +
> +FMTOOLS_VERSION = 1.0.2
> +FMTOOLS_SITE = http://www.stanford.edu/~blp/fmtools/
> +
> +define FMTOOLS_BUILD_CMDS
> +	$(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_LD)" -C $(@D) all

Just use $(TARGET_CONFIGURE_OPTS) instead of setting CC and LD individually.

> +endef
> +
> +define FMTOOLS_INSTALL_TARGET_CMDS
> +	$(INSTALL) -D -m 0755 $(@D)/fm $(TARGET_DIR)/usr/sbin
> +	$(INSTALL) -D -m 0755 $(@D)/fmscan $(TARGET_DIR)/usr/sbin
> +endef
> +
> +$(eval $(call GENTARGETS))

baruch
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 68d28fa..94faf44 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -175,6 +175,7 @@  source "package/e2fsprogs/Config.in"
 source "package/eeprog/Config.in"
 source "package/fconfig/Config.in"
 source "package/fis/Config.in"
+source "package/fmtools/Config.in"
 source "package/gadgetfs-test/Config.in"
 source "package/gdisk/Config.in"
 source "package/genext2fs/Config.in"
diff --git a/package/fmtools/Config.in b/package/fmtools/Config.in
new file mode 100644
index 0000000..41c883c
--- /dev/null
+++ b/package/fmtools/Config.in
@@ -0,0 +1,9 @@ 
+config BR2_PACKAGE_FMTOOLS
+	bool "fmtools"
+	help
+	  fmtools is a pair of simple command-line utilities for
+	  “video4linux” radio tuner cards under Linux. It includes
+	  fm for power control, tuning, and volume and fmscan for
+	  scanning for stations.
+
+	  http://www.stanford.edu/~blp/fmtools/
diff --git a/package/fmtools/fmtools.mk b/package/fmtools/fmtools.mk
new file mode 100644
index 0000000..c03afbc
--- /dev/null
+++ b/package/fmtools/fmtools.mk
@@ -0,0 +1,19 @@ 
+#############################################################
+#
+# fmtools
+#
+#############################################################
+
+FMTOOLS_VERSION = 1.0.2
+FMTOOLS_SITE = http://www.stanford.edu/~blp/fmtools/
+
+define FMTOOLS_BUILD_CMDS
+	$(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_LD)" -C $(@D) all
+endef
+
+define FMTOOLS_INSTALL_TARGET_CMDS
+	$(INSTALL) -D -m 0755 $(@D)/fm $(TARGET_DIR)/usr/sbin
+	$(INSTALL) -D -m 0755 $(@D)/fmscan $(TARGET_DIR)/usr/sbin
+endef
+
+$(eval $(call GENTARGETS))