diff mbox

linux.mk: .ub-File copying after building initramfs

Message ID 1332292744-11797-1-git-send-email-markus.kaindl@stusta.mhn.de
State Accepted
Headers show

Commit Message

Markus Kaindl March 21, 2012, 1:19 a.m. UTC
test should exit with Exit-Code 0 if no .ub-File present and copy the
file if Exit-Code 1, otherwise make fails

Signed-off-by: Markus Kaindl <markus.kaindl@stusta.mhn.de>
---
 linux/linux.mk |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Comments

Peter Korsgaard March 21, 2012, 10:44 a.m. UTC | #1
>>>>> "Markus" == Markus Kaindl <markus.kaindl@stusta.mhn.de> writes:

 Markus> test should exit with Exit-Code 0 if no .ub-File present and copy the
 Markus> file if Exit-Code 1, otherwise make fails

Committed, thanks.
diff mbox

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index 2a29de8..2fb890e 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -230,7 +230,7 @@  $(LINUX_DIR)/.stamp_initramfs_rebuilt: $(LINUX_DIR)/.stamp_target_installed $(LI
 	# Copy the kernel image to its final destination
 	cp $(LINUX_IMAGE_PATH) $(BINARIES_DIR)
 	# If there is a .ub file copy it to the final destination
-	test -f $(LINUX_IMAGE_PATH).ub && cp $(LINUX_IMAGE_PATH).ub $(BINARIES_DIR)
+	test ! -f $(LINUX_IMAGE_PATH).ub || cp $(LINUX_IMAGE_PATH).ub $(BINARIES_DIR)
 	$(Q)touch $@
 
 # The initramfs building code must make sure this target gets called