diff mbox

[23/30] package/matchbox: drop useless dependencies

Message ID 0f88fac02eba1f18605db80731bfb130d00721cb.1429725549.git.yann.morin.1998@free.fr
State Changes Requested
Headers show

Commit Message

Yann E. MORIN April 22, 2015, 6:09 p.m. UTC
xlib-libXft is only needed when building a 'standalone' matchbox, which
means not using matchbox-lib.

But we *are* building matchbox-lib, and we do not support the standalone
mode (and probably won't, as even upstream says it is ugly, by lack of
theming).

Similarly, xlib-libXext is only used for its 'xsync' extension, for
which support is entirely commented-out in matchbox.

So, drop the dependency on xlib-libXft, and make it explicit we're not
building either standalone modes; drop xlib-libXext.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 package/matchbox/Config.in   | 1 -
 package/matchbox/matchbox.mk | 6 +++++-
 2 files changed, 5 insertions(+), 2 deletions(-)

Comments

Arnout Vandecappelle May 1, 2015, 8:41 p.m. UTC | #1
On 22/04/15 20:09, Yann E. MORIN wrote:
> xlib-libXft is only needed when building a 'standalone' matchbox, which
> means not using matchbox-lib.
> 
> But we *are* building matchbox-lib, and we do not support the standalone
> mode (and probably won't, as even upstream says it is ugly, by lack of
> theming).
> 
> Similarly, xlib-libXext is only used for its 'xsync' extension, for
> which support is entirely commented-out in matchbox.
> 
> So, drop the dependency on xlib-libXft, and make it explicit we're not
> building either standalone modes; drop xlib-libXext.
> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> ---
>  package/matchbox/Config.in   | 1 -
>  package/matchbox/matchbox.mk | 6 +++++-
>  2 files changed, 5 insertions(+), 2 deletions(-)
> 
> diff --git a/package/matchbox/Config.in b/package/matchbox/Config.in
> index 9d8d060..fa186e9 100644
> --- a/package/matchbox/Config.in
> +++ b/package/matchbox/Config.in
> @@ -4,7 +4,6 @@ menuconfig BR2_PACKAGE_MATCHBOX
>  	depends on BR2_USE_MMU # fork()
>  	select BR2_PACKAGE_FONTCONFIG
>  	select BR2_PACKAGE_EXPAT
> -	select BR2_PACKAGE_XLIB_LIBXEXT
>  	select BR2_PACKAGE_XLIB_LIBXCURSOR
>  	select BR2_PACKAGE_MATCHBOX_LIB
>  	help
> diff --git a/package/matchbox/matchbox.mk b/package/matchbox/matchbox.mk
> index 4ec3fb5..bce9520 100644
> --- a/package/matchbox/matchbox.mk
> +++ b/package/matchbox/matchbox.mk
> @@ -11,7 +11,11 @@ MATCHBOX_LICENSE = GPLv2+
>  MATCHBOX_LICENSE_FILES = COPYING
>  
>  MATCHBOX_DEPENDENCIES = matchbox-lib
> -MATCHBOX_CONF_OPTS = --enable-expat --disable-composite
> +MATCHBOX_CONF_OPTS = \
> +	--enable-expat \
> +	--disable-composite \
> +	--disable-standalone \
> +	--disable-standalone-xft

 So, is the dependency on xlib_libXft a few lines lower still relevant? If so,
comment on it in the commit message.

 Regards,
 Arnout

>  
>  # Workaround bug in configure script
>  MATCHBOX_CONF_ENV = expat=yes
>
Arnout Vandecappelle May 1, 2015, 8:58 p.m. UTC | #2
On 01/05/15 22:41, Arnout Vandecappelle wrote:
> On 22/04/15 20:09, Yann E. MORIN wrote:
>> xlib-libXft is only needed when building a 'standalone' matchbox, which
>> means not using matchbox-lib.
>>
>> But we *are* building matchbox-lib, and we do not support the standalone
>> mode (and probably won't, as even upstream says it is ugly, by lack of
>> theming).
>>
>> Similarly, xlib-libXext is only used for its 'xsync' extension, for
>> which support is entirely commented-out in matchbox.
>>
>> So, drop the dependency on xlib-libXft, and make it explicit we're not
>> building either standalone modes; drop xlib-libXext.
>>
>> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
>> ---
>>  package/matchbox/Config.in   | 1 -
>>  package/matchbox/matchbox.mk | 6 +++++-
>>  2 files changed, 5 insertions(+), 2 deletions(-)
>>
>> diff --git a/package/matchbox/Config.in b/package/matchbox/Config.in
>> index 9d8d060..fa186e9 100644
>> --- a/package/matchbox/Config.in
>> +++ b/package/matchbox/Config.in
>> @@ -4,7 +4,6 @@ menuconfig BR2_PACKAGE_MATCHBOX
>>  	depends on BR2_USE_MMU # fork()
>>  	select BR2_PACKAGE_FONTCONFIG
>>  	select BR2_PACKAGE_EXPAT
>> -	select BR2_PACKAGE_XLIB_LIBXEXT
>>  	select BR2_PACKAGE_XLIB_LIBXCURSOR
>>  	select BR2_PACKAGE_MATCHBOX_LIB
>>  	help
>> diff --git a/package/matchbox/matchbox.mk b/package/matchbox/matchbox.mk
>> index 4ec3fb5..bce9520 100644
>> --- a/package/matchbox/matchbox.mk
>> +++ b/package/matchbox/matchbox.mk
>> @@ -11,7 +11,11 @@ MATCHBOX_LICENSE = GPLv2+
>>  MATCHBOX_LICENSE_FILES = COPYING
>>  
>>  MATCHBOX_DEPENDENCIES = matchbox-lib
>> -MATCHBOX_CONF_OPTS = --enable-expat --disable-composite
>> +MATCHBOX_CONF_OPTS = \
>> +	--enable-expat \
>> +	--disable-composite \
>> +	--disable-standalone \
>> +	--disable-standalone-xft
> 
>  So, is the dependency on xlib_libXft a few lines lower still relevant? If so,
> comment on it in the commit message.

 It actually is, configure checks for it and it is used in the code. So
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
but I'd still like it to be mentioned in the commit message.

 Regards,
 Arnout

> 
>  Regards,
>  Arnout
> 
>>  
>>  # Workaround bug in configure script
>>  MATCHBOX_CONF_ENV = expat=yes
>>
> 
>
Yann E. MORIN May 2, 2015, 1:40 p.m. UTC | #3
Arnout, All,

On 2015-05-01 22:58 +0200, Arnout Vandecappelle spake thusly:
> On 01/05/15 22:41, Arnout Vandecappelle wrote:
> > On 22/04/15 20:09, Yann E. MORIN wrote:
> >> xlib-libXft is only needed when building a 'standalone' matchbox, which
> >> means not using matchbox-lib.
> >>
> >> But we *are* building matchbox-lib, and we do not support the standalone
> >> mode (and probably won't, as even upstream says it is ugly, by lack of
> >> theming).
> >>
> >> Similarly, xlib-libXext is only used for its 'xsync' extension, for
> >> which support is entirely commented-out in matchbox.
> >>
> >> So, drop the dependency on xlib-libXft, and make it explicit we're not
> >> building either standalone modes; drop xlib-libXext.
> >>
> >> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> >> ---
> >>  package/matchbox/Config.in   | 1 -
> >>  package/matchbox/matchbox.mk | 6 +++++-
> >>  2 files changed, 5 insertions(+), 2 deletions(-)
> >>
> >> diff --git a/package/matchbox/Config.in b/package/matchbox/Config.in
> >> index 9d8d060..fa186e9 100644
> >> --- a/package/matchbox/Config.in
> >> +++ b/package/matchbox/Config.in
> >> @@ -4,7 +4,6 @@ menuconfig BR2_PACKAGE_MATCHBOX
> >>  	depends on BR2_USE_MMU # fork()
> >>  	select BR2_PACKAGE_FONTCONFIG
> >>  	select BR2_PACKAGE_EXPAT
> >> -	select BR2_PACKAGE_XLIB_LIBXEXT
> >>  	select BR2_PACKAGE_XLIB_LIBXCURSOR
> >>  	select BR2_PACKAGE_MATCHBOX_LIB
> >>  	help
> >> diff --git a/package/matchbox/matchbox.mk b/package/matchbox/matchbox.mk
> >> index 4ec3fb5..bce9520 100644
> >> --- a/package/matchbox/matchbox.mk
> >> +++ b/package/matchbox/matchbox.mk
> >> @@ -11,7 +11,11 @@ MATCHBOX_LICENSE = GPLv2+
> >>  MATCHBOX_LICENSE_FILES = COPYING
> >>  
> >>  MATCHBOX_DEPENDENCIES = matchbox-lib
> >> -MATCHBOX_CONF_OPTS = --enable-expat --disable-composite
> >> +MATCHBOX_CONF_OPTS = \
> >> +	--enable-expat \
> >> +	--disable-composite \
> >> +	--disable-standalone \
> >> +	--disable-standalone-xft
> > 
> >  So, is the dependency on xlib_libXft a few lines lower still relevant? If so,
> > comment on it in the commit message.
> 
>  It actually is, configure checks for it and it is used in the code. So
> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> but I'd still like it to be mentioned in the commit message.

Well, not sure. AFAICS, checks for libxft are done only when either
standalone or standalone-xft is specified. Also, Xft is only used in
src/mbtheme-standalone.c, which as its name implies, is the standalone
mode.

So, I'll remove that dependency in the patch that disable standalone
mode (pending a test-build without libXft, but pretty confident it'll
work, nothing selects it in matchbox, I never manually selected it, and
all my previous builds were successfull).

Thanks!

Regards,
Yann E. MORIN.
Yann E. MORIN May 2, 2015, 2:12 p.m. UTC | #4
Arnout, All,

On 2015-05-02 15:40 +0200, Yann E. MORIN spake thusly:
> On 2015-05-01 22:58 +0200, Arnout Vandecappelle spake thusly:
> > On 01/05/15 22:41, Arnout Vandecappelle wrote:
> > > On 22/04/15 20:09, Yann E. MORIN wrote:
> > >> xlib-libXft is only needed when building a 'standalone' matchbox, which
> > >> means not using matchbox-lib.
[--SNIP--]
> > >  So, is the dependency on xlib_libXft a few lines lower still relevant? If so,
> > > comment on it in the commit message.
> > 
> >  It actually is, configure checks for it and it is used in the code. So
> > Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> > but I'd still like it to be mentioned in the commit message.
> 
> Well, not sure. AFAICS, checks for libxft are done only when either
> standalone or standalone-xft is specified. Also, Xft is only used in
> src/mbtheme-standalone.c, which as its name implies, is the standalone
> mode.
> 
> So, I'll remove that dependency in the patch that disable standalone
> mode (pending a test-build without libXft, but pretty confident it'll
> work, nothing selects it in matchbox, I never manually selected it, and
> all my previous builds were successfull).

OK, the build goes on successfully as expected.

So I'll drop the dependency on libXft.

Thanks! :-)

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/matchbox/Config.in b/package/matchbox/Config.in
index 9d8d060..fa186e9 100644
--- a/package/matchbox/Config.in
+++ b/package/matchbox/Config.in
@@ -4,7 +4,6 @@  menuconfig BR2_PACKAGE_MATCHBOX
 	depends on BR2_USE_MMU # fork()
 	select BR2_PACKAGE_FONTCONFIG
 	select BR2_PACKAGE_EXPAT
-	select BR2_PACKAGE_XLIB_LIBXEXT
 	select BR2_PACKAGE_XLIB_LIBXCURSOR
 	select BR2_PACKAGE_MATCHBOX_LIB
 	help
diff --git a/package/matchbox/matchbox.mk b/package/matchbox/matchbox.mk
index 4ec3fb5..bce9520 100644
--- a/package/matchbox/matchbox.mk
+++ b/package/matchbox/matchbox.mk
@@ -11,7 +11,11 @@  MATCHBOX_LICENSE = GPLv2+
 MATCHBOX_LICENSE_FILES = COPYING
 
 MATCHBOX_DEPENDENCIES = matchbox-lib
-MATCHBOX_CONF_OPTS = --enable-expat --disable-composite
+MATCHBOX_CONF_OPTS = \
+	--enable-expat \
+	--disable-composite \
+	--disable-standalone \
+	--disable-standalone-xft
 
 # Workaround bug in configure script
 MATCHBOX_CONF_ENV = expat=yes