@@ -21,3 +21,16 @@ config BR2_PACKAGE_SPICE
This package implements the server-part of Spice.
http://www.spice-space.org/
+
+if BR2_PACKAGE_SPICE
+
+comment "client depends on X.org"
+ depends on !BR2_PACKAGE_XORG7
+
+config BR2_PACKAGE_SPICE_CLIENT
+ bool "Enable client"
+ depends on BR2_PACKAGE_XORG7
+ select BR2_PACKAGE_XLIB_LIBXFIXES
+ select BR2_PACKAGE_XLIB_LIBXRANDR
+
+endif # BR2_PACKAGE_SPICE
@@ -26,12 +26,18 @@ SPICE_CONF_OPT = \
--disable-gui \
--disable-opengl \
--disable-smartcard \
- --disable-client \
--disable-automated-tests \
--without-sasl \
SPICE_DEPENDENCIES += host-pkgconf
+ifeq ($(BR2_PACKAGE_SPICE_CLIENT),y)
+SPICE_CONF_OPT += --enable-client
+SPICE_DEPENDENCIES += xlib_libXfixes xlib_libXrandr
+else
+SPICE_CONF_OPT += --disable-client
+endif
+
SPICE_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
SPICE_MAKE_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> --- package/spice/Config.in | 13 +++++++++++++ package/spice/spice.mk | 8 +++++++- 2 files changed, 20 insertions(+), 1 deletions(-)