diff mbox

powerpc/mm: Move page table dump into powerpc subdirectory

Message ID 20170413124148.EB6C76E664@localhost.localdomain (mailing list archive)
State Rejected
Headers show

Commit Message

Christophe Leroy April 13, 2017, 12:41 p.m. UTC
Page table dump is a powerpc specific thing, so it should
appear in powerpc/ subdirectory of debugfs

Signed-off-by: Christophe Leroy <christophe.leroy@c-s.fr>
---
 arch/powerpc/mm/dump_linuxpagetables.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Michael Ellerman April 13, 2017, 1:20 p.m. UTC | #1
Christophe Leroy <christophe.leroy@c-s.fr> writes:

> Page table dump is a powerpc specific thing, so it should
> appear in powerpc/ subdirectory of debugfs

It's not powerpc specific. x86, arm, arm64 and s390 all have it.

But, I notice we somehow got the name wrong :}

All the other arches call it "kernel_page_tables".

> -	debugfs_file = debugfs_create_file("kernel_pagetables", 0400, NULL,
> -			NULL, &ptdump_fops);

¯\_(ツ)_/¯


So we probably should rename it to match the other arches. I would take
a patch for that.

cheers
diff mbox

Patch

diff --git a/arch/powerpc/mm/dump_linuxpagetables.c b/arch/powerpc/mm/dump_linuxpagetables.c
index 22d2433333f5..df7664ea7ede 100644
--- a/arch/powerpc/mm/dump_linuxpagetables.c
+++ b/arch/powerpc/mm/dump_linuxpagetables.c
@@ -14,7 +14,7 @@ 
  * as published by the Free Software Foundation; version 2
  * of the License.
  */
-#include <linux/debugfs.h>
+#include <asm/debugfs.h>
 #include <linux/fs.h>
 #include <linux/io.h>
 #include <linux/mm.h>
@@ -483,8 +483,8 @@  static int ptdump_init(void)
 
 	populate_markers();
 	build_pgtable_complete_mask();
-	debugfs_file = debugfs_create_file("kernel_pagetables", 0400, NULL,
-			NULL, &ptdump_fops);
+	debugfs_file = debugfs_create_file("kernel_pagetables", 0400,
+			powerpc_debugfs_root, NULL, &ptdump_fops);
 	return debugfs_file ? 0 : -ENOMEM;
 }
 device_initcall(ptdump_init);