diff mbox series

disk: part: rename parameter of lba512_muldiv()

Message ID 20200116193658.5819-1-xypron.glpk@gmx.de
State Accepted
Commit a9d1c0e2bc3fced595b742d90e65c744c55616b3
Delegated to: Tom Rini
Headers show
Series disk: part: rename parameter of lba512_muldiv() | expand

Commit Message

Heinrich Schuchardt Jan. 16, 2020, 7:36 p.m. UTC
div_by is a misleading parameter name, when we are doing >> div_by.
Rename it to right_shift.

Reported-by: Simon Glass <sjg@chromium.org>
Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
---
 disk/part.c | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)

--
2.24.1

Comments

Tom Rini Jan. 23, 2020, 10:01 p.m. UTC | #1
On Thu, Jan 16, 2020 at 08:36:58PM +0100, Heinrich Schuchardt wrote:

> div_by is a misleading parameter name, when we are doing >> div_by.
> Rename it to right_shift.
> 
> Reported-by: Simon Glass <sjg@chromium.org>
> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>

Applied to u-boot/master, thanks!
diff mbox series

Patch

diff --git a/disk/part.c b/disk/part.c
index 8982ef3bae..4cc2fc19f7 100644
--- a/disk/part.c
+++ b/disk/part.c
@@ -104,17 +104,18 @@  typedef lbaint_t lba512_t;
 #endif

 /*
- * Overflowless variant of (block_count * mul_by / 2**div_by)
- * when div_by > mul_by
+ * Overflowless variant of (block_count * mul_by / 2**right_shift)
+ * when 2**right_shift > mul_by
  */
-static lba512_t lba512_muldiv(lba512_t block_count, lba512_t mul_by, int div_by)
+static lba512_t lba512_muldiv(lba512_t block_count, lba512_t mul_by,
+			      int right_shift)
 {
 	lba512_t bc_quot, bc_rem;

 	/* x * m / d == x / d * m + (x % d) * m / d */
-	bc_quot = block_count >> div_by;
-	bc_rem  = block_count - (bc_quot << div_by);
-	return bc_quot * mul_by + ((bc_rem * mul_by) >> div_by);
+	bc_quot = block_count >> right_shift;
+	bc_rem  = block_count - (bc_quot << right_shift);
+	return bc_quot * mul_by + ((bc_rem * mul_by) >> right_shift);
 }

 void dev_print (struct blk_desc *dev_desc)