[09/11] package/neardal: unconditionally use libedit
diff mbox series

Message ID 20191113151724.12155-10-peter@korsgaard.com
State Superseded
Headers show
Series
  • Fix license incompatibility with readline
Related show

Commit Message

Peter Korsgaard Nov. 13, 2019, 3:17 p.m. UTC
neardal is licensed under GPL-2.0, which is not license compatible with
readline (GPL-3.0+), so always use the libedit backend.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/neardal/Config.in  |  2 +-
 package/neardal/neardal.mk | 10 +---------
 2 files changed, 2 insertions(+), 10 deletions(-)

Comments

Yann E. MORIN Nov. 13, 2019, 8:58 p.m. UTC | #1
Peter, All,

On 2019-11-13 16:17 +0100, Peter Korsgaard spake thusly:
> neardal is licensed under GPL-2.0, which is not license compatible with

neardal is not GPL-2.0; it is LGPL-2.0:

    https://github.com/connectivity/neardal/blob/master/COPYING

LGPL-2.1 can be "promoted" to be GPLv3-compatible:

    https://en.wikipedia.org/wiki/License_compatibility#Compatibility_of_FOSS_licenses

But I could not find anything about LGPL-2.0...

Regards,
Yann E. MORIN.

> readline (GPL-3.0+), so always use the libedit backend.
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
> ---
>  package/neardal/Config.in  |  2 +-
>  package/neardal/neardal.mk | 10 +---------
>  2 files changed, 2 insertions(+), 10 deletions(-)
> 
> diff --git a/package/neardal/Config.in b/package/neardal/Config.in
> index c729283380..5f33ae4953 100644
> --- a/package/neardal/Config.in
> +++ b/package/neardal/Config.in
> @@ -5,7 +5,7 @@ config BR2_PACKAGE_NEARDAL
>  	depends on BR2_USE_MMU # dbus
>  	select BR2_PACKAGE_DBUS
>  	select BR2_PACKAGE_DBUS_GLIB
> -	select BR2_PACKAGE_READLINE if !BR2_PACKAGE_LIBEDIT
> +	select BR2_PACKAGE_LIBEDIT
>  	help
>  	  Provides a simple C API to exchange data with the neard NFC
>  	  manager daemon.
> diff --git a/package/neardal/neardal.mk b/package/neardal/neardal.mk
> index ea9643244e..cc82e7f20f 100644
> --- a/package/neardal/neardal.mk
> +++ b/package/neardal/neardal.mk
> @@ -10,17 +10,9 @@ NEARDAL_INSTALL_STAGING = YES
>  NEARDAL_LICENSE = GPL-2.0
>  NEARDAL_LICENSE_FILES = COPYING
>  
> -NEARDAL_DEPENDENCIES = host-pkgconf dbus dbus-glib
> +NEARDAL_DEPENDENCIES = host-pkgconf dbus dbus-glib libedit
>  NEARDAL_AUTORECONF = YES
>  
> -# Either readline or libedit are needed, and the Config.in file
> -# guarantees at least one of them is enabled
> -ifeq ($(BR2_PACKAGE_READLINE),y)
> -NEARDAL_DEPENDENCIES += readline
> -else ifeq ($(BR2_PACKAGE_LIBEDIT),y)
> -NEARDAL_DEPENDENCIES += libedit
> -endif
> -
>  define NEARDAL_INSTALL_NCL
>  	$(INSTALL) -m 0755 -D $(@D)/ncl/ncl $(TARGET_DIR)/usr/bin/ncl
>  endef
> -- 
> 2.20.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard Nov. 14, 2019, 8:23 a.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > neardal is licensed under GPL-2.0, which is not license compatible with
 > readline (GPL-3.0+), so always use the libedit backend.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Strangely enough I have not received your reply, neither directly or
through the list, even though I see it in the archive - I guess the mail
issues aren't over yet.

Anyway, you are right - Our license tag is apparently wrong, and I
didn't verify it.

Still, given the unclarity about LGPL-2.0 vs GPL-3.0 - And the fact that
readline is only used in the ncl utility and not in the library (and
using LGPL for an application), so I would prefer to err on the side of
caution and unconditionally use libedit.

I will send an updated series changing _LICENSE and adjusting the
commit message of this patch to refer to LGPL instead.

Thanks.

Patch
diff mbox series

diff --git a/package/neardal/Config.in b/package/neardal/Config.in
index c729283380..5f33ae4953 100644
--- a/package/neardal/Config.in
+++ b/package/neardal/Config.in
@@ -5,7 +5,7 @@  config BR2_PACKAGE_NEARDAL
 	depends on BR2_USE_MMU # dbus
 	select BR2_PACKAGE_DBUS
 	select BR2_PACKAGE_DBUS_GLIB
-	select BR2_PACKAGE_READLINE if !BR2_PACKAGE_LIBEDIT
+	select BR2_PACKAGE_LIBEDIT
 	help
 	  Provides a simple C API to exchange data with the neard NFC
 	  manager daemon.
diff --git a/package/neardal/neardal.mk b/package/neardal/neardal.mk
index ea9643244e..cc82e7f20f 100644
--- a/package/neardal/neardal.mk
+++ b/package/neardal/neardal.mk
@@ -10,17 +10,9 @@  NEARDAL_INSTALL_STAGING = YES
 NEARDAL_LICENSE = GPL-2.0
 NEARDAL_LICENSE_FILES = COPYING
 
-NEARDAL_DEPENDENCIES = host-pkgconf dbus dbus-glib
+NEARDAL_DEPENDENCIES = host-pkgconf dbus dbus-glib libedit
 NEARDAL_AUTORECONF = YES
 
-# Either readline or libedit are needed, and the Config.in file
-# guarantees at least one of them is enabled
-ifeq ($(BR2_PACKAGE_READLINE),y)
-NEARDAL_DEPENDENCIES += readline
-else ifeq ($(BR2_PACKAGE_LIBEDIT),y)
-NEARDAL_DEPENDENCIES += libedit
-endif
-
 define NEARDAL_INSTALL_NCL
 	$(INSTALL) -m 0755 -D $(@D)/ncl/ncl $(TARGET_DIR)/usr/bin/ncl
 endef