[08/11] package/mariadb: use bundled GPL-2.0+ libreadline
diff mbox series

Message ID 20191113151724.12155-9-peter@korsgaard.com
State Accepted
Headers show
Series
  • Fix license incompatibility with readline
Related show

Commit Message

Peter Korsgaard Nov. 13, 2019, 3:17 p.m. UTC
mariadb is licensed under GPL-2.0, which is not license compatible with
modern readline (GPL-3.0+), so instead use the bundled older version
(GPL-2.0+ licensed) of readline instead.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/mariadb/mariadb.mk | 6 ++++--
 package/mysql/Config.in    | 1 -
 2 files changed, 4 insertions(+), 3 deletions(-)

Comments

Yann E. MORIN Nov. 13, 2019, 9 p.m. UTC | #1
Peter, All,

On 2019-11-13 16:17 +0100, Peter Korsgaard spake thusly:
> mariadb is licensed under GPL-2.0, which is not license compatible with
> modern readline (GPL-3.0+), so instead use the bundled older version
> (GPL-2.0+ licensed) of readline instead.
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/mariadb/mariadb.mk | 6 ++++--
>  package/mysql/Config.in    | 1 -
>  2 files changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/package/mariadb/mariadb.mk b/package/mariadb/mariadb.mk
> index 6a18db48ab..82e3c16daf 100644
> --- a/package/mariadb/mariadb.mk
> +++ b/package/mariadb/mariadb.mk
> @@ -19,8 +19,10 @@ MARIADB_DEPENDENCIES = \
>  	openssl \
>  	zlib \
>  	libaio \
> -	libxml2 \
> -	readline
> +	libxml2
> +
> +# use bundled GPL-2.0+ licensed readline as package/readline is GPL-3.0+
> +MARIADB_CONF_OPTS += -DWITH_READLINE=ON
>  
>  # We won't need unit tests
>  MARIADB_CONF_OPTS += -DWITH_UNIT_TESTS=0
> diff --git a/package/mysql/Config.in b/package/mysql/Config.in
> index 30a82cc91b..d3f9f1f00d 100644
> --- a/package/mysql/Config.in
> +++ b/package/mysql/Config.in
> @@ -22,7 +22,6 @@ config BR2_PACKAGE_MARIADB
>  	select BR2_PACKAGE_LIBXML2
>  	select BR2_PACKAGE_NCURSES
>  	select BR2_PACKAGE_OPENSSL
> -	select BR2_PACKAGE_READLINE
>  	select BR2_PACKAGE_HAS_MYSQL
>  	help
>  	  MariaDB is one of the most popular database servers in the
> -- 
> 2.20.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard Nov. 19, 2019, 7:39 a.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > mariadb is licensed under GPL-2.0, which is not license compatible with
 > modern readline (GPL-3.0+), so instead use the bundled older version
 > (GPL-2.0+ licensed) of readline instead.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2019.02.x and 2019.08.x, thanks.

Patch
diff mbox series

diff --git a/package/mariadb/mariadb.mk b/package/mariadb/mariadb.mk
index 6a18db48ab..82e3c16daf 100644
--- a/package/mariadb/mariadb.mk
+++ b/package/mariadb/mariadb.mk
@@ -19,8 +19,10 @@  MARIADB_DEPENDENCIES = \
 	openssl \
 	zlib \
 	libaio \
-	libxml2 \
-	readline
+	libxml2
+
+# use bundled GPL-2.0+ licensed readline as package/readline is GPL-3.0+
+MARIADB_CONF_OPTS += -DWITH_READLINE=ON
 
 # We won't need unit tests
 MARIADB_CONF_OPTS += -DWITH_UNIT_TESTS=0
diff --git a/package/mysql/Config.in b/package/mysql/Config.in
index 30a82cc91b..d3f9f1f00d 100644
--- a/package/mysql/Config.in
+++ b/package/mysql/Config.in
@@ -22,7 +22,6 @@  config BR2_PACKAGE_MARIADB
 	select BR2_PACKAGE_LIBXML2
 	select BR2_PACKAGE_NCURSES
 	select BR2_PACKAGE_OPENSSL
-	select BR2_PACKAGE_READLINE
 	select BR2_PACKAGE_HAS_MYSQL
 	help
 	  MariaDB is one of the most popular database servers in the