diff mbox series

[2/3] mmc: sdhci-omap: drop ->get_ro() implementation

Message ID 20190115162837.5399-3-thomas.petazzoni@bootlin.com
State Changes Requested
Headers show
Series Introduce support for WP GPIO in the core SDHCI | expand

Commit Message

Thomas Petazzoni Jan. 15, 2019, 4:28 p.m. UTC
The SDHCI core is know properly checking for the state of a WP GPIO,
so there is no longer any need for the sdhci-omap code to implement
->get_ro() using mmc_gpio_get_ro().

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
Note: this patch has only been compiled tested, as I don't have the
hardware to test it.
---
 drivers/mmc/host/sdhci-omap.c | 1 -
 1 file changed, 1 deletion(-)

Comments

Thierry Reding Jan. 16, 2019, 1:27 p.m. UTC | #1
On Tue, Jan 15, 2019 at 05:28:36PM +0100, Thomas Petazzoni wrote:
> The SDHCI core is know properly checking for the state of a WP GPIO,

"know" -> "now"

> so there is no longer any need for the sdhci-omap code to implement
> ->get_ro() using mmc_gpio_get_ro().
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
> Note: this patch has only been compiled tested, as I don't have the
> hardware to test it.
> ---
>  drivers/mmc/host/sdhci-omap.c | 1 -
>  1 file changed, 1 deletion(-)

I can't runtime test this myself, but it certainly looks like this would
do the right thing because it calls the core now call the very same
function as this used to, so:

Reviewed-by: Thierry Reding <treding@nvidia.com>

Adding Tony and linux-omap for a slightly wider audience and hopefully
find someone to test this on. For reference, the whole series is here:

	https://patchwork.kernel.org/project/linux-mmc/list/?series=66905

Thierry

> 
> diff --git a/drivers/mmc/host/sdhci-omap.c b/drivers/mmc/host/sdhci-omap.c
> index d264391616f9..c2a28930086f 100644
> --- a/drivers/mmc/host/sdhci-omap.c
> +++ b/drivers/mmc/host/sdhci-omap.c
> @@ -987,7 +987,6 @@ static int sdhci_omap_probe(struct platform_device *pdev)
>  		goto err_put_sync;
>  	}
>  
> -	host->mmc_host_ops.get_ro = mmc_gpio_get_ro;
>  	host->mmc_host_ops.start_signal_voltage_switch =
>  					sdhci_omap_start_signal_voltage_switch;
>  	host->mmc_host_ops.set_ios = sdhci_omap_set_ios;
> -- 
> 2.20.1
>
Tony Lindgren Jan. 16, 2019, 3:47 p.m. UTC | #2
* Thierry Reding <thierry.reding@gmail.com> [190116 13:28]:
> On Tue, Jan 15, 2019 at 05:28:36PM +0100, Thomas Petazzoni wrote:
> > The SDHCI core is know properly checking for the state of a WP GPIO,
> 
> "know" -> "now"
> 
> > so there is no longer any need for the sdhci-omap code to implement
> > ->get_ro() using mmc_gpio_get_ro().
> > 
> > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> > ---
> > Note: this patch has only been compiled tested, as I don't have the
> > hardware to test it.
> > ---
> >  drivers/mmc/host/sdhci-omap.c | 1 -
> >  1 file changed, 1 deletion(-)
> 
> I can't runtime test this myself, but it certainly looks like this would
> do the right thing because it calls the core now call the very same
> function as this used to, so:
> 
> Reviewed-by: Thierry Reding <treding@nvidia.com>
> 
> Adding Tony and linux-omap for a slightly wider audience and hopefully
> find someone to test this on. For reference, the whole series is here:
> 
> 	https://patchwork.kernel.org/project/linux-mmc/list/?series=66905

Thanks Kishon can you please review and test?

Regards,

Tony

> > diff --git a/drivers/mmc/host/sdhci-omap.c b/drivers/mmc/host/sdhci-omap.c
> > index d264391616f9..c2a28930086f 100644
> > --- a/drivers/mmc/host/sdhci-omap.c
> > +++ b/drivers/mmc/host/sdhci-omap.c
> > @@ -987,7 +987,6 @@ static int sdhci_omap_probe(struct platform_device *pdev)
> >  		goto err_put_sync;
> >  	}
> >  
> > -	host->mmc_host_ops.get_ro = mmc_gpio_get_ro;
> >  	host->mmc_host_ops.start_signal_voltage_switch =
> >  					sdhci_omap_start_signal_voltage_switch;
> >  	host->mmc_host_ops.set_ios = sdhci_omap_set_ios;
> > -- 
> > 2.20.1
> >
Thomas Petazzoni Jan. 16, 2019, 3:58 p.m. UTC | #3
Hello,

On Wed, 16 Jan 2019 07:47:18 -0800, Tony Lindgren wrote:

> > Reviewed-by: Thierry Reding <treding@nvidia.com>
> > 
> > Adding Tony and linux-omap for a slightly wider audience and hopefully
> > find someone to test this on. For reference, the whole series is here:
> > 
> > 	https://patchwork.kernel.org/project/linux-mmc/list/?series=66905  
> 
> Thanks Kishon can you please review and test?

I think Adrian's comment that ->get_ro() should be called first in the
core code makes sense, so I'll send a v2 with this change. Perhaps
testing should be done on the v2 instead, even though I believe it
should be functionally equivalent.

Best regards,

Thomas
Faiz Abbas Jan. 18, 2019, 10:57 a.m. UTC | #4
Tony,

On 16/01/19 9:17 PM, Tony Lindgren wrote:
> * Thierry Reding <thierry.reding@gmail.com> [190116 13:28]:
>> On Tue, Jan 15, 2019 at 05:28:36PM +0100, Thomas Petazzoni wrote:
>>> The SDHCI core is know properly checking for the state of a WP GPIO,
>>
>> "know" -> "now"
>>
>>> so there is no longer any need for the sdhci-omap code to implement
>>> ->get_ro() using mmc_gpio_get_ro().
>>>
>>> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
>>> ---
>>> Note: this patch has only been compiled tested, as I don't have the
>>> hardware to test it.
>>> ---
>>>  drivers/mmc/host/sdhci-omap.c | 1 -
>>>  1 file changed, 1 deletion(-)
>>
>> I can't runtime test this myself, but it certainly looks like this would
>> do the right thing because it calls the core now call the very same
>> function as this used to, so:
>>
>> Reviewed-by: Thierry Reding <treding@nvidia.com>
>>
>> Adding Tony and linux-omap for a slightly wider audience and hopefully
>> find someone to test this on. For reference, the whole series is here:
>>
>> 	https://patchwork.kernel.org/project/linux-mmc/list/?series=66905
> 
> Thanks Kishon can you please review and test?
> 

I can help with testing once Thomas posts a v2.

Thanks,
Faiz
Tony Lindgren Jan. 18, 2019, 3:32 p.m. UTC | #5
* Faiz Abbas <faiz_abbas@ti.com> [190118 10:54]:
> Tony,
> 
> On 16/01/19 9:17 PM, Tony Lindgren wrote:
> > * Thierry Reding <thierry.reding@gmail.com> [190116 13:28]:
> >> On Tue, Jan 15, 2019 at 05:28:36PM +0100, Thomas Petazzoni wrote:
> >>> The SDHCI core is know properly checking for the state of a WP GPIO,
> >>
> >> "know" -> "now"
> >>
> >>> so there is no longer any need for the sdhci-omap code to implement
> >>> ->get_ro() using mmc_gpio_get_ro().
> >>>
> >>> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> >>> ---
> >>> Note: this patch has only been compiled tested, as I don't have the
> >>> hardware to test it.
> >>> ---
> >>>  drivers/mmc/host/sdhci-omap.c | 1 -
> >>>  1 file changed, 1 deletion(-)
> >>
> >> I can't runtime test this myself, but it certainly looks like this would
> >> do the right thing because it calls the core now call the very same
> >> function as this used to, so:
> >>
> >> Reviewed-by: Thierry Reding <treding@nvidia.com>
> >>
> >> Adding Tony and linux-omap for a slightly wider audience and hopefully
> >> find someone to test this on. For reference, the whole series is here:
> >>
> >> 	https://patchwork.kernel.org/project/linux-mmc/list/?series=66905
> > 
> > Thanks Kishon can you please review and test?
> > 
> 
> I can help with testing once Thomas posts a v2.

OK great thanks!

Tony
diff mbox series

Patch

diff --git a/drivers/mmc/host/sdhci-omap.c b/drivers/mmc/host/sdhci-omap.c
index d264391616f9..c2a28930086f 100644
--- a/drivers/mmc/host/sdhci-omap.c
+++ b/drivers/mmc/host/sdhci-omap.c
@@ -987,7 +987,6 @@  static int sdhci_omap_probe(struct platform_device *pdev)
 		goto err_put_sync;
 	}
 
-	host->mmc_host_ops.get_ro = mmc_gpio_get_ro;
 	host->mmc_host_ops.start_signal_voltage_switch =
 					sdhci_omap_start_signal_voltage_switch;
 	host->mmc_host_ops.set_ios = sdhci_omap_set_ios;