mbox series

[net-next,0/2] nfp: bpf: rename ALU_OP_NEG and support BPF_NEG

Message ID 20171101173825.7008-1-jakub.kicinski@netronome.com
Headers show
Series nfp: bpf: rename ALU_OP_NEG and support BPF_NEG | expand

Message

Jakub Kicinski Nov. 1, 2017, 5:38 p.m. UTC
Jiong says:

  Compilers are starting to use BPF_NEG, for example LLVM. However, NFP
does not support JITing it. This patch set adds this. Unit test is added
as well.

  Meanwhile, the current NFP_ALU_NEG is actually doing bitwise NOT (one's
complement) operation, so the name is misleading. This patch set corrects
this.


Jiong Wang (2):
  nfp: bpf: rename ALU_OP_NEG to ALU_OP_NOT
  nfp: bpf: support [BPF_ALU | BPF_ALU64] | BPF_NEG

 drivers/net/ethernet/netronome/nfp/bpf/jit.c | 26 +++++++++++++++++++++++++-
 drivers/net/ethernet/netronome/nfp/nfp_asm.h |  2 +-
 2 files changed, 26 insertions(+), 2 deletions(-)

Comments

David Miller Nov. 2, 2017, 7:47 a.m. UTC | #1
From: Jakub Kicinski <jakub.kicinski@netronome.com>
Date: Wed,  1 Nov 2017 10:38:23 -0700

> Jiong says:
> 
>   Compilers are starting to use BPF_NEG, for example LLVM. However, NFP
> does not support JITing it. This patch set adds this. Unit test is added
> as well.
> 
>   Meanwhile, the current NFP_ALU_NEG is actually doing bitwise NOT (one's
> complement) operation, so the name is misleading. This patch set corrects
> this.

Series applied, thanks.