diff mbox

[U-Boot,V2,08/11] mtd: nand: supress 'unknown NAND' warning if no nand is found

Message ID 1283441611.2011.113.camel@quadra
State Superseded
Headers show

Commit Message

Steve Sakoman Sept. 2, 2010, 3:33 p.m. UTC
This printk was added recently and results in ugly output on systems
with no NAND:

NAND:  nand_get_flash_type: unknown NAND device: Manufacturer ID: 0x00, Chip ID: 0x00 0 MiB

instead of:

NAND:  0 MiB

Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 drivers/mtd/nand/nand_base.c |    7 +++++--
 1 files changed, 5 insertions(+), 2 deletions(-)

Comments

Sandeep Paulraj Sept. 4, 2010, 5:38 p.m. UTC | #1
> 
> This printk was added recently and results in ugly output on systems
> with no NAND:
> 
> NAND:  nand_get_flash_type: unknown NAND device: Manufacturer ID: 0x00,
> Chip ID: 0x00 0 MiB
> 
> instead of:
> 
> NAND:  0 MiB
> 
> Signed-off-by: Steve Sakoman <steve@sakoman.com>

Steve,

A proper patch would be very much appreciated instead of an updated patch within an e-mail chain.

Scott,

Is it ok if I add this to my tree?

Its part of a 11 patch series and a total of some 20 patches submitted by Steve 


> ---
>  drivers/mtd/nand/nand_base.c |    7 +++++--
>  1 files changed, 5 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
> index ed1c9c9..b2400dd 100644
> --- a/drivers/mtd/nand/nand_base.c
> +++ b/drivers/mtd/nand/nand_base.c
> @@ -2653,8 +2653,11 @@ static struct nand_flash_dev
> *nand_get_flash_type(struct mtd_info *mtd,
>  	}
> 
>  	if (!type) {
> -		printk(KERN_INFO "%s: unknown NAND device: Manufacturer ID:"
> -		       " 0x%02x, Chip ID: 0x%02x\n", __func__,
> +		/* supress warning if there is no nand */
> +		if ((*maf_id != 0x00) && (*maf_id != 0xff) &&
> +		    (dev_id  != 0x00) && (dev_id  != 0xff))
> +			printk(KERN_INFO "%s: unknown NAND device: "
> +		       "Manufacturer ID: 0x%02x, Chip ID: 0x%02x\n", __func__,
>  		       *maf_id, dev_id);
>  		return ERR_PTR(-ENODEV);
>  	}
> --
> 1.7.0.4


Regards,
Sandeep
Steve Sakoman Sept. 4, 2010, 8:16 p.m. UTC | #2
On Sat, 2010-09-04 at 12:38 -0500, Paulraj, Sandeep wrote:
> 
> > 
> > This printk was added recently and results in ugly output on systems
> > with no NAND:
> > 
> > NAND:  nand_get_flash_type: unknown NAND device: Manufacturer ID: 0x00,
> > Chip ID: 0x00 0 MiB
> > 
> > instead of:
> > 
> > NAND:  0 MiB
> > 
> > Signed-off-by: Steve Sakoman <steve@sakoman.com>
> 
> Steve,
> 
> A proper patch would be very much appreciated instead of an updated patch within an e-mail chain.
> 

Sandeep,

I've updated my omap4-next-upstream branch with the new version of this
patch series (it also contains the previous series):

http://www.sakoman.com/cgi-bin/gitweb.cgi?p=u-boot.git;a=shortlog;h=refs/heads/omap4-next-upstream

Would you like me to resubmit the entire series as a v2?  The subject
patch is the only one that has changed.

Steve
Sergei Shtylyov Sept. 5, 2010, 10:59 a.m. UTC | #3
Hello.

On 02-09-2010 19:33, Steve Sakoman wrote:

> This printk was added recently and results in ugly output on systems
> with no NAND:

> NAND:  nand_get_flash_type: unknown NAND device: Manufacturer ID: 0x00, Chip ID: 0x00 0 MiB

> instead of:

> NAND:  0 MiB

> Signed-off-by: Steve Sakoman<steve@sakoman.com>
> ---
>   drivers/mtd/nand/nand_base.c |    7 +++++--
>   1 files changed, 5 insertions(+), 2 deletions(-)

> diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
> index ed1c9c9..b2400dd 100644
> --- a/drivers/mtd/nand/nand_base.c
> +++ b/drivers/mtd/nand/nand_base.c
> @@ -2653,8 +2653,11 @@ static struct nand_flash_dev *nand_get_flash_type(struct mtd_info *mtd,
>   	}
>
>   	if (!type) {
> -		printk(KERN_INFO "%s: unknown NAND device: Manufacturer ID:"
> -		       " 0x%02x, Chip ID: 0x%02x\n", __func__,
> +		/* supress warning if there is no nand */
> +		if ((*maf_id != 0x00)&&  (*maf_id != 0xff)&&
> +		    (dev_id  != 0x00)&&  (dev_id  != 0xff))

    Parens around != are not necessary.

WBR, Sergei
Steve Sakoman Sept. 5, 2010, 9:37 p.m. UTC | #4
On Sun, Sep 5, 2010 at 3:59 AM, Sergei Shtylyov <sshtylyov@mvista.com> wrote:
> Hello.
>
> On 02-09-2010 19:33, Steve Sakoman wrote:
>
>> This printk was added recently and results in ugly output on systems
>> with no NAND:
>
>> NAND:  nand_get_flash_type: unknown NAND device: Manufacturer ID: 0x00, Chip ID: 0x00 0 MiB
>
>> instead of:
>
>> NAND:  0 MiB
>
>> Signed-off-by: Steve Sakoman<steve@sakoman.com>
>> ---
>>   drivers/mtd/nand/nand_base.c |    7 +++++--
>>   1 files changed, 5 insertions(+), 2 deletions(-)
>
>> diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
>> index ed1c9c9..b2400dd 100644
>> --- a/drivers/mtd/nand/nand_base.c
>> +++ b/drivers/mtd/nand/nand_base.c
>> @@ -2653,8 +2653,11 @@ static struct nand_flash_dev *nand_get_flash_type(struct mtd_info *mtd,
>>       }
>>
>>       if (!type) {
>> -             printk(KERN_INFO "%s: unknown NAND device: Manufacturer ID:"
>> -                    " 0x%02x, Chip ID: 0x%02x\n", __func__,
>> +             /* supress warning if there is no nand */
>> +             if ((*maf_id != 0x00) &&  (*maf_id != 0xff) &&
>> +                 (dev_id  != 0x00) &&  (dev_id  != 0xff))
>
>    Parens around != are not necessary.

Understood -- I just think it is easier to read/understand with
parens.  If the general consensus is that I should remove them I am
happy to do so.

Steve
Scott Wood Sept. 7, 2010, 5:37 p.m. UTC | #5
On Sat, 4 Sep 2010 12:38:34 -0500
"Paulraj, Sandeep" <s-paulraj@ti.com> wrote:

> Scott,
> 
> Is it ok if I add this to my tree?

Yes, once the whitespace is fixed.

> 
> Its part of a 11 patch series and a total of some 20 patches submitted by Steve 
> 
> 
> > ---
> >  drivers/mtd/nand/nand_base.c |    7 +++++--
> >  1 files changed, 5 insertions(+), 2 deletions(-)
> > 
> > diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
> > index ed1c9c9..b2400dd 100644
> > --- a/drivers/mtd/nand/nand_base.c
> > +++ b/drivers/mtd/nand/nand_base.c
> > @@ -2653,8 +2653,11 @@ static struct nand_flash_dev
> > *nand_get_flash_type(struct mtd_info *mtd,
> >  	}
> > 
> >  	if (!type) {
> > -		printk(KERN_INFO "%s: unknown NAND device: Manufacturer ID:"
> > -		       " 0x%02x, Chip ID: 0x%02x\n", __func__,
> > +		/* supress warning if there is no nand */
> > +		if ((*maf_id != 0x00) && (*maf_id != 0xff) &&
> > +		    (dev_id  != 0x00) && (dev_id  != 0xff))
> > +			printk(KERN_INFO "%s: unknown NAND device: "
> > +		       "Manufacturer ID: 0x%02x, Chip ID: 0x%02x\n", __func__,
> >  		       *maf_id, dev_id);
> >  		return ERR_PTR(-ENODEV);

printk's continuation lines need one more tab.

-Scott
Scott Wood Sept. 7, 2010, 5:37 p.m. UTC | #6
On Sun, 5 Sep 2010 14:37:13 -0700
Steve Sakoman <sakoman@gmail.com> wrote:

> On Sun, Sep 5, 2010 at 3:59 AM, Sergei Shtylyov <sshtylyov@mvista.com> wrote:
> > On 02-09-2010 19:33, Steve Sakoman wrote:
> >
> >> diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
> >> index ed1c9c9..b2400dd 100644
> >> --- a/drivers/mtd/nand/nand_base.c
> >> +++ b/drivers/mtd/nand/nand_base.c
> >> @@ -2653,8 +2653,11 @@ static struct nand_flash_dev *nand_get_flash_type(struct mtd_info *mtd,
> >>       }
> >>
> >>       if (!type) {
> >> -             printk(KERN_INFO "%s: unknown NAND device: Manufacturer ID:"
> >> -                    " 0x%02x, Chip ID: 0x%02x\n", __func__,
> >> +             /* supress warning if there is no nand */
> >> +             if ((*maf_id != 0x00) &&  (*maf_id != 0xff) &&
> >> +                 (dev_id  != 0x00) &&  (dev_id  != 0xff))
> >
> >    Parens around != are not necessary.
> 
> Understood -- I just think it is easier to read/understand with
> parens.  If the general consensus is that I should remove them I am
> happy to do so.

My vote is no parens.

-Scott
Steve Sakoman Sept. 7, 2010, 9:27 p.m. UTC | #7
On Sat, Sep 4, 2010 at 10:38 AM, Paulraj, Sandeep <s-paulraj@ti.com> wrote:
>
>
>>
>> This printk was added recently and results in ugly output on systems
>> with no NAND:
>>
>> NAND:  nand_get_flash_type: unknown NAND device: Manufacturer ID: 0x00,
>> Chip ID: 0x00 0 MiB
>>
>> instead of:
>>
>> NAND:  0 MiB
>>
>> Signed-off-by: Steve Sakoman <steve@sakoman.com>
>
> Steve,
>
> A proper patch would be very much appreciated instead of an updated patch within an e-mail chain.

OK, I will send a revised V3 patch this afternoon which includes the
paren and white space changes requested by Scott.

I've also updated the patch in my omap4-next-upstream branch:

http://www.sakoman.com/cgi-bin/gitweb.cgi?p=u-boot.git;a=commitdiff;h=4700ca9b657b77a29b7444cfe7514dd783773f53

Steve
diff mbox

Patch

diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
index ed1c9c9..b2400dd 100644
--- a/drivers/mtd/nand/nand_base.c
+++ b/drivers/mtd/nand/nand_base.c
@@ -2653,8 +2653,11 @@  static struct nand_flash_dev *nand_get_flash_type(struct mtd_info *mtd,
 	}
 
 	if (!type) {
-		printk(KERN_INFO "%s: unknown NAND device: Manufacturer ID:"
-		       " 0x%02x, Chip ID: 0x%02x\n", __func__,
+		/* supress warning if there is no nand */
+		if ((*maf_id != 0x00) && (*maf_id != 0xff) &&
+		    (dev_id  != 0x00) && (dev_id  != 0xff))
+			printk(KERN_INFO "%s: unknown NAND device: "
+		       "Manufacturer ID: 0x%02x, Chip ID: 0x%02x\n", __func__,
 		       *maf_id, dev_id);
 		return ERR_PTR(-ENODEV);
 	}