mbox series

[SRU,Xenial,0/2] alsa/hdmi: the hdmi audio stops working from Ubuntu-4.4.0-155.182

Message ID 20200915035132.7731-1-hui.wang@canonical.com
Headers show
Series alsa/hdmi: the hdmi audio stops working from Ubuntu-4.4.0-155.182 | expand

Message

Hui Wang Sept. 15, 2020, 3:51 a.m. UTC
BugLink: https://bugs.launchpad.net/bugs/1895603

[Impact]
We had a Dell machine, this machine was enabled with ubuntu 4.4
kernel before, but recently the hdmi audio on this machine stopped
working with the latest ubuntu 4.4. kernel. The system can't detect
its plugging and can't output sound to it anymore.

[Fix]
This is because we backported a patch from stable updates, and that
patch is for v5.2 kernel, if we backported it to 4.4 kernel, we need
to do some change, and also we need to backport one more patch from
stabe kernel.

[Test Case]
Connect a monitor to the machine and boot up, after booting up, we
could see the hdmi audio is found, and play sound to the hdmi audio,
we could hear the sound from monitor.


[Regression Risk]
It is possible to make the hdmi audio fail to work after applying this
patchset, like the hdmi audio can't be detected after plugging a hdmi
monitor. But this possibility is very low, we tested the patchset on
many dell and lenovo machines, all worked well.

Hui Wang (2):
  ALSA: hda/hdmi - Read the pin sense from register when repolling
  UBUNTU: SAUNCE: ALSA: hda/hdmi - Check pin_eld->monitor_present

 sound/pci/hda/patch_hdmi.c | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Kleber Souza Sept. 15, 2020, 10:03 a.m. UTC | #1
On 15.09.20 05:51, Hui Wang wrote:
> BugLink: https://bugs.launchpad.net/bugs/1895603
> 
> [Impact]
> We had a Dell machine, this machine was enabled with ubuntu 4.4
> kernel before, but recently the hdmi audio on this machine stopped
> working with the latest ubuntu 4.4. kernel. The system can't detect
> its plugging and can't output sound to it anymore.
> 
> [Fix]
> This is because we backported a patch from stable updates, and that
> patch is for v5.2 kernel, if we backported it to 4.4 kernel, we need
> to do some change, and also we need to backport one more patch from
> stabe kernel.
> 
> [Test Case]
> Connect a monitor to the machine and boot up, after booting up, we
> could see the hdmi audio is found, and play sound to the hdmi audio,
> we could hear the sound from monitor.
> 
> 
> [Regression Risk]
> It is possible to make the hdmi audio fail to work after applying this
> patchset, like the hdmi audio can't be detected after plugging a hdmi
> monitor. But this possibility is very low, we tested the patchset on
> many dell and lenovo machines, all worked well.
> 
> Hui Wang (2):
>   ALSA: hda/hdmi - Read the pin sense from register when repolling
>   UBUNTU: SAUNCE: ALSA: hda/hdmi - Check pin_eld->monitor_present
> 
>  sound/pci/hda/patch_hdmi.c | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)
> 

Hi Hui,

Have you sent this fixup for the linux-stable 4.4.y?


There's a typo on patch 2/2, it should be "SAUCE". This can be
fixed when applying.

Acked-by: Kleber Sacilotto de Souza <kleber.souza@canonical.com>


Thanks.
Hui Wang Sept. 15, 2020, 10:40 a.m. UTC | #2
On 2020/9/15 下午6:03, Kleber Souza wrote:
> On 15.09.20 05:51, Hui Wang wrote:
>> BugLink: https://bugs.launchpad.net/bugs/1895603
>>
>> [Impact]
>> We had a Dell machine, this machine was enabled with ubuntu 4.4
>> kernel before, but recently the hdmi audio on this machine stopped
>> working with the latest ubuntu 4.4. kernel. The system can't detect
>> its plugging and can't output sound to it anymore.
>>
>> [Fix]
>> This is because we backported a patch from stable updates, and that
>> patch is for v5.2 kernel, if we backported it to 4.4 kernel, we need
>> to do some change, and also we need to backport one more patch from
>> stabe kernel.
>>
>> [Test Case]
>> Connect a monitor to the machine and boot up, after booting up, we
>> could see the hdmi audio is found, and play sound to the hdmi audio,
>> we could hear the sound from monitor.
>>
>>
>> [Regression Risk]
>> It is possible to make the hdmi audio fail to work after applying this
>> patchset, like the hdmi audio can't be detected after plugging a hdmi
>> monitor. But this possibility is very low, we tested the patchset on
>> many dell and lenovo machines, all worked well.
>>
>> Hui Wang (2):
>>    ALSA: hda/hdmi - Read the pin sense from register when repolling
>>    UBUNTU: SAUNCE: ALSA: hda/hdmi - Check pin_eld->monitor_present
>>
>>   sound/pci/hda/patch_hdmi.c | 8 +++++++-
>>   1 file changed, 7 insertions(+), 1 deletion(-)
>>
> Hi Hui,
>
> Have you sent this fixup for the linux-stable 4.4.y?
OK, I will check linux-stable 4.4.y and send the patchset to it.
>
>
> There's a typo on patch 2/2, it should be "SAUCE". This can be
> fixed when applying.
Thanks.
> Acked-by: Kleber Sacilotto de Souza <kleber.souza@canonical.com>
>
>
> Thanks.
Stefan Bader Sept. 16, 2020, 3:05 p.m. UTC | #3
On 15.09.20 05:51, Hui Wang wrote:
> BugLink: https://bugs.launchpad.net/bugs/1895603
> 
> [Impact]
> We had a Dell machine, this machine was enabled with ubuntu 4.4
> kernel before, but recently the hdmi audio on this machine stopped
> working with the latest ubuntu 4.4. kernel. The system can't detect
> its plugging and can't output sound to it anymore.
> 
> [Fix]
> This is because we backported a patch from stable updates, and that
> patch is for v5.2 kernel, if we backported it to 4.4 kernel, we need
> to do some change, and also we need to backport one more patch from
> stabe kernel.
> 
> [Test Case]
> Connect a monitor to the machine and boot up, after booting up, we
> could see the hdmi audio is found, and play sound to the hdmi audio,
> we could hear the sound from monitor.
> 
> 
> [Regression Risk]
> It is possible to make the hdmi audio fail to work after applying this
> patchset, like the hdmi audio can't be detected after plugging a hdmi
> monitor. But this possibility is very low, we tested the patchset on
> many dell and lenovo machines, all worked well.
> 
> Hui Wang (2):
>   ALSA: hda/hdmi - Read the pin sense from register when repolling
>   UBUNTU: SAUNCE: ALSA: hda/hdmi - Check pin_eld->monitor_present
> 
>  sound/pci/hda/patch_hdmi.c | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)
> 
Acked-by: Stefan Bader <stefan.bader@canonical.com>
William Breathitt Gray Sept. 17, 2020, 1:56 p.m. UTC | #4
On Tue, Sep 15, 2020 at 11:51:30AM +0800, Hui Wang wrote:
> BugLink: https://bugs.launchpad.net/bugs/1895603
> 
> [Impact]
> We had a Dell machine, this machine was enabled with ubuntu 4.4
> kernel before, but recently the hdmi audio on this machine stopped
> working with the latest ubuntu 4.4. kernel. The system can't detect
> its plugging and can't output sound to it anymore.
> 
> [Fix]
> This is because we backported a patch from stable updates, and that
> patch is for v5.2 kernel, if we backported it to 4.4 kernel, we need
> to do some change, and also we need to backport one more patch from
> stabe kernel.
> 
> [Test Case]
> Connect a monitor to the machine and boot up, after booting up, we
> could see the hdmi audio is found, and play sound to the hdmi audio,
> we could hear the sound from monitor.
> 
> 
> [Regression Risk]
> It is possible to make the hdmi audio fail to work after applying this
> patchset, like the hdmi audio can't be detected after plugging a hdmi
> monitor. But this possibility is very low, we tested the patchset on
> many dell and lenovo machines, all worked well.
> 
> Hui Wang (2):
>   ALSA: hda/hdmi - Read the pin sense from register when repolling
>   UBUNTU: SAUNCE: ALSA: hda/hdmi - Check pin_eld->monitor_present
> 
>  sound/pci/hda/patch_hdmi.c | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)
> 
> -- 
> 2.17.1

Applied to Xenial with "SAUCE" typo fixed.

William Breathitt Gray