diff mbox series

[v5,3/9] dm: Rename DM_FLAG_REMOVE_WITH_PD_ON

Message ID 20210124213248.3715556-4-sjg@chromium.org
State Accepted
Commit a547fcb82880f89d9fdac218308b66e28d3e1481
Delegated to: Simon Glass
Headers show
Series [v5,1/9] smem: Don't use -EPROBE_DEFER | expand

Commit Message

Simon Glass Jan. 24, 2021, 9:32 p.m. UTC
This flag has the word 'REMOVE' in it which means it conflicts with
the DM_REMOVE flags. Rename it to DM_FLAG_LEAVE_PD_ON which seems to
indicate its purpose well enough.

Signed-off-by: Simon Glass <sjg@chromium.org>
---

(no changes since v1)

 drivers/core/device-remove.c    | 2 +-
 drivers/video/meson/meson_vpu.c | 2 +-
 drivers/watchdog/rti_wdt.c      | 2 +-
 include/dm/device.h             | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

Comments

Simon Glass Feb. 4, 2021, 1:54 a.m. UTC | #1
This flag has the word 'REMOVE' in it which means it conflicts with
the DM_REMOVE flags. Rename it to DM_FLAG_LEAVE_PD_ON which seems to
indicate its purpose well enough.

Signed-off-by: Simon Glass <sjg@chromium.org>
---

(no changes since v1)

 drivers/core/device-remove.c    | 2 +-
 drivers/video/meson/meson_vpu.c | 2 +-
 drivers/watchdog/rti_wdt.c      | 2 +-
 include/dm/device.h             | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

Applied to u-boot-dm, thanks!
diff mbox series

Patch

diff --git a/drivers/core/device-remove.c b/drivers/core/device-remove.c
index 7e8f3afb2d6..7874d53c843 100644
--- a/drivers/core/device-remove.c
+++ b/drivers/core/device-remove.c
@@ -200,7 +200,7 @@  int device_remove(struct udevice *dev, uint flags)
 
 	if (!(flags & DM_REMOVE_NO_PD) &&
 	    !(drv->flags &
-	      (DM_FLAG_DEFAULT_PD_CTRL_OFF | DM_FLAG_REMOVE_WITH_PD_ON)) &&
+	      (DM_FLAG_DEFAULT_PD_CTRL_OFF | DM_FLAG_LEAVE_PD_ON)) &&
 	    dev != gd->cur_serial_dev)
 		dev_power_domain_off(dev);
 
diff --git a/drivers/video/meson/meson_vpu.c b/drivers/video/meson/meson_vpu.c
index ca6933a6c54..558f9ba766c 100644
--- a/drivers/video/meson/meson_vpu.c
+++ b/drivers/video/meson/meson_vpu.c
@@ -212,5 +212,5 @@  U_BOOT_DRIVER(meson_vpu) = {
 	.probe = meson_vpu_probe,
 	.bind = meson_vpu_bind,
 	.priv_auto	= sizeof(struct meson_vpu_priv),
-	.flags  = DM_FLAG_PRE_RELOC | DM_FLAG_REMOVE_WITH_PD_ON,
+	.flags  = DM_FLAG_PRE_RELOC | DM_FLAG_LEAVE_PD_ON,
 };
diff --git a/drivers/watchdog/rti_wdt.c b/drivers/watchdog/rti_wdt.c
index f64a39f6579..8335b20ae84 100644
--- a/drivers/watchdog/rti_wdt.c
+++ b/drivers/watchdog/rti_wdt.c
@@ -119,5 +119,5 @@  U_BOOT_DRIVER(rti_wdt) = {
 	.ops = &rti_wdt_ops,
 	.probe = rti_wdt_probe,
 	.priv_auto	= sizeof(struct rti_wdt_priv),
-	.flags = DM_FLAG_REMOVE_WITH_PD_ON,
+	.flags = DM_FLAG_LEAVE_PD_ON,
 };
diff --git a/include/dm/device.h b/include/dm/device.h
index f5b4cd6876e..a52bbdc3a63 100644
--- a/include/dm/device.h
+++ b/include/dm/device.h
@@ -71,7 +71,7 @@  struct driver_info;
  * Device is removed without switching off its power domain. This might
  * be required, i. e. for serial console (debug) output when booting OS.
  */
-#define DM_FLAG_REMOVE_WITH_PD_ON	(1 << 13)
+#define DM_FLAG_LEAVE_PD_ON		(1 << 13)
 
 /*
  * One or multiple of these flags are passed to device_remove() so that