diff mbox series

[3/6] riscv: sifive/fu540: spl: Rename soc_spl_init()

Message ID 1596434946-12630-3-git-send-email-bmeng.cn@gmail.com
State Accepted
Commit d6a01704b06b5ffe4b90366b15525389c54582ba
Delegated to: Andes
Headers show
Series [1/6] riscv: Call spl_board_init_f() in the generic SPL board_init_f() | expand

Commit Message

Bin Meng Aug. 3, 2020, 6:09 a.m. UTC
From: Bin Meng <bin.meng@windriver.com>

spl_soc_init() seems to be a better name, as all SPL functions
names start from the spl_ prefix.

Signed-off-by: Bin Meng <bin.meng@windriver.com>
---

 arch/riscv/cpu/fu540/spl.c              | 2 +-
 arch/riscv/include/asm/arch-fu540/spl.h | 2 +-
 board/sifive/fu540/spl.c                | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

Comments

Rick Chen Aug. 6, 2020, 3:29 a.m. UTC | #1
> From: Bin Meng [mailto:bmeng.cn@gmail.com]
> Sent: Monday, August 03, 2020 2:09 PM
> To: Rick Jian-Zhi Chen(陳建志); Pragnesh Patel; U-Boot Mailing List
> Cc: Bin Meng
> Subject: [PATCH 3/6] riscv: sifive/fu540: spl: Rename soc_spl_init()
>
> From: Bin Meng <bin.meng@windriver.com>
>
> spl_soc_init() seems to be a better name, as all SPL functions names start from the spl_ prefix.
>
> Signed-off-by: Bin Meng <bin.meng@windriver.com>
> ---
>
>  arch/riscv/cpu/fu540/spl.c              | 2 +-
>  arch/riscv/include/asm/arch-fu540/spl.h | 2 +-
>  board/sifive/fu540/spl.c                | 2 +-
>  3 files changed, 3 insertions(+), 3 deletions(-)

Reviewed-by: Rick Chen <rick@andestech.com>
Pragnesh Patel Aug. 6, 2020, 7:38 a.m. UTC | #2
>-----Original Message-----
>From: Bin Meng <bmeng.cn@gmail.com>
>Sent: 03 August 2020 11:39
>To: Rick Chen <rick@andestech.com>; Pragnesh Patel
><pragnesh.patel@sifive.com>; U-Boot Mailing List <u-boot@lists.denx.de>
>Cc: Bin Meng <bin.meng@windriver.com>
>Subject: [PATCH 3/6] riscv: sifive/fu540: spl: Rename soc_spl_init()
>
>[External Email] Do not click links or attachments unless you recognize the
>sender and know the content is safe
>
>From: Bin Meng <bin.meng@windriver.com>
>
>spl_soc_init() seems to be a better name, as all SPL functions names start from
>the spl_ prefix.
>
>Signed-off-by: Bin Meng <bin.meng@windriver.com>
>---
>
> arch/riscv/cpu/fu540/spl.c              | 2 +-
> arch/riscv/include/asm/arch-fu540/spl.h | 2 +-
> board/sifive/fu540/spl.c                | 2 +-
> 3 files changed, 3 insertions(+), 3 deletions(-)
>

Reviewed-by: Pragnesh Patel <pragnesh.patel@sifive.com>
Tested-by: Pragnesh Patel <pragnesh.patel@sifive.com>
diff mbox series

Patch

diff --git a/arch/riscv/cpu/fu540/spl.c b/arch/riscv/cpu/fu540/spl.c
index a2034e9..45657b7 100644
--- a/arch/riscv/cpu/fu540/spl.c
+++ b/arch/riscv/cpu/fu540/spl.c
@@ -7,7 +7,7 @@ 
 #include <dm.h>
 #include <log.h>
 
-int soc_spl_init(void)
+int spl_soc_init(void)
 {
 	int ret;
 	struct udevice *dev;
diff --git a/arch/riscv/include/asm/arch-fu540/spl.h b/arch/riscv/include/asm/arch-fu540/spl.h
index 0c188be..4697279 100644
--- a/arch/riscv/include/asm/arch-fu540/spl.h
+++ b/arch/riscv/include/asm/arch-fu540/spl.h
@@ -9,6 +9,6 @@ 
 #ifndef _SPL_SIFIVE_H
 #define _SPL_SIFIVE_H
 
-int soc_spl_init(void);
+int spl_soc_init(void);
 
 #endif /* _SPL_SIFIVE_H */
diff --git a/board/sifive/fu540/spl.c b/board/sifive/fu540/spl.c
index 31d315d..135e118 100644
--- a/board/sifive/fu540/spl.c
+++ b/board/sifive/fu540/spl.c
@@ -21,7 +21,7 @@  int spl_board_init_f(void)
 {
 	int ret;
 
-	ret = soc_spl_init();
+	ret = spl_soc_init();
 	if (ret) {
 		debug("FU540 SPL init failed: %d\n", ret);
 		return ret;