diff mbox

[U-Boot,1/2] am33xx: add a pulldown macro to pinmux config

Message ID 1357663926-15937-1-git-send-email-larsi@wh2.tu-dresden.de
State Superseded
Delegated to: Tom Rini
Headers show

Commit Message

Lars Poeschel Jan. 8, 2013, 4:52 p.m. UTC
From: Lars Poeschel <poeschel@lemonage.de>

Signed-off-by: Lars Poeschel <poeschel@lemonage.de>
---
 arch/arm/include/asm/arch-am33xx/mux.h |    3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/arch/arm/include/asm/arch-am33xx/mux.h b/arch/arm/include/asm/arch-am33xx/mux.h
index aed6b00..460ac1c 100644
--- a/arch/arm/include/asm/arch-am33xx/mux.h
+++ b/arch/arm/include/asm/arch-am33xx/mux.h
@@ -25,7 +25,8 @@ 
 /* PAD Control Fields */
 #define SLEWCTRL	(0x1 << 6)
 #define RXACTIVE	(0x1 << 5)
-#define PULLUP_EN	(0x1 << 4) /* Pull UP Selection */
+#define PULLDOWN_EN	(0x0 << 4) /* Pull Down Selection */
+#define PULLUP_EN	(0x1 << 4) /* Pull Up Selection */
 #define PULLUDEN	(0x0 << 3) /* Pull up enabled */
 #define PULLUDDIS	(0x1 << 3) /* Pull up disabled */
 #define MODE(val)	val	/* used for Readability */