diff mbox

[U-Boot] fix out of tree building with kallsyms

Message ID 1343724293-7935-1-git-send-email-vapier@gentoo.org
State Accepted
Commit 8a156fb6e43208e77dd9a8b6265e491bc7814950
Headers show

Commit Message

Mike Frysinger July 31, 2012, 8:44 a.m. UTC
The call to SYSTEM_MAP assumes that the u-boot output is in $PWD when
it really should be in $(obj).  This fixes building out of tree.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 Makefile |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Wolfgang Denk Sept. 2, 2012, 3:41 p.m. UTC | #1
Dear Mike Frysinger,

In message <1343724293-7935-1-git-send-email-vapier@gentoo.org> you wrote:
> The call to SYSTEM_MAP assumes that the u-boot output is in $PWD when
> it really should be in $(obj).  This fixes building out of tree.
> 
> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
> ---
>  Makefile |    2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied, thanks.

Best regards,

Wolfgang Denk
diff mbox

Patch

diff --git a/Makefile b/Makefile
index eb37ea1..3605ab8 100644
--- a/Makefile
+++ b/Makefile
@@ -490,7 +490,7 @@  $(obj)u-boot:	depend \
 		$(SUBDIR_TOOLS) $(OBJS) $(LIBBOARD) $(LIBS) $(LDSCRIPT) $(obj)u-boot.lds
 		$(GEN_UBOOT)
 ifeq ($(CONFIG_KALLSYMS),y)
-		smap=`$(call SYSTEM_MAP,u-boot) | \
+		smap=`$(call SYSTEM_MAP,$(obj)u-boot) | \
 			awk '$$2 ~ /[tTwW]/ {printf $$1 $$3 "\\\\000"}'` ; \
 		$(CC) $(CFLAGS) -DSYSTEM_MAP="\"$${smap}\"" \
 			-c common/system_map.c -o $(obj)common/system_map.o