diff mbox

[U-Boot] fix unconfigured out-of-tree building of tools

Message ID 1309488980-16074-1-git-send-email-vapier@gentoo.org
State Accepted
Commit 14ce91b11530d7b5382adba19031b822f8f3c3fa
Delegated to: Wolfgang Denk
Headers show

Commit Message

Mike Frysinger July 1, 2011, 2:56 a.m. UTC
Now that the tools target requires the generated version header file, we
need to make sure that the directory it writes to exists.  In a configured
tree, this is taken care of for us.  But in an unconfigured one, the dir
does not yet exist causing a build error like so:

/bin/sh: line 5: ..../u-boot_build/include/version_autogenerated.h.tmp: No such file or directory

So create the dir for this file before we attempt to generate it.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 Makefile |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

Comments

Wolfgang Denk July 26, 2011, 2:55 p.m. UTC | #1
Dear Mike Frysinger,

In message <1309488980-16074-1-git-send-email-vapier@gentoo.org> you wrote:
> Now that the tools target requires the generated version header file, we
> need to make sure that the directory it writes to exists.  In a configured
> tree, this is taken care of for us.  But in an unconfigured one, the dir
> does not yet exist causing a build error like so:
> 
> /bin/sh: line 5: ..../u-boot_build/include/version_autogenerated.h.tmp: No such file or directory
> 
> So create the dir for this file before we attempt to generate it.
> 
> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
> ---
>  Makefile |    1 +
>  1 files changed, 1 insertions(+), 0 deletions(-)

Applied, thanks.

Best regards,

Wolfgang Denk
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 49d54a9..4ba1f4c 100644
--- a/Makefile
+++ b/Makefile
@@ -542,6 +542,7 @@  tools: $(VERSION_FILE)
 endif	# config.mk
 
 $(VERSION_FILE):
+		@mkdir -p $(dir $(VERSION_FILE))
 		@( localvers='$(shell $(TOPDIR)/tools/setlocalversion $(TOPDIR))' ; \
 		   printf '#define PLAIN_VERSION "%s%s"\n' \
 			"$(U_BOOT_VERSION)" "$${localvers}" ; \