diff mbox series

[meta-swupdate] Add additional LGPL license to swupdate recipe

Message ID 20201015121244.49198-1-sava.jakovljev@teufel.de
State New
Headers show
Series [meta-swupdate] Add additional LGPL license to swupdate recipe | expand

Commit Message

Sava Jakovljev Oct. 15, 2020, 12:12 p.m. UTC
* IPC library is licensed under LGPLv2.1.

Signed-off-by: Sava Jakovljev <sava.jakovljev@teufel.de>
---
 recipes-support/swupdate/swupdate.inc | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Stefano Babic Oct. 15, 2020, 12:29 p.m. UTC | #1
Hi Sava,

On 15.10.20 14:12, Sava Jakovljev wrote:
> * IPC library is licensed under LGPLv2.1.
> 
> Signed-off-by: Sava Jakovljev <sava.jakovljev@teufel.de>
> ---
>  recipes-support/swupdate/swupdate.inc | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/recipes-support/swupdate/swupdate.inc b/recipes-support/swupdate/swupdate.inc
> index 94da375..a6e614e 100644
> --- a/recipes-support/swupdate/swupdate.inc
> +++ b/recipes-support/swupdate/swupdate.inc
> @@ -2,7 +2,7 @@ SUMMARY="Image updater for Yocto projects"
>  DESCRIPTION = "Application for automatic software update from USB Pen"
>  SECTION="swupdate"
>  DEPENDS = "libconfig"
> -LICENSE = "GPLv2+"
> +LICENSE = "GPLv2+ & LGPLv2+"

The project itself is released under GPLv2. Of course, things are more
complicated and some parts are licensed under another license (library,
Lua scripts). The list of licenses is described in documentation at :

http://sbabic.github.io/swupdate/licensing.html

>  LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
>  
>  inherit cml1 update-rc.d systemd pkgconfig
> 

Best regards,
Stefano Babic
Sava Jakovljev Oct. 15, 2020, 1:35 p.m. UTC | #2
Hi Stefano,


Thank you for the fast response.


The reason why we are submitting this patch is because our software is linking with the IPC library, which is provided by the swupdate recipe and licensed under LGPL.

Yocto generates license manifest files, from which right now all swupdate packages are specified only as GPL-compatible.


This of course would make more sense if the IPC library would be built as a shared object.


Nevertheless, I have a feeling that declaring the recipe with two licenses is more precise to the real status, and this patch is only "useful" for license manifest files,  from which it has to be clearly visible whether a software is pure GPL or some parts are licensed differently.


Please correct me if I'm wrong on my reasoning - to summarize it, our software is using LGPL part of swupdate, thus the intention is to also declare swupdate in the license manifest file as both GPL, which it it, and also LGPL, since it is providing one library under it.


Best regards,

Sava Jakovljev
Stefano Babic Oct. 15, 2020, 2:09 p.m. UTC | #3
On 15.10.20 15:35, Sava Jakovljev wrote:
> Hi Stefano,
> 
> 
> Thank you for the fast response.
> 
> 
> The reason why we are submitting this patch is because our software is
> linking with the IPC library, which is provided by the swupdate recipe
> and licensed under LGPL.

This is perfectly legal and approved.

> 
> Yocto generates license manifest files, from which right now all
> swupdate packages are specified only as GPL-compatible. 

Well, License itself is even more. Lua Handler and Lua scripts are
released under Lua License, that is MIT.

> 
> 
> This of course would make more sense if the IPC library would be built
> as a shared object.

I do not think it is enough: a shared library is not automatically
released under a Less if not strictly specified (but it is specified in
the project).

> 
> 
> Nevertheless, I have a feeling that declaring the recipe with two
> licenses is more precise to the real status, and this patch is only
> "useful" for license manifest files,  from which it has to be clearly
> visible whether a software is pure GPL or some parts are licensed
> differently.

ok - but then you habe to add checksum for both of them.

Please also add a comment in the recipe that links to the list of all
licenses in the project
(file:///home/stefano/Projects/swupdate/doc/build/html/licensing.html)

> 
> 
> Please correct me if I'm wrong on my reasoning - to summarize it, our
> software is using LGPL part of swupdate,

Perfectly fine.

> thus the intention is to also
> declare swupdate in the license manifest file as both GPL, which it it,
> and also LGPL, since it is providing one library under it.

ok - let's do in that way.

Best regards,
Stefano Babic

> 
> 
> Best regards,
> 
> Sava Jakovljev
> 
> ------------------------------------------------------------------------
> *From:* Stefano Babic <sbabic@denx.de>
> *Sent:* Thursday, October 15, 2020 2:29:17 PM
> *To:* Sava Jakovljev; swupdate@googlegroups.com
> *Subject:* Re: [swupdate] [meta-swupdate] Add additional LGPL license to
> swupdate recipe
>  
> Hi Sava,
> 
> On 15.10.20 14:12, Sava Jakovljev wrote:
>> * IPC library is licensed under LGPLv2.1.
>> 
>> Signed-off-by: Sava Jakovljev <sava.jakovljev@teufel.de>
>> ---
>>  recipes-support/swupdate/swupdate.inc | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>> 
>> diff --git a/recipes-support/swupdate/swupdate.inc b/recipes-support/swupdate/swupdate.inc
>> index 94da375..a6e614e 100644
>> --- a/recipes-support/swupdate/swupdate.inc
>> +++ b/recipes-support/swupdate/swupdate.inc
>> @@ -2,7 +2,7 @@ SUMMARY="Image updater for Yocto projects"
>>  DESCRIPTION = "Application for automatic software update from USB Pen"
>>  SECTION="swupdate"
>>  DEPENDS = "libconfig"
>> -LICENSE = "GPLv2+"
>> +LICENSE = "GPLv2+ & LGPLv2+"
> 
> The project itself is released under GPLv2. Of course, things are more
> complicated and some parts are licensed under another license (library,
> Lua scripts). The list of licenses is described in documentation at :
> 
> http://sbabic.github.io/swupdate/licensing.html
> 
>>  LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
>>  
>>  inherit cml1 update-rc.d systemd pkgconfig
>> 
> 
> Best regards,
> Stefano Babic
> 
> -- 
> =====================================================================
> DENX Software Engineering GmbH,      Managing Director: Wolfgang Denk
> HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
> Phone: +49-8142-66989-53 Fax: +49-8142-66989-80 Email: sbabic@denx.de
> =====================================================================
> 
> -- 
> You received this message because you are subscribed to the Google
> Groups "swupdate" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to swupdate+unsubscribe@googlegroups.com
> <mailto:swupdate+unsubscribe@googlegroups.com>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/swupdate/81ea1cc90ff34b908ac5dca43cd16ff7%40teufel.de
> <https://groups.google.com/d/msgid/swupdate/81ea1cc90ff34b908ac5dca43cd16ff7%40teufel.de?utm_medium=email&utm_source=footer>.
Sava Jakovljev Oct. 15, 2020, 2:16 p.m. UTC | #4
Hi Stefano - cool, thanks!


I'll follow your suggestions and add required changes. I overlooked the fact that lua_swupdate.so.0.1 is also licensed under LGPL.


Thank you again.

Best regards,

Sava Jakovljev
diff mbox series

Patch

diff --git a/recipes-support/swupdate/swupdate.inc b/recipes-support/swupdate/swupdate.inc
index 94da375..a6e614e 100644
--- a/recipes-support/swupdate/swupdate.inc
+++ b/recipes-support/swupdate/swupdate.inc
@@ -2,7 +2,7 @@  SUMMARY="Image updater for Yocto projects"
 DESCRIPTION = "Application for automatic software update from USB Pen"
 SECTION="swupdate"
 DEPENDS = "libconfig"
-LICENSE = "GPLv2+"
+LICENSE = "GPLv2+ & LGPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
 
 inherit cml1 update-rc.d systemd pkgconfig